summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-08-06 04:01:21 +0000
committerMike Frysinger <vapier@gentoo.org>2012-08-06 04:01:21 +0000
commit1947635d6d74e005b47c2613f9326d1962ab6d67 (patch)
tree7384771a03fcf9c3dc702057e93d75b4e62df0cf /sys-process
parentFixing jython for 2.1.0 too (diff)
downloadgentoo-2-1947635d6d74e005b47c2613f9326d1962ab6d67.tar.gz
gentoo-2-1947635d6d74e005b47c2613f9326d1962ab6d67.tar.bz2
gentoo-2-1947635d6d74e005b47c2613f9326d1962ab6d67.zip
Fix building with glibc-2.16.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/acct/ChangeLog6
-rw-r--r--sys-process/acct/acct-6.5.5-r2.ebuild3
-rw-r--r--sys-process/acct/files/acct-6.5.5-no-gets.patch22
3 files changed, 29 insertions, 2 deletions
diff --git a/sys-process/acct/ChangeLog b/sys-process/acct/ChangeLog
index cf19cf4f1e42..65e2e7ab111b 100644
--- a/sys-process/acct/ChangeLog
+++ b/sys-process/acct/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/acct
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/ChangeLog,v 1.59 2012/07/28 16:19:01 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/ChangeLog,v 1.60 2012/08/06 04:01:21 vapier Exp $
+
+ 06 Aug 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/acct-6.5.5-no-gets.patch, acct-6.5.5-r2.ebuild:
+ Fix building with glibc-2.16.
28 Jul 2012; Anthony G. Basile <blueness@gentoo.org> acct-6.5.5-r2.ebuild:
Keyword ~mips
diff --git a/sys-process/acct/acct-6.5.5-r2.ebuild b/sys-process/acct/acct-6.5.5-r2.ebuild
index 5dd4a6154878..2028236480b8 100644
--- a/sys-process/acct/acct-6.5.5-r2.ebuild
+++ b/sys-process/acct/acct-6.5.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/acct-6.5.5-r2.ebuild,v 1.7 2012/07/28 16:19:01 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/acct/acct-6.5.5-r2.ebuild,v 1.8 2012/08/06 04:01:21 vapier Exp $
EAPI="2"
@@ -17,6 +17,7 @@ IUSE=""
src_prepare() {
epatch "${FILESDIR}"/${PN}-6.5.5-cross-compile.patch
+ epatch "${FILESDIR}"/${PN}-6.5.5-no-gets.patch
eautoreconf
}
diff --git a/sys-process/acct/files/acct-6.5.5-no-gets.patch b/sys-process/acct/files/acct-6.5.5-no-gets.patch
new file mode 100644
index 000000000000..3478b66de9db
--- /dev/null
+++ b/sys-process/acct/files/acct-6.5.5-no-gets.patch
@@ -0,0 +1,22 @@
+hack until acct pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@