summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-10 19:24:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-10 19:24:24 +0000
commit0789733c55ba909c078c1182530bf64131d6fed7 (patch)
tree5a75d6ff5ed5037c9db08c435fe9998a41f9b29c /sys-process
parentDrop old. (diff)
downloadgentoo-2-0789733c55ba909c078c1182530bf64131d6fed7.tar.gz
gentoo-2-0789733c55ba909c078c1182530bf64131d6fed7.tar.bz2
gentoo-2-0789733c55ba909c078c1182530bf64131d6fed7.zip
Always enable cgroup support for kernel_linux and prevent valgrind detection (we definately don't want to run valgrind from Portage because it's too unreliable)
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/ChangeLog7
-rw-r--r--sys-process/htop/htop-0.9.ebuild14
2 files changed, 14 insertions, 7 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index 7117ad7a7348..6ad4aaf681c0 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/htop
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.87 2011/01/10 17:15:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.88 2011/01/10 19:24:24 ssuominen Exp $
+
+ 10 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> htop-0.9.ebuild:
+ Always enable cgroup support for kernel_linux and prevent valgrind detection
+ (we definately don't want to run valgrind from Portage because it's too
+ unreliable)
10 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> htop-0.9.ebuild:
The bundled (and obsolete) plpa library is licensed BSD.
diff --git a/sys-process/htop/htop-0.9.ebuild b/sys-process/htop/htop-0.9.ebuild
index dd1b91a2d3d4..a98139e27a6b 100644
--- a/sys-process/htop/htop-0.9.ebuild
+++ b/sys-process/htop/htop-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.9.ebuild,v 1.2 2011/01/10 17:15:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.9.ebuild,v 1.3 2011/01/10 19:24:24 ssuominen Exp $
EAPI=3
inherit eutils flag-o-matic multilib
@@ -12,9 +12,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-IUSE="cgroup debug openvz unicode vserver"
+IUSE="debug elibc_FreeBSD kernel_linux openvz unicode vserver"
-DEPEND="sys-libs/ncurses[unicode?]"
+RDEPEND="sys-libs/ncurses[unicode?]"
+DEPEND="${RDEPEND}"
pkg_setup() {
if use elibc_FreeBSD && ! [[ -f ${ROOT}/proc/stat && -f ${ROOT}/proc/meminfo ]]; then
@@ -38,14 +39,15 @@ src_prepare() {
}
src_configure() {
- useq debug && append-flags -DDEBUG
+ use debug && append-flags -DDEBUG
econf \
$(use_enable openvz) \
- $(use_enable cgroup) \
+ $(use_enable kernel_linux cgroup) \
$(use_enable vserver) \
$(use_enable unicode) \
- --enable-taskstats
+ --enable-taskstats \
+ --without-valgrind
}
src_install() {