summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-31 03:50:27 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-31 03:50:27 +0000
commit8086ac7f9a71d53da486f7582a39db37ba878a2a (patch)
tree96ed23c9e1408aedb1efcc0b9eda8ca58a824bdc /sys-process/iotop
parentClean up style a bit. (diff)
downloadgentoo-2-8086ac7f9a71d53da486f7582a39db37ba878a2a.tar.gz
gentoo-2-8086ac7f9a71d53da486f7582a39db37ba878a2a.tar.bz2
gentoo-2-8086ac7f9a71d53da486f7582a39db37ba878a2a.zip
Version bump.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/iotop')
-rw-r--r--sys-process/iotop/ChangeLog7
-rw-r--r--sys-process/iotop/iotop-0.4.4.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-process/iotop/ChangeLog b/sys-process/iotop/ChangeLog
index 51c264e82c6e..f1915f49a17b 100644
--- a/sys-process/iotop/ChangeLog
+++ b/sys-process/iotop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/iotop
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/ChangeLog,v 1.54 2011/06/23 15:20:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/ChangeLog,v 1.55 2011/10/31 03:50:27 radhermit Exp $
+
+*iotop-0.4.4 (31 Oct 2011)
+
+ 31 Oct 2011; Tim Harder <radhermit@gentoo.org> +iotop-0.4.4.ebuild:
+ Version bump.
23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -iotop-0.4.1.ebuild,
-iotop-0.4.2.ebuild:
diff --git a/sys-process/iotop/iotop-0.4.4.ebuild b/sys-process/iotop/iotop-0.4.4.ebuild
new file mode 100644
index 000000000000..2e8145f1f6aa
--- /dev/null
+++ b/sys-process/iotop/iotop-0.4.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.4.4.ebuild,v 1.1 2011/10/31 03:50:27 radhermit Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="ncurses"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils linux-info
+
+DESCRIPTION="Iotop has a top-like UI used to show which process is using the I/O"
+HOMEPAGE="http://guichaz.free.fr/iotop/"
+SRC_URI="http://guichaz.free.fr/iotop//files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+DOCS="NEWS README THANKS"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+ doman iotop.1 || die "doman failed"
+}