summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-11-07 03:39:26 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-11-07 03:39:26 +0000
commitf755ebcb32cb8d9119c555c41e06d082d79694c7 (patch)
treee4cde38fc5bfa0015029640b6dc5a7ed7f5cba62 /sys-power
parentOld. (diff)
downloadgentoo-2-f755ebcb32cb8d9119c555c41e06d082d79694c7.tar.gz
gentoo-2-f755ebcb32cb8d9119c555c41e06d082d79694c7.tar.bz2
gentoo-2-f755ebcb32cb8d9119c555c41e06d082d79694c7.zip
Version bump, bug #347019.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/iasl/ChangeLog10
-rw-r--r--sys-power/iasl/files/iasl-20110922-as-needed.patch16
-rw-r--r--sys-power/iasl/files/iasl-20110922-locale.patch16
-rw-r--r--sys-power/iasl/files/iasl-20110922-parallelmake-001.patch54
-rw-r--r--sys-power/iasl/files/iasl-20110922-parallelmake-002.patch101
-rw-r--r--sys-power/iasl/iasl-20110922.ebuild133
6 files changed, 329 insertions, 1 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index 92f5d8f13ffb..2d374d49adef 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-power/iasl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.33 2011/09/30 16:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.34 2011/11/07 03:39:26 robbat2 Exp $
+
+*iasl-20110922 (07 Nov 2011)
+
+ 07 Nov 2011; Robin H. Johnson <robbat2@gentoo.org> +iasl-20110922.ebuild,
+ +files/iasl-20110922-as-needed.patch, +files/iasl-20110922-locale.patch,
+ +files/iasl-20110922-parallelmake-001.patch,
+ +files/iasl-20110922-parallelmake-002.patch:
+ Version bump, bug #347019.
30 Sep 2011; Mike Frysinger <vapier@gentoo.org> iasl-20060912.ebuild,
iasl-20080514.ebuild, iasl-20080701.ebuild, iasl-20090123.ebuild,
diff --git a/sys-power/iasl/files/iasl-20110922-as-needed.patch b/sys-power/iasl/files/iasl-20110922-as-needed.patch
new file mode 100644
index 000000000000..a507f74ea9b2
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20110922-as-needed.patch
@@ -0,0 +1,16 @@
+ tools/acpiexec/Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/tools/acpiexec/Makefile b/tools/acpiexec/Makefile
+index ba6b534..8435985 100644
+--- a/tools/acpiexec/Makefile
++++ b/tools/acpiexec/Makefile
+@@ -269,7 +269,7 @@ CWARNINGFLAGS += \
+ # Rules
+ #
+ $(PROG) : $(OBJECTS)
+- $(CC) $(LDFLAGS) $(OBJECTS) -o $(PROG)
++ $(CC) $(OBJECTS) $(LDFLAGS) -o $(PROG)
+ $(COPYPROG)
+
+ %.o : %.c $(HEADERS) $(ACPICA_HEADERS)
diff --git a/sys-power/iasl/files/iasl-20110922-locale.patch b/sys-power/iasl/files/iasl-20110922-locale.patch
new file mode 100644
index 000000000000..920c409b76d2
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20110922-locale.patch
@@ -0,0 +1,16 @@
+diff -Nuar acpica-unix-20110922.orig/compiler/Makefile acpica-unix-20110922/compiler/Makefile
+--- acpica-unix-20110922.orig/compiler/Makefile 2011-09-22 15:59:34.000000000 +0000
++++ acpica-unix-20110922/compiler/Makefile 2011-11-07 03:36:49.103281798 +0000
+@@ -258,10 +258,10 @@
+ #
+ # Bison/Flex configuration
+ #
+-YACC= bison
++YACC= LC_ALL=C bison
+ YFLAGS+= -v -d -y
+
+-LEX= flex
++LEX= LC_ALL=C flex
+ LFLAGS+= -i -s
+
+ #
diff --git a/sys-power/iasl/files/iasl-20110922-parallelmake-001.patch b/sys-power/iasl/files/iasl-20110922-parallelmake-001.patch
new file mode 100644
index 000000000000..b739dd8ab8e4
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20110922-parallelmake-001.patch
@@ -0,0 +1,54 @@
+From 95b2e4c8cecc4ea469d4fd5cfe6927d631aade3a Mon Sep 17 00:00:00 2001
+From: Alphat <AlphatPC@gmail.com>
+Date: Sun, 9 Oct 2011 08:11:36 +0800
+Subject: [PATCH 1/2] iasl-20110922-parallelmake-001
+
+---
+ compiler/Makefile | 16 ++++++++--------
+ 1 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/compiler/Makefile b/compiler/Makefile
+index e08941a..c831064 100644
+--- a/compiler/Makefile
++++ b/compiler/Makefile
+@@ -276,14 +276,14 @@ $(PROG) : $(INTERMEDIATES) $(MISC) $(OBJECTS)
+ aslcompilerlex.c : $(ASL_COMPILER)/aslcompiler.l
+ ${LEX} ${LFLAGS} -PAslCompiler -o$@ $?
+
+-aslcompilerparse.c aslcompilerparse.h : $(ASL_COMPILER)/aslcompiler.y
+- ${YACC} ${YFLAGS} -pAslCompiler -o$@ $?
++aslcompilerparse.c aslcompilerparse.h aslcompilerparse.output : $(ASL_COMPILER)/aslcompiler.y
++ ${YACC} ${YFLAGS} -pAslCompiler -oaslcompilerparse.c $?
+
+ dtparserlex.c : $(ASL_COMPILER)/dtparser.l
+ ${LEX} ${LFLAGS} -PDtParser -o$@ $?
+
+-dtparserparse.c dtparserparse.h : $(ASL_COMPILER)/dtparser.y
+- ${YACC} ${YFLAGS} -pDtParser -o$@ $?
++dtparserparse.c dtparserparse.h dtparserparse.output : $(ASL_COMPILER)/dtparser.y
++ ${YACC} ${YFLAGS} -pDtParser -odtparserparse.c $?
+
+ # Rename headers produced by bison/yacc
+
+@@ -302,14 +302,14 @@ aslcompiler.y.h : aslcompilerparse.h
+ # Cannot use the common compile warning flags since the C files are created
+ # by the utilities above and they are not necessarily ANSI C, etc.
+ #
+-aslcompilerlex.o : aslcompilerlex.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $?
++aslcompilerlex.o : aslcompilerlex.c aslcompilerparse.h
++ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $<
+
+ aslcompilerparse.o : aslcompilerparse.c
+ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $?
+
+-dtparserlex.o : dtparserlex.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $?
++dtparserlex.o : dtparserlex.c dtparserparse.h
++ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $<
+
+ dtparserparse.o : dtparserparse.c
+ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $?
+--
+1.7.7
+
diff --git a/sys-power/iasl/files/iasl-20110922-parallelmake-002.patch b/sys-power/iasl/files/iasl-20110922-parallelmake-002.patch
new file mode 100644
index 000000000000..071ebd047d45
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20110922-parallelmake-002.patch
@@ -0,0 +1,101 @@
+From 2a6a29863c735fd26bf12b1b55aff4f8bf736535 Mon Sep 17 00:00:00 2001
+From: Alphat <AlphatPC@gmail.com>
+Date: Sun, 9 Oct 2011 08:14:12 +0800
+Subject: [PATCH 2/2] iasl-20110922-parallelmake-002
+
+---
+ compiler/Makefile | 39 ++++++++++++++-------------------------
+ 1 files changed, 14 insertions(+), 25 deletions(-)
+
+diff --git a/compiler/Makefile b/compiler/Makefile
+index c831064..b795e16 100644
+--- a/compiler/Makefile
++++ b/compiler/Makefile
+@@ -67,9 +67,9 @@ HEADERS = \
+
+ OBJECTS = \
+ aslcompilerlex.o \
+- aslcompilerparse.o \
++ aslcompiler.y.o \
+ dtparserlex.o \
+- dtparserparse.o \
++ dtparser.y.o \
+ adfile.o \
+ adisasm.o \
+ adwalk.o \
+@@ -203,17 +203,15 @@ OBJECTS = \
+
+ INTERMEDIATES = \
+ aslcompilerlex.c \
+- aslcompilerparse.c \
++ aslcompiler.y.c \
+ dtparserlex.c \
+- dtparserparse.c
++ dtparser.y.c
+
+ MISC = \
+- aslcompilerparse.h \
+ aslcompiler.y.h \
+- aslcompilerparse.output \
+- dtparserparse.h \
++ aslcompiler.y.output \
+ dtparser.y.h \
+- dtparserparse.output
++ dtparser.y.output
+
+ CFLAGS+= \
+ -D$(HOST) \
+@@ -276,42 +274,33 @@ $(PROG) : $(INTERMEDIATES) $(MISC) $(OBJECTS)
+ aslcompilerlex.c : $(ASL_COMPILER)/aslcompiler.l
+ ${LEX} ${LFLAGS} -PAslCompiler -o$@ $?
+
+-aslcompilerparse.c aslcompilerparse.h aslcompilerparse.output : $(ASL_COMPILER)/aslcompiler.y
+- ${YACC} ${YFLAGS} -pAslCompiler -oaslcompilerparse.c $?
++aslcompiler.y.c aslcompiler.y.h aslcompiler.y.output : $(ASL_COMPILER)/aslcompiler.y
++ ${YACC} ${YFLAGS} -pAslCompiler -oaslcompiler.y.c $?
+
+ dtparserlex.c : $(ASL_COMPILER)/dtparser.l
+ ${LEX} ${LFLAGS} -PDtParser -o$@ $?
+
+-dtparserparse.c dtparserparse.h dtparserparse.output : $(ASL_COMPILER)/dtparser.y
+- ${YACC} ${YFLAGS} -pDtParser -odtparserparse.c $?
++dtparser.y.c dtparser.y.h dtparser.y.output : $(ASL_COMPILER)/dtparser.y
++ ${YACC} ${YFLAGS} -pDtParser -odtparser.y.c $?
+
+ # Rename headers produced by bison/yacc
+
+-dtparser.y.h: dtparserparse.h
+- @echo Copy intermediate file:
+- @cp -f -v dtparserparse.h dtparser.y.h
+-
+-aslcompiler.y.h : aslcompilerparse.h
+- @echo Copy intermediate file:
+- @cp -f -v aslcompilerparse.h aslcompiler.y.h
+-
+-
+ #
+ # Parsers and Lexers - final object files
+ #
+ # Cannot use the common compile warning flags since the C files are created
+ # by the utilities above and they are not necessarily ANSI C, etc.
+ #
+-aslcompilerlex.o : aslcompilerlex.c aslcompilerparse.h
++aslcompilerlex.o : aslcompilerlex.c aslcompiler.y.h
+ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $<
+
+-aslcompilerparse.o : aslcompilerparse.c
++aslcompiler.y.o : aslcompiler.y.c
+ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $?
+
+-dtparserlex.o : dtparserlex.c dtparserparse.h
++dtparserlex.o : dtparserlex.c dtparser.y.h
+ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $<
+
+-dtparserparse.o : dtparserparse.c
++dtparser.y.o : dtparser.y.c
+ $(CC) -c $(CFLAGS) -Wall -Werror -Wstrict-aliasing=0 -o$@ $?
+
+
+--
+1.7.7
+
diff --git a/sys-power/iasl/iasl-20110922.ebuild b/sys-power/iasl/iasl-20110922.ebuild
new file mode 100644
index 000000000000..6c74eb91ba99
--- /dev/null
+++ b/sys-power/iasl/iasl-20110922.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20110922.ebuild,v 1.1 2011/11/07 03:39:26 robbat2 Exp $
+
+EAPI=4
+
+inherit toolchain-funcs flag-o-matic eutils
+
+MY_PN=acpica-unix
+MY_P=${MY_PN}-${PV}
+MY_TESTS_P=${MY_PN/ca/tests}-${PV}
+DESCRIPTION="Intel ACPI Source Language (ASL) compiler"
+HOMEPAGE="http://www.intel.com/technology/iapc/acpi/"
+SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
+ test? ( http://www.acpica.org/download/${MY_TESTS_P}.tar.gz )"
+
+LICENSE="iASL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use test
+ then
+ ewarn 'You have selected USE="test". This will install the test results'
+ ewarn "into /usr/share/${PF}/, compressed as a tarball."
+ ewarn 'The tests themselves will only rarely die, but the test results'
+ ewarn 'are interesting for arch testing. The tests may take quite some'
+ ewarn 'time to complete.'
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-20110922-as-needed.patch"
+ epatch "${FILESDIR}/${PN}-20110922-locale.patch"
+ epatch "${FILESDIR}/${PN}-20110922-parallelmake-001.patch"
+ epatch "${FILESDIR}/${PN}-20110922-parallelmake-002.patch"
+
+ find "${S}" -type f -name 'Makefile*' -print0 | \
+ xargs -0 -I '{}' \
+ sed -r -e 's:-\<Werror\>::g' -i '{}' \
+ || die
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ local target bin
+
+ for target in compiler tools/acpi{bin,exec,help,names,src,xtract}
+ do
+ einfo "Compiling in ${target}/"
+ cd "${S}"/${target}
+ case "${target}" in
+ compiler) bin=iasl;;
+ *) bin=${target#*/};;
+ esac
+
+ emake CC="$(tc-getCC)" || die "emake in ${target} failed"
+ einfo "Finished compiling ${target}"
+
+ mv ${bin} "${T}" || die "mv ${bin} failed"
+ einfo "Finished moving ${bin}"
+
+ make clean || die "make clean in ${target} failed"
+ einfo "Finished cleaning ${target}"
+
+ echo ${bin} >>"${T}"/binlist
+ done
+ einfo "$(<"${T}"/binlist)"
+}
+
+src_test() {
+ aslts_test
+ #aapits_test
+ #The aapits test currently fails, missing include probably.
+}
+
+src_install() {
+ local bin
+ for bin in $(<"${T}"/binlist) ; do
+ dobin "${T}"/${bin}
+ done
+ dodoc README changes.txt
+ if use test ; then
+ tb="${T}"/testresults.tar.bz2
+ export ASLTSDIR="$(<"${T}"/asltdir)"
+ ebegin "Creating Test Tarball"
+ tar -cjf "${tb}" -C "${ASLTSDIR}"/tmp/RESULTS . || die "tar failed"
+ eend $?
+ dodir /usr/share/${PF}
+ insinto /usr/share/${PF}
+ doins ${tb} || die "doins testresults.tar.bz2 failed"
+ fi
+
+}
+
+aslts_test() {
+ export ASL="${T}"/iasl \
+ acpiexec="${T}"/acpiexec \
+ ASLTSDIR="${WORKDIR}/${MY_TESTS_P}"/tests/aslts
+ export PATH="${PATH}:${ASLTSDIR}/bin"
+ echo "$ASLTSDIR" >"${T}"/asltdir
+ cd "${ASLTSDIR}"
+ edos2unix $(find . -type 'f')
+ make install || die "make install aslts test failed"
+ chmod +x $(find bin/ ! -regex 'ERROR_OPCODES|HOW_TO_USE|README' ) || die "chmod bin +x failed"
+
+ #The below Do commands runs the tests twice and then dies if the results aren't
+ #Identical.
+ Do 1 || die "failed Do 1"
+ Do 2 || die "failed Do 2"
+}
+
+aapits_test() {
+ mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
+ cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
+ edos2unix $(find . -type 'f')
+ chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
+ make || die "make in aapits failed"
+ cd asl || die "cd asl failed"
+ make || die "make in asl failed"
+ cd ../bin
+ ./aapitsrun || die "aapitsrun failed"
+}