summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-07-05 03:15:16 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-07-05 03:15:16 +0000
commit054f2cde956c764989f69b973d699ab2ab692106 (patch)
tree2d1dbc0dd7a7c1c639b67f65d32e0e5a0f1e29b9 /sys-power
parent(#223111) Bump, fix various compilation issues of the older version with newe... (diff)
downloadgentoo-2-054f2cde956c764989f69b973d699ab2ab692106.tar.gz
gentoo-2-054f2cde956c764989f69b973d699ab2ab692106.tar.bz2
gentoo-2-054f2cde956c764989f69b973d699ab2ab692106.zip
Bug #229443, compile-fix for newer libtool setups.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc4-00103-g1beee8d x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/nut/ChangeLog6
-rw-r--r--sys-power/nut/files/nut-2.2.2-no-libdummy.patch32
-rw-r--r--sys-power/nut/nut-2.2.2.ebuild4
3 files changed, 40 insertions, 2 deletions
diff --git a/sys-power/nut/ChangeLog b/sys-power/nut/ChangeLog
index 32a6e4f2b633..6d3af9aa9caf 100644
--- a/sys-power/nut/ChangeLog
+++ b/sys-power/nut/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/nut
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.56 2008/06/25 02:53:07 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.57 2008/07/05 03:15:15 robbat2 Exp $
+
+ 05 Jul 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/nut-2.2.2-no-libdummy.patch, nut-2.2.2.ebuild:
+ Bug #229443, compile-fix for newer libtool setups.
25 Jun 2008; Robin H. Johnson <robbat2@gentoo.org>
files/nut-2.2.2-init.d-upsmon:
diff --git a/sys-power/nut/files/nut-2.2.2-no-libdummy.patch b/sys-power/nut/files/nut-2.2.2-no-libdummy.patch
new file mode 100644
index 000000000000..646e9fefe184
--- /dev/null
+++ b/sys-power/nut/files/nut-2.2.2-no-libdummy.patch
@@ -0,0 +1,32 @@
+diff -Nuar nut-2.2.2.orig/common/Makefile.am nut-2.2.2/common/Makefile.am
+--- nut-2.2.2.orig/common/Makefile.am 2007-05-27 07:07:56.000000000 -0700
++++ nut-2.2.2/common/Makefile.am 2008-07-04 20:09:14.062814944 -0700
+@@ -10,8 +10,8 @@
+
+ # Define a dummy library so that Automake builds rules for the
+ # corresponding object files. This library is not actually built,
+-EXTRA_LIBRARIES = libdummy.a
+-libdummy_a_SOURCES = parseconf.c state.c upsconf.c
++#EXTRA_LIBRARIES = libdummy.a
++#libdummy_a_SOURCES = parseconf.c state.c upsconf.c
+
+ ../include/nut_version.h: FORCE
+ (cd ../include/ && $(MAKE) $(AM_MAKEFLAGS) nut_version.h)
+diff -Nuar nut-2.2.2.orig/drivers/Makefile.am nut-2.2.2/drivers/Makefile.am
+--- nut-2.2.2.orig/drivers/Makefile.am 2008-07-04 20:12:38.201211819 -0700
++++ nut-2.2.2/drivers/Makefile.am 2008-07-04 20:12:59.829462787 -0700
+@@ -211,10 +211,12 @@
+ upscode2.h victronups.h powerpanel.h powerp-bin.h powerp-txt.h \
+ upshandler.h netxml-ups.h mge-xml.h
+
++EXTRA_LIBRARIES =
++
+ # Define a dummy library so that Automake builds rules for the
+ # corresponding object files. This library is not actually built,
+-EXTRA_LIBRARIES = libdummy.a
+-libdummy_a_SOURCES = main.c dstate.c serial.c
++#EXTRA_LIBRARIES += libdummy.a
++#libdummy_a_SOURCES = main.c dstate.c serial.c
+
+ # the nuthalmain library combines the code for main-hal.c and
+ # dstate-hal.c. It is necessary for Automake-technical reasons,
diff --git a/sys-power/nut/nut-2.2.2.ebuild b/sys-power/nut/nut-2.2.2.ebuild
index 82fde6b56617..efac2ac7c3f7 100644
--- a/sys-power/nut/nut-2.2.2.ebuild
+++ b/sys-power/nut/nut-2.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.2.2.ebuild,v 1.2 2008/06/25 16:03:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.2.2.ebuild,v 1.3 2008/07/05 03:15:15 robbat2 Exp $
inherit eutils fixheadtails autotools
@@ -58,6 +58,8 @@ src_unpack() {
ht_fix_file configure.in
+ epatch "${FILESDIR}"/${P}-no-libdummy.patch
+
sed -e "s:GD_LIBS.*=.*-L/usr/X11R6/lib \(.*\) -lXpm -lX11:GD_LIBS=\"\1:" \
-i configure.in || die "sed failed"