summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-04-26 21:13:06 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-04-26 21:13:06 +0000
commitd336a32253c7c927a740f5e42d48c522294f6e2d (patch)
tree61d07f59cac6f1613015ca2342d147af29a0c41e /sys-libs
parentAdd arm love for ChromiumOS. (diff)
downloadgentoo-2-d336a32253c7c927a740f5e42d48c522294f6e2d.tar.gz
gentoo-2-d336a32253c7c927a740f5e42d48c522294f6e2d.tar.bz2
gentoo-2-d336a32253c7c927a740f5e42d48c522294f6e2d.zip
Bump to 0.1.1, for gnome-boxes
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libosinfo/ChangeLog7
-rw-r--r--sys-libs/libosinfo/libosinfo-0.1.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-libs/libosinfo/ChangeLog b/sys-libs/libosinfo/ChangeLog
index 70fb92261aad..681446e761fe 100644
--- a/sys-libs/libosinfo/ChangeLog
+++ b/sys-libs/libosinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libosinfo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/ChangeLog,v 1.6 2012/03/10 04:30:16 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/ChangeLog,v 1.7 2012/04/26 21:13:06 nirbheek Exp $
+
+*libosinfo-0.1.1 (26 Apr 2012)
+
+ 26 Apr 2012; Nirbheek Chauhan <nirbheek@gentoo.org> +libosinfo-0.1.1.ebuild:
+ Bump to 0.1.1, for gnome-boxes
*libosinfo-0.1.0 (10 Mar 2012)
diff --git a/sys-libs/libosinfo/libosinfo-0.1.1.ebuild b/sys-libs/libosinfo/libosinfo-0.1.1.ebuild
new file mode 100644
index 000000000000..5605195229ba
--- /dev/null
+++ b/sys-libs/libosinfo/libosinfo-0.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/libosinfo-0.1.1.ebuild,v 1.1 2012/04/26 21:13:06 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="GObject library for managing information about real and virtual OSes"
+HOMEPAGE="https://fedorahosted.org/libosinfo/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+SRC_URI="https://fedorahosted.org/releases/l/i/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection +vala test"
+
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ dev-libs/glib:2
+ net-libs/libsoup:2.4
+ net-libs/libsoup-gnome:2.4
+ >=dev-libs/libxml2-2.6.0:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ test? ( dev-libs/check )
+ vala? ( dev-lang/vala:0.14 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ # --enable-udev only installs udev rules
+ G2CONF="--disable-coverage
+ --disable-static
+ --enable-udev
+ --with-udev-rulesdir=/lib/udev/rules.d
+ VAPIGEN=$(type -P vapigen-0.14)
+ $(use_enable introspection)
+ $(use_enable test tests)
+ $(use_enable vala)"
+}