summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-10-14 07:04:58 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-10-14 07:04:58 +0000
commitba4986683a8b5a9b112d36be6296585b324fd476 (patch)
tree221b6c9877ad1a53111a729a749029d73350bdad /sys-libs
parentOpenMotif is exactly needed with 2.2, 2.3 will not work at the moment. Thank... (diff)
downloadgentoo-2-ba4986683a8b5a9b112d36be6296585b324fd476.tar.gz
gentoo-2-ba4986683a8b5a9b112d36be6296585b324fd476.tar.bz2
gentoo-2-ba4986683a8b5a9b112d36be6296585b324fd476.zip
Removed generic gcc command, bug #194233.
(Portage version: 2.1.3.9)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/slang/ChangeLog8
-rw-r--r--sys-libs/slang/files/digest-slang-1.4.9-r16
-rw-r--r--sys-libs/slang/files/digest-slang-2.0.63
-rw-r--r--sys-libs/slang/files/slang-2.0.6-foreground.patch36
-rw-r--r--sys-libs/slang/files/slang-2.0.6-slsh-libs.patch11
-rw-r--r--sys-libs/slang/slang-1.4.9-r1.ebuild64
-rw-r--r--sys-libs/slang/slang-1.4.9-r2.ebuild7
-rw-r--r--sys-libs/slang/slang-2.0.6.ebuild65
8 files changed, 11 insertions, 189 deletions
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index 7de82c3e7c5a..425c36561724 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/slang
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.62 2007/09/18 16:47:16 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.63 2007/10/14 07:04:57 matsuu Exp $
+
+ 14 Oct 2007; <matsuu@gentoo.org> -files/slang-2.0.6-foreground.patch,
+ -files/slang-2.0.6-slsh-libs.patch, -slang-1.4.9-r1.ebuild,
+ slang-1.4.9-r2.ebuild, -slang-2.0.6.ebuild:
+ Removed old versions.
+ Fixed distcc issue, bug #194233.
*slang-2.1.2 (18 Sep 2007)
diff --git a/sys-libs/slang/files/digest-slang-1.4.9-r1 b/sys-libs/slang/files/digest-slang-1.4.9-r1
deleted file mode 100644
index c0ec75f257a8..000000000000
--- a/sys-libs/slang/files/digest-slang-1.4.9-r1
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 a69e4f7558e727decb3efa8d9a9e77b6 slang-1.4.9-patches.tar.gz 12132
-RMD160 02c7df8f7d51c39c0bf9e729606aa1b94c3e6aaf slang-1.4.9-patches.tar.gz 12132
-SHA256 487174a2b5df8564b99589e789319b37ee75c52d09ce98bfb12656414cdca3fb slang-1.4.9-patches.tar.gz 12132
-MD5 4fbb1a7f1257e065ca830deefe13d350 slang-1.4.9.tar.bz2 631079
-RMD160 bd2c37554129134e4e874502af0ebcb6fc7e151b slang-1.4.9.tar.bz2 631079
-SHA256 fa42e57e902f2161dc2b297e0dcb24ca180024770afa379027db582803ffa2fa slang-1.4.9.tar.bz2 631079
diff --git a/sys-libs/slang/files/digest-slang-2.0.6 b/sys-libs/slang/files/digest-slang-2.0.6
deleted file mode 100644
index bdebd18e98fa..000000000000
--- a/sys-libs/slang/files/digest-slang-2.0.6
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 fb8ab2dfc3d8f44b9161b9b0e0c94141 slang-2.0.6.tar.gz 1325084
-RMD160 caf879e440f28297b00cea8bf504af813998424a slang-2.0.6.tar.gz 1325084
-SHA256 5e73fddd052c1a62a20002dafbe7215cf9e449d8a50e81065972f0317caa286c slang-2.0.6.tar.gz 1325084
diff --git a/sys-libs/slang/files/slang-2.0.6-foreground.patch b/sys-libs/slang/files/slang-2.0.6-foreground.patch
deleted file mode 100644
index c9c5bbb0c95b..000000000000
--- a/sys-libs/slang/files/slang-2.0.6-foreground.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- src/sldisply.c.old 2006-02-05 21:47:31.000000000 +0100
-+++ src/sldisply.c 2006-07-28 09:41:34.000000000 +0200
-@@ -158,7 +158,7 @@
- static Brush_Info_Type Brush_Table[JMAX_COLORS];
-
- /* 0 if least significant bit is blue, not red */
--/* static int Is_Fg_BGR = 0; */
-+static int Is_Fg_BGR = 0;
- static int Is_Bg_BGR = 0;
- #define COLOR_ARG(color, is_bgr) ((is_bgr) ? RGB_to_BGR[(color)&0x7] : (color))
- static SLCONST int RGB_to_BGR[] =
-@@ -1394,7 +1394,7 @@
- if (fg0 == SLSMG_COLOR_DEFAULT)
- tt_write_string (Default_Color_Fg_Str);
- else
-- tt_printf (Color_Fg_Str, COLOR_ARG(fg0, Is_Bg_BGR), 0);
-+ tt_printf (Color_Fg_Str, COLOR_ARG(fg0, Is_Fg_BGR), 0);
- }
-
- if (unknown_attributes
-@@ -2554,13 +2554,13 @@
- if (Color_Fg_Str == NULL)
- {
- Color_Fg_Str = SLtt_tgetstr ("Sf"); /* setf */
-- /* Is_Fg_BGR = (Color_Fg_Str != NULL); */
-+ Is_Fg_BGR = (Color_Fg_Str != NULL);
- }
- Color_Bg_Str = SLtt_tgetstr ("AB"); /* ANSI setbf */
- if (Color_Bg_Str == NULL)
- {
- Color_Bg_Str = SLtt_tgetstr ("Sb"); /* setb */
-- /* Is_Fg_BGR = (Color_Bg_Str != NULL); */
-+ Is_Bg_BGR = (Color_Bg_Str != NULL);
- }
-
- if ((Max_Terminfo_Colors = SLtt_tgetnum ("Co")) < 0)
diff --git a/sys-libs/slang/files/slang-2.0.6-slsh-libs.patch b/sys-libs/slang/files/slang-2.0.6-slsh-libs.patch
deleted file mode 100644
index 676cf46ee46b..000000000000
--- a/sys-libs/slang/files/slang-2.0.6-slsh-libs.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./slsh/Makefile.in.old 2006-07-15 22:02:01.000000000 -0700
-+++ ./slsh/Makefile.in 2006-07-15 22:02:21.000000000 -0700
-@@ -69,7 +69,7 @@
- slsh_exe: slsh.o readline.o
- $(CC) slsh.o readline.o -o slsh_exe $(LDFLAGS) $(SRC_LIBS)
- slsh: slsh.o readline.o
-- $(CC) slsh.o readline.o -o slsh $(LDFLAGS) $(INST_LIBS)
-+ $(CC) slsh.o readline.o -o slsh $(LDFLAGS) $(SRC_LIBS)
- slsh.o: slsh.c slsh.h config.h
- $(CC) -c $(CFLAGS) $(SLANG_SRCINC) $(DEFS) slsh.c
- readline.o: readline.c slsh.h config.h
diff --git a/sys-libs/slang/slang-1.4.9-r1.ebuild b/sys-libs/slang/slang-1.4.9-r1.ebuild
deleted file mode 100644
index 0e7d29e172a9..000000000000
--- a/sys-libs/slang/slang-1.4.9-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.9-r1.ebuild,v 1.24 2007/03/18 17:15:01 grobian Exp $
-
-inherit eutils multilib
-
-# Patches are taken from http://www.suse.de/~nadvornik/slang/
-# They were originally Red Hat and Debian's patches
-
-DESCRIPTION="Console display library used by most text viewer"
-HOMEPAGE="http://www.s-lang.org/"
-SRC_URI="ftp://space.mit.edu/pub/davis/slang/v1.4/${P}.tar.bz2
- mirror://gentoo/${P}-patches.tar.gz"
-
-LICENSE="|| ( GPL-2 Artistic )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="cjk unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch ${WORKDIR}/${P}.patch
- epatch ${WORKDIR}/${P}-fsuid.patch
- epatch ${WORKDIR}/${P}-autoconf.patch
- if use unicode ; then
- epatch ${WORKDIR}/slang-debian-utf8.patch
- epatch ${WORKDIR}/slang-utf8-acs.patch
- epatch ${WORKDIR}/slang-utf8-fix.patch
- fi
- if use cjk ; then
- sed -i \
- -e "/SLANG_HAS_KANJI_SUPPORT/s/0/1/" \
- src/sl-feat.h
- fi
-}
-
-src_compile() {
- export LANG=C
- export LC_ALL=C
- econf || die "econf failed"
- emake -j1 all elf || die "make failed"
-}
-
-src_install() {
- make install install-elf DESTDIR=${D} || die "make install failed"
- chmod a+rx "${D}"/usr/$(get_libdir)/libslang*$(get_libname)* || die "chmod failed"
-
- if use unicode ; then
- for i in ${D}/usr/$(get_libdir)/libslang-utf8* ; do
- local libslang=${i/${D}/}
- dosym ${libslang} ${libslang/-utf8/}
- done
- dosym /usr/$(get_libdir)/libslang{-utf8,}.a
- fi
-
- rm -rf ${D}/usr/doc
- dodoc NEWS README *.txt
- dodoc doc/*.txt doc/internal/*.txt doc/text/*.txt
- dohtml doc/*.html
-}
diff --git a/sys-libs/slang/slang-1.4.9-r2.ebuild b/sys-libs/slang/slang-1.4.9-r2.ebuild
index f2109c250a8d..22eeb0b2dea2 100644
--- a/sys-libs/slang/slang-1.4.9-r2.ebuild
+++ b/sys-libs/slang/slang-1.4.9-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.9-r2.ebuild,v 1.18 2007/03/18 17:15:01 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.9-r2.ebuild,v 1.19 2007/10/14 07:04:57 matsuu Exp $
-inherit eutils
+inherit eutils toolchain-funcs
# Patches are taken from http://www.suse.de/~nadvornik/slang/
# They were originally Red Hat and Debian's patches
@@ -46,7 +46,8 @@ src_compile() {
export LANG=C
export LC_ALL=C
econf || die "econf failed"
- emake -j1 all elf || die "make failed"
+ sed -i -e "/^ELF_LINK/s:gcc:$(tc-getCC):" src/Makefile || die
+ emake CC="$(tc-getCC)" ELF_CC="$(tc-getCC)" -j1 all elf || die "make failed"
}
src_install() {
diff --git a/sys-libs/slang/slang-2.0.6.ebuild b/sys-libs/slang/slang-2.0.6.ebuild
deleted file mode 100644
index 2447dd38b2c7..000000000000
--- a/sys-libs/slang/slang-2.0.6.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.0.6.ebuild,v 1.4 2006/09/19 22:48:21 liquidx Exp $
-
-inherit eutils
-
-DESCRIPTION="Console display library used by most text viewer"
-HOMEPAGE="http://www.s-lang.org/"
-SRC_URI="ftp://space.mit.edu/pub/davis/slang/v${PV%.*}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~amd64 ~x86"
-# USE=cjk is broken; see http://www.jedsoft.org/pipermail/slang-users_jedsoft.org/2006/000399.html
-IUSE="pcre png"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2
- pcre? ( dev-libs/libpcre )
- png? ( media-libs/libpng )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/^SLANG_INST_INC/s/-I@includedir@/-I@SRCDIR@ -I@includedir@/' \
- -e '/^SLANG_INST_LIB/s/-L@libdir@/-L@OBJDIR@ -L@ELFDIR@ -L@libdir@/' \
- slsh/Makefile.in || die
-
- epatch "${FILESDIR}/${PN}-2.0.6-slsh-libs.patch"
- epatch "${FILESDIR}/${PN}-2.0.6-foreground.patch"
-
- grep -rlZ -- '-lslang\>' "${S}" | xargs -0 sed -i -e 's:-lslang:-lslang-2:g'
-}
-
-src_compile() {
- econf \
- $(use_with pcre) \
- $(use_with png) || die "econf failed"
- emake -j1 THIS_LIB="slang-2" all || die "make all failed"
- emake -j1 THIS_LIB="slang-2" elf || die "make elf failed"
- cd slsh
- emake -j1 THIS_LIB="slang-2" slsh || die "make slsh failed"
-}
-
-src_install() {
- emake -j1 THIS_LIB="slang-2" DESTDIR="${D}" install install-elf || die "make install failed"
-
- # Move headers around
- dodir /usr/include/slang-2
- mv "${D}"/usr/include/*.h "${D}/usr/include/slang-2"
-
- rm -rf "${D}/usr/share/doc/slang"
- dodoc NEWS README *.txt
- dodoc doc/*.txt doc/internal/*.txt doc/text/*.txt
- dohtml doc/slangdoc.html
-}
-
-pkg_postinst() {
- elog "For compatibility reason slang 2.x is installed in Gentoo as libslang-2."
- elog "This has the unfortunate consequence that if you want to build something"
- elog "from sources that uses slang 2.x, you need to change the linking library"
- elog "to -lslang-2 instead of simply -lslang."
- elog "We're sorry for the inconvenience, but it's to overcome an otherwise"
- elog "problematic situation."
-}