summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2012-05-29 08:25:43 +0000
committerRichard Yao <ryao@gentoo.org>2012-05-29 08:25:43 +0000
commit48012be48718d49bc62953b308945dbfbbf32db5 (patch)
tree5309572dcf0d554d2ab825f5be33632cb17354e3 /sys-libs
parentRename __atomic_compare_exchange to avoid conflict with builtin, bug #417547,... (diff)
downloadgentoo-2-48012be48718d49bc62953b308945dbfbbf32db5.tar.gz
gentoo-2-48012be48718d49bc62953b308945dbfbbf32db5.tar.bz2
gentoo-2-48012be48718d49bc62953b308945dbfbbf32db5.zip
Fix illegal C++ code, bug #417763, approved by Chainsaw
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ncurses/ChangeLog6
-rw-r--r--sys-libs/ncurses/files/ncurses-5.9-fix-clang-build.patch44
-rw-r--r--sys-libs/ncurses/ncurses-5.9-r2.ebuild5
3 files changed, 53 insertions, 2 deletions
diff --git a/sys-libs/ncurses/ChangeLog b/sys-libs/ncurses/ChangeLog
index 1d0d89c03dfc..07f71d097c7b 100644
--- a/sys-libs/ncurses/ChangeLog
+++ b/sys-libs/ncurses/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/ncurses
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.205 2012/05/21 09:43:32 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.206 2012/05/29 08:25:43 ryao Exp $
+
+ 29 May 2012; Richard Yao <ryao@gentoo.org>
+ +files/ncurses-5.9-fix-clang-build.patch, ncurses-5.9-r2.ebuild:
+ Fix illegal C++ code, bug #417763, approved by Chainsaw
21 May 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ncurses-5.9-r2.ebuild:
x86 stable wrt bug #413897
diff --git a/sys-libs/ncurses/files/ncurses-5.9-fix-clang-build.patch b/sys-libs/ncurses/files/ncurses-5.9-fix-clang-build.patch
new file mode 100644
index 000000000000..0c6ca7acc4fc
--- /dev/null
+++ b/sys-libs/ncurses/files/ncurses-5.9-fix-clang-build.patch
@@ -0,0 +1,44 @@
+diff --git a/ncurses-5.9/c++/cursesf.h b/ncurses-5.9/c++/cursesf.h
+index 70a30c3..db38063 100644
+--- a/ncurses-5.9/c++/cursesf.h
++++ b/ncurses-5.9/c++/cursesf.h
+@@ -677,7 +677,7 @@ protected:
+ }
+
+ public:
+- NCursesUserForm (NCursesFormField Fields[],
++ NCursesUserForm (NCursesFormField* Fields[],
+ const T* p_UserData = STATIC_CAST(T*)(0),
+ bool with_frame=FALSE,
+ bool autoDelete_Fields=FALSE)
+@@ -686,7 +686,7 @@ public:
+ set_user (const_cast<void *>(p_UserData));
+ };
+
+- NCursesUserForm (NCursesFormField Fields[],
++ NCursesUserForm (NCursesFormField* Fields[],
+ int nlines,
+ int ncols,
+ int begin_y = 0,
+diff --git a/ncurses-5.9/c++/cursesm.h b/ncurses-5.9/c++/cursesm.h
+index d9c2273..2d5b79a 100644
+--- a/ncurses-5.9/c++/cursesm.h
++++ b/ncurses-5.9/c++/cursesm.h
+@@ -635,7 +635,7 @@ protected:
+ }
+
+ public:
+- NCursesUserMenu (NCursesMenuItem Items[],
++ NCursesUserMenu (NCursesMenuItem* Items[],
+ const T* p_UserData = STATIC_CAST(T*)(0),
+ bool with_frame=FALSE,
+ bool autoDelete_Items=FALSE)
+@@ -644,7 +644,7 @@ public:
+ set_user (const_cast<void *>(p_UserData));
+ };
+
+- NCursesUserMenu (NCursesMenuItem Items[],
++ NCursesUserMenu (NCursesMenuItem* Items[],
+ int nlines,
+ int ncols,
+ int begin_y = 0,
diff --git a/sys-libs/ncurses/ncurses-5.9-r2.ebuild b/sys-libs/ncurses/ncurses-5.9-r2.ebuild
index f3d619a83595..5ed52362f44f 100644
--- a/sys-libs/ncurses/ncurses-5.9-r2.ebuild
+++ b/sys-libs/ncurses/ncurses-5.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.9-r2.ebuild,v 1.8 2012/05/21 09:43:32 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.9-r2.ebuild,v 1.9 2012/05/29 08:25:43 ryao Exp $
EAPI="1"
inherit eutils flag-o-matic toolchain-funcs
@@ -31,6 +31,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-5.8-gfbsd.patch
epatch "${FILESDIR}"/${PN}-5.7-nongnu.patch
epatch "${FILESDIR}"/${PN}-5.9-rxvt-unicode-9.15.patch #192083 #383871
+ epatch "${FILESDIR}"/${PN}-5.9-fix-clang-build.patch #417763
sed -i \
-e '/^PKG_CONFIG_LIBDIR/s:=.*:=$(libdir)/pkgconfig:' \
misc/Makefile.in || die
@@ -148,6 +149,8 @@ src_install() {
local termfile=$(find "${D}"/usr/share/terminfo/ -name "${x}" 2>/dev/null)
local basedir=$(basename $(dirname "${termfile}"))
+
+
if [[ -n ${termfile} ]] ; then
dodir /etc/terminfo/${basedir}
mv ${termfile} "${D}"/etc/terminfo/${basedir}/