summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-25 06:17:28 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-25 06:17:28 +0000
commit437c315f5d84c7478c5bfe247f0e66e750426035 (patch)
tree15fca58c481ae3615baf579cc648aeead4c5936d /sys-libs
parentUpdate gtk2 patch (from Arnaud Lech via bug #86156); tidy ebuild (diff)
downloadgentoo-2-437c315f5d84c7478c5bfe247f0e66e750426035.tar.gz
gentoo-2-437c315f5d84c7478c5bfe247f0e66e750426035.tar.bz2
gentoo-2-437c315f5d84c7478c5bfe247f0e66e750426035.zip
use Stefan suggestion of executing ld-linux and having it setup the library path so we get a 'clean' env for the simple tests #86465
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild14
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild14
2 files changed, 20 insertions, 8 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index 66411e9aa745..2558498bc880 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.4 2005/03/24 23:21:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.5 2005/03/25 06:17:28 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -1003,9 +1003,15 @@ EOF
# example host.conf with multicast dns disabled by default
doins ${FILESDIR}/2.3.4/host.conf
- for x in ls ps date ; do
- [[ -z $(type -p ${x}) ]] && continue
- env LD_LIBRARY_PATH="${D}/$(get_libdir)" ${x} > /dev/null \
+ # simple test to make sure our new glibc isnt completely broken.
+ # for now, skip the multilib scenario.
+ [[ $(get_libdir) != "lib" ]] && return 0
+ for x in date env ls true uname ; do
+ x=$(type -p ${x})
+ [[ -z ${x} ]] && continue
+ "${D}"/$(get_libdir)/ld-*.so \
+ --library-path "${D}"/$(get_libdir) \
+ ${x} > /dev/null \
|| die "simple run test (${x}) failed"
done
}
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 8c985fbf5eb5..7157e8e27947 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.31 2005/03/24 23:21:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.32 2005/03/25 06:17:28 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -484,9 +484,15 @@ toolchain-glibc_src_install() {
# example host.conf with multicast dns disabled by default
doins ${FILESDIR}/2.3.4/host.conf
- for x in ls ps date ; do
- [[ -z $(type -p ${x}) ]] && continue
- env LD_LIBRARY_PATH="${D}/$(get_libdir)" ${x} > /dev/null \
+ # simple test to make sure our new glibc isnt completely broken.
+ # for now, skip the multilib scenario.
+ [[ $(get_libdir) != "lib" ]] && return 0
+ for x in date env ls true uname ; do
+ x=$(type -p ${x})
+ [[ -z ${x} ]] && continue
+ "${D}"/$(get_libdir)/ld-*.so \
+ --library-path "${D}"/$(get_libdir) \
+ ${x} > /dev/null \
|| die "simple run test (${x}) failed"
done
}