summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-05-14 11:43:28 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-05-14 11:43:28 +0000
commit03d778c4a1d71bb7425f7c8312b5b40ba6817103 (patch)
tree415cbaa292cd5936e0b168f9f9d41a4d6cd03ec7 /sys-libs
parentDrop ~mips since its broken. (diff)
downloadgentoo-2-03d778c4a1d71bb7425f7c8312b5b40ba6817103.tar.gz
gentoo-2-03d778c4a1d71bb7425f7c8312b5b40ba6817103.tar.bz2
gentoo-2-03d778c4a1d71bb7425f7c8312b5b40ba6817103.zip
Drop older stable versions that depended on sys-apps/getent.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/musl/ChangeLog6
-rw-r--r--sys-libs/musl/musl-1.1.7.ebuild103
-rw-r--r--sys-libs/musl/musl-1.1.8.ebuild99
3 files changed, 5 insertions, 203 deletions
diff --git a/sys-libs/musl/ChangeLog b/sys-libs/musl/ChangeLog
index c6f1cd1d2bfa..62b01ef2639c 100644
--- a/sys-libs/musl/ChangeLog
+++ b/sys-libs/musl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/musl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.57 2015/05/14 11:41:35 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.58 2015/05/14 11:43:28 blueness Exp $
+
+ 14 May 2015; Anthony G. Basile <blueness@gentoo.org> -musl-1.1.7.ebuild,
+ -musl-1.1.8.ebuild:
+ Drop older stable versions that depended on sys-apps/getent.
14 May 2015; Anthony G. Basile <blueness@gentoo.org> musl-1.1.9.ebuild:
Drop ~mips since its broken.
diff --git a/sys-libs/musl/musl-1.1.7.ebuild b/sys-libs/musl/musl-1.1.7.ebuild
deleted file mode 100644
index f421c614d450..000000000000
--- a/sys-libs/musl/musl-1.1.7.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-1.1.7.ebuild,v 1.2 2015/03/24 00:14:05 blueness Exp $
-
-EAPI=5
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
- inherit git-2
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
-HOMEPAGE="http://www.musl-libc.org/"
-if [[ ${PV} != "9999" ]] ; then
- PATCH_VER=""
- SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
- KEYWORDS="-* amd64 arm ~mips ppc x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="crosscompile_opts_headers-only"
-
-if [[ ${CATEGORY} != cross-* ]] ; then
- RDEPEND+=" sys-apps/getent"
-fi
-
-is_crosscompile() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-
-just_headers() {
- use crosscompile_opts_headers-only && is_crosscompile
-}
-
-pkg_setup() {
- if [ ${CTARGET} == ${CHOST} ] ; then
- case ${CHOST} in
- *-musl*) ;;
- *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
- esac
- fi
-
- epatch_user
-}
-
-src_configure() {
- tc-getCC ${CTARGET}
- just_headers && export CC=true
-
- ./configure \
- --target="${CTARGET}" \
- --prefix="/usr" \
- --disable-gcc-wrapper
-}
-
-src_compile() {
- emake include/bits/alltypes.h || die
- just_headers && return 0
-
- emake || die
-}
-
-src_install() {
- local sysroot=${D}
- is_crosscompile && sysroot+="/usr/${CTARGET}"
-
- local target="install"
- just_headers && target="install-headers"
- emake DESTDIR="${sysroot}" ${target} || die
-
- # Make sure we install the sys-include symlink so that when
- # we build a 2nd stage cross-compiler, gcc finds the target
- # system headers correctly. See gcc/doc/gccinstall.info
- if is_crosscompile ; then
- dosym usr/include /usr/${CTARGET}/sys-include
- fi
-
- # musl provides ldd via a sym link to its ld.so
- local ldso=$(basename ${D}/lib/ld-musl-*)
- dosym /lib/${ldso} /usr/bin/ldd
-}
-
-pkg_postinst() {
- is_crosscompile && return 0
-
- [ "${ROOT}" != "/" ] && return 0
-
- # TODO: musl doesn't use ldconfig, instead here we can
- # create sym links to libraries outside of /lib and /usr/lib
- ldconfig
- # reload init ...
- /sbin/telinit U 2>/dev/null
-}
diff --git a/sys-libs/musl/musl-1.1.8.ebuild b/sys-libs/musl/musl-1.1.8.ebuild
deleted file mode 100644
index df329052126e..000000000000
--- a/sys-libs/musl/musl-1.1.8.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-1.1.8.ebuild,v 1.2 2015/04/01 20:04:37 blueness Exp $
-
-EAPI=5
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
- inherit git-2
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
-HOMEPAGE="http://www.musl-libc.org/"
-if [[ ${PV} != "9999" ]] ; then
- PATCH_VER=""
- SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
- KEYWORDS="-* amd64 arm ~mips ppc x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="crosscompile_opts_headers-only"
-
-if [[ ${CATEGORY} != cross-* ]] ; then
- RDEPEND+=" sys-apps/getent"
-fi
-
-is_crosscompile() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-
-just_headers() {
- use crosscompile_opts_headers-only && is_crosscompile
-}
-
-pkg_setup() {
- if [ ${CTARGET} == ${CHOST} ] ; then
- case ${CHOST} in
- *-musl*) ;;
- *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
- esac
- fi
-
- epatch_user
-}
-
-src_configure() {
- tc-getCC ${CTARGET}
- just_headers && export CC=true
-
- local sysroot
- is_crosscompile && sysroot=/usr/${CTARGET}
- ./configure \
- --target=${CTARGET} \
- --prefix=${sysroot}/usr \
- --syslibdir=${sysroot}/lib \
- --disable-gcc-wrapper
-}
-
-src_compile() {
- emake include/bits/alltypes.h || die
- just_headers && return 0
-
- emake || die
-}
-
-src_install() {
- local target="install"
- just_headers && target="install-headers"
- emake DESTDIR="${D}" ${target} || die
- just_headers && return 0
-
- # musl provides ldd via a sym link to its ld.so
- local sysroot
- is_crosscompile && sysroot=/usr/${CTARGET}
- local ldso=$(basename "${D}"${sysroot}/lib/ld-musl-*)
- dosym ${sysroot}/lib/${ldso} ${sysroot}/usr/bin/ldd
-}
-
-pkg_postinst() {
- is_crosscompile && return 0
-
- [ "${ROOT}" != "/" ] && return 0
-
- # TODO: musl doesn't use ldconfig, instead here we can
- # create sym links to libraries outside of /lib and /usr/lib
- ldconfig
- # reload init ...
- /sbin/telinit U 2>/dev/null
-}