summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-14 05:17:48 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-14 05:17:48 +0000
commitdf250d511b22c4321a4b8a2b31fce769b50b533f (patch)
tree27bf344f663fa1eb008b5b905aa232e8a0a430a7 /sys-libs/zlib
parentold (diff)
downloadgentoo-2-df250d511b22c4321a4b8a2b31fce769b50b533f.tar.gz
gentoo-2-df250d511b22c4321a4b8a2b31fce769b50b533f.tar.bz2
gentoo-2-df250d511b22c4321a4b8a2b31fce769b50b533f.zip
old
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-libs/zlib')
-rw-r--r--sys-libs/zlib/files/digest-zlib-1.2.21
-rw-r--r--sys-libs/zlib/files/digest-zlib-1.2.2-r11
-rw-r--r--sys-libs/zlib/files/zlib-1.2.2-inftrees.patch11
-rw-r--r--sys-libs/zlib/zlib-1.2.2-r1.ebuild72
-rw-r--r--sys-libs/zlib/zlib-1.2.2.ebuild70
5 files changed, 0 insertions, 155 deletions
diff --git a/sys-libs/zlib/files/digest-zlib-1.2.2 b/sys-libs/zlib/files/digest-zlib-1.2.2
deleted file mode 100644
index 5f8e75741a93..000000000000
--- a/sys-libs/zlib/files/digest-zlib-1.2.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1b8aab042d40979e456194c468fd72c5 zlib-1.2.2.tar.bz2 371728
diff --git a/sys-libs/zlib/files/digest-zlib-1.2.2-r1 b/sys-libs/zlib/files/digest-zlib-1.2.2-r1
deleted file mode 100644
index 5f8e75741a93..000000000000
--- a/sys-libs/zlib/files/digest-zlib-1.2.2-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1b8aab042d40979e456194c468fd72c5 zlib-1.2.2.tar.bz2 371728
diff --git a/sys-libs/zlib/files/zlib-1.2.2-inftrees.patch b/sys-libs/zlib/files/zlib-1.2.2-inftrees.patch
deleted file mode 100644
index 0df8dbb35e4c..000000000000
--- a/sys-libs/zlib/files/zlib-1.2.2-inftrees.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- inftrees.c 2005-07-02 08:56:13.000000000 -0400
-+++ inftrees.c 2005-07-02 08:57:15.000000000 -0400
-@@ -134,7 +134,7 @@
- left -= count[len];
- if (left < 0) return -1; /* over-subscribed */
- }
-- if (left > 0 && (type == CODES || (codes - count[0] != 1)))
-+ if (left > 0 && (type == CODES || max != 1))
- return -1; /* incomplete set */
-
- /* generate offsets into symbol table for each length for sorting */
diff --git a/sys-libs/zlib/zlib-1.2.2-r1.ebuild b/sys-libs/zlib/zlib-1.2.2-r1.ebuild
deleted file mode 100644
index 8aa33789f387..000000000000
--- a/sys-libs/zlib/zlib-1.2.2-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.2-r1.ebuild,v 1.3 2005/07/06 23:06:41 spb Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard (de)compression library"
-HOMEPAGE="http://www.gzip.org/zlib/"
-SRC_URI="http://www.gzip.org/zlib/${P}.tar.bz2
- http://www.zlib.net/${P}.tar.bz2"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="build"
-
-RDEPEND=""
-
-pkg_setup() {
- tc-export CC RANLIB
- export AR="$(tc-getAR) rc"
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- # Make sure we link with glibc at all times
- epatch ${FILESDIR}/${PN}-1.2.1-glibc.patch
- # Needed for Alpha and prelink
- epatch ${FILESDIR}/${PN}-1.2.1-build-fPIC.patch
- # Only export global symbols, bug #32764
- epatch ${FILESDIR}/${P}-mapfile.patch
- # The configure script can be kind of dumb #55434
- epatch ${FILESDIR}/${PN}-1.2.1-configure.patch
- # fix shared library test on -fPIC dependant archs
- epatch ${FILESDIR}/${PN}-1.2.1-fPIC.patch
- # fix inflate vuln found by taviso@gentoo
- epatch ${FILESDIR}/${P}-inftrees.patch
-}
-
-src_compile() {
- ./configure --shared --prefix=/usr --libdir=/$(get_libdir) || die
- emake || die
-}
-
-src_install() {
- einstall libdir=${D}/$(get_libdir) || die
- rm "${D}"/$(get_libdir)/libz.a
- insinto /usr/include
- doins zconf.h zlib.h
-
- if ! use build ; then
- doman zlib.3
- dodoc FAQ README ChangeLog
- docinto txt
- dodoc algorithm.txt
- fi
-
- # we don't need the static lib in /lib
- # as it's only for compiling against
- dolib libz.a
-
- # all the shared libs go into /lib
- # for NFS based /usr
- into /
- dolib libz.so.${PV}
- ( cd ${D}/$(get_libdir) ; chmod 755 libz.so.* )
- dosym libz.so.${PV} /$(get_libdir)/libz.so
- dosym libz.so.${PV} /$(get_libdir)/libz.so.1
- gen_usr_ldscript libz.so
-}
diff --git a/sys-libs/zlib/zlib-1.2.2.ebuild b/sys-libs/zlib/zlib-1.2.2.ebuild
deleted file mode 100644
index a9c1986b3b56..000000000000
--- a/sys-libs/zlib/zlib-1.2.2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.2.ebuild,v 1.15 2005/05/17 03:59:34 vapier Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard (de)compression library"
-HOMEPAGE="http://www.gzip.org/zlib/"
-SRC_URI="http://www.gzip.org/zlib/${P}.tar.bz2
- http://www.zlib.net/${P}.tar.bz2"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="build"
-
-RDEPEND=""
-
-pkg_setup() {
- tc-export CC RANLIB
- export AR="$(tc-getAR) rc"
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- # Make sure we link with glibc at all times
- epatch ${FILESDIR}/${PN}-1.2.1-glibc.patch
- # Needed for Alpha and prelink
- epatch ${FILESDIR}/${PN}-1.2.1-build-fPIC.patch
- # Only export global symbols, bug #32764
- epatch ${FILESDIR}/${P}-mapfile.patch
- # The configure script can be kind of dumb #55434
- epatch ${FILESDIR}/${PN}-1.2.1-configure.patch
- # fix shared library test on -fPIC dependant archs
- epatch ${FILESDIR}/${PN}-1.2.1-fPIC.patch
-}
-
-src_compile() {
- ./configure --shared --prefix=/usr --libdir=/$(get_libdir) || die
- emake || die
-}
-
-src_install() {
- einstall libdir=${D}/$(get_libdir) || die
- rm "${D}"/$(get_libdir)/libz.a
- insinto /usr/include
- doins zconf.h zlib.h
-
- if ! use build ; then
- doman zlib.3
- dodoc FAQ README ChangeLog
- docinto txt
- dodoc algorithm.txt
- fi
-
- # we don't need the static lib in /lib
- # as it's only for compiling against
- dolib libz.a
-
- # all the shared libs go into /lib
- # for NFS based /usr
- into /
- dolib libz.so.${PV}
- ( cd ${D}/$(get_libdir) ; chmod 755 libz.so.* )
- dosym libz.so.${PV} /$(get_libdir)/libz.so
- dosym libz.so.${PV} /$(get_libdir)/libz.so.1
- gen_usr_ldscript libz.so
-}