summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-19 05:32:44 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-19 05:32:44 +0000
commite98f75417d34e48444b907fb5ea6d7dfc1de980d (patch)
tree59aa4357b2c35c3b2c456791be1259e5fbd8a5e5 /sys-libs/uclibc
parentimplement --missing flag for user-control over IUSE-missing behavior (diff)
downloadgentoo-2-e98f75417d34e48444b907fb5ea6d7dfc1de980d.tar.gz
gentoo-2-e98f75417d34e48444b907fb5ea6d7dfc1de980d.tar.bz2
gentoo-2-e98f75417d34e48444b907fb5ea6d7dfc1de980d.zip
use new --missing option with built_with_use
(Portage version: 2.1.2)
Diffstat (limited to 'sys-libs/uclibc')
-rw-r--r--sys-libs/uclibc/uclibc-0.9.27-r1.ebuild6
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28-r1.ebuild6
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28-r2.ebuild6
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.ebuild6
4 files changed, 12 insertions, 12 deletions
diff --git a/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild b/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
index 4cd66f804893..4e34c278513d 100644
--- a/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.21 2007/01/07 10:58:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.22 2007/01/19 05:32:44 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -78,12 +78,12 @@ pkg_setup() {
[[ -n ${UCLIBC_AND_GLIBC} ]] && return 0
[[ ${ROOT} != "/" ]] && return 0
- if ! built_with_use ${CATEGORY}/uclibc nls && use nls && ! use pregen ; then
+ if ! built_with_use --missing false ${CATEGORY}/uclibc nls && use nls && ! use pregen ; then
eerror "You previously built uclibc with USE=-nls."
eerror "You cannot generate locale data with this"
eerror "system. Please rerun emerge with USE=pregen."
die "host cannot support locales"
- elif built_with_use ${CATEGORY}/uclibc nls && ! use nls ; then
+ elif built_with_use --missing false ${CATEGORY}/uclibc nls && ! use nls ; then
eerror "You previously built uclibc with USE=nls."
eerror "Rebuilding uClibc with USE=-nls will prob"
eerror "destroy your system."
diff --git a/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild b/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild
index 1386947e77f3..c7ecf4b58f7b 100644
--- a/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild,v 1.6 2007/01/07 10:58:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild,v 1.7 2007/01/19 05:32:44 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -76,12 +76,12 @@ pkg_setup() {
[[ -n ${UCLIBC_AND_GLIBC} ]] && return 0
[[ ${ROOT} != "/" ]] && return 0
- if ! built_with_use ${CATEGORY}/uclibc nls && use nls && ! use pregen ; then
+ if ! built_with_use --missing false ${CATEGORY}/uclibc nls && use nls && ! use pregen ; then
eerror "You previously built uclibc with USE=-nls."
eerror "You cannot generate locale data with this"
eerror "system. Please rerun emerge with USE=pregen."
die "host cannot support locales"
- elif built_with_use ${CATEGORY}/uclibc nls && ! use nls ; then
+ elif built_with_use --missing false ${CATEGORY}/uclibc nls && ! use nls ; then
eerror "You previously built uclibc with USE=nls."
eerror "Rebuilding uClibc with USE=-nls will prob"
eerror "destroy your system."
diff --git a/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild b/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild
index fa78308b936d..9b0f271e1b75 100644
--- a/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild,v 1.1 2007/01/15 23:57:52 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild,v 1.2 2007/01/19 05:32:44 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -76,12 +76,12 @@ pkg_setup() {
[[ -n ${UCLIBC_AND_GLIBC} ]] && return 0
[[ ${ROOT} != "/" ]] && return 0
- if ! built_with_use ${CATEGORY}/uclibc nls && use nls && ! use pregen ; then
+ if ! built_with_use --missing false ${CATEGORY}/uclibc nls && use nls && ! use pregen ; then
eerror "You previously built uclibc with USE=-nls."
eerror "You cannot generate locale data with this"
eerror "system. Please rerun emerge with USE=pregen."
die "host cannot support locales"
- elif built_with_use ${CATEGORY}/uclibc nls && ! use nls ; then
+ elif built_with_use --missing false ${CATEGORY}/uclibc nls && ! use nls ; then
eerror "You previously built uclibc with USE=nls."
eerror "Rebuilding uClibc with USE=-nls will prob"
eerror "destroy your system."
diff --git a/sys-libs/uclibc/uclibc-0.9.28.ebuild b/sys-libs/uclibc/uclibc-0.9.28.ebuild
index 2da83e9623ec..70365eb8e21b 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.26 2007/01/07 10:58:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.27 2007/01/19 05:32:44 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -76,12 +76,12 @@ pkg_setup() {
[[ -n ${UCLIBC_AND_GLIBC} ]] && return 0
[[ ${ROOT} != "/" ]] && return 0
- if ! built_with_use ${CATEGORY}/uclibc nls && use nls && ! use pregen ; then
+ if ! built_with_use --missing false ${CATEGORY}/uclibc nls && use nls && ! use pregen ; then
eerror "You previously built uclibc with USE=-nls."
eerror "You cannot generate locale data with this"
eerror "system. Please rerun emerge with USE=pregen."
die "host cannot support locales"
- elif built_with_use ${CATEGORY}/uclibc nls && ! use nls ; then
+ elif built_with_use --missing false ${CATEGORY}/uclibc nls && ! use nls ; then
eerror "You previously built uclibc with USE=nls."
eerror "Rebuilding uClibc with USE=-nls will prob"
eerror "destroy your system."