summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-11 20:43:02 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-11 20:43:02 +0000
commitc844dcd56405e9a98e3f7a642ee69ae5b7225a01 (patch)
treebba08d8f7785925b4dd8960c93d5997fa7d1575a /sys-libs/tdb
parentPunt eclasses that were labeled for removal in 2009. (diff)
downloadgentoo-2-c844dcd56405e9a98e3f7a642ee69ae5b7225a01.tar.gz
gentoo-2-c844dcd56405e9a98e3f7a642ee69ae5b7225a01.tar.bz2
gentoo-2-c844dcd56405e9a98e3f7a642ee69ae5b7225a01.zip
Fix installation of shared objects with USE=-python. Thanks to Davide Pesavento for reporting.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/tdb')
-rw-r--r--sys-libs/tdb/ChangeLog9
-rw-r--r--sys-libs/tdb/tdb-1.2.0-r1.ebuild70
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-libs/tdb/ChangeLog b/sys-libs/tdb/ChangeLog
index 9f7fc034d89c..9d1e43560e21 100644
--- a/sys-libs/tdb/ChangeLog
+++ b/sys-libs/tdb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/tdb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.10 2010/01/04 18:03:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.11 2010/01/11 20:43:02 flameeyes Exp $
+
+*tdb-1.2.0-r1 (11 Jan 2010)
+
+ 11 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +tdb-1.2.0-r1.ebuild:
+ Fix installation of shared objects with USE=-python. Thanks to Davide
+ Pesavento for reporting.
*tdb-1.2.0 (04 Jan 2010)
diff --git a/sys-libs/tdb/tdb-1.2.0-r1.ebuild b/sys-libs/tdb/tdb-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..b870c66eb12f
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.2.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.0-r1.ebuild,v 1.1 2010/01/11 20:43:02 flameeyes Exp $
+
+EAPI="2"
+
+inherit confutils eutils autotools
+
+DESCRIPTION="Samba tdb"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+LICENSE="GPL-3"
+IUSE="python tools tdbtest"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="!<net-fs/samba-3.3
+ !<net-fs/samba-libs-3.4
+ "
+RDEPEND="${DEPEND}"
+
+BINPROGS="bin/tdbdump bin/tdbtool bin/tdbbackup"
+
+src_prepare() {
+ eautoconf -Ilibreplace
+ sed -e 's:$(SHLD_FLAGS) :$(SHLD_FLAGS) $(LDFLAGS) :' -i Makefile.in || die "sed failed"
+}
+
+src_configure() {
+
+ econf \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ $(use_enable python) \
+ || die "econf failed"
+
+}
+
+src_compile() {
+
+ emake dirs || die "emake dirs failed"
+ emake showflags || die "emake showflags failed"
+ emake shared-build || die "emake shared-build failed"
+ if use tools ; then emake ${BINPROGS} || die "emake binaries failed"; fi
+ if use python ; then emake build-python || die "emake build-python failed"; fi
+ if use tdbtest ; then make bin/tdbtest || die "emake tdbtest failed"; fi
+
+}
+
+src_install() {
+
+ dolib.a sharedbuild/lib/libtdb.a || die
+ # you need to install all the files, not just the .so one
+ dolib.so sharedbuild/lib/libtdb.so* || die
+
+ if use python || use tools ; then
+ emake install DESTDIR="${D}" || die "emake install failed"
+ fi
+
+ if ! use tools ; then
+ for prog in ${BINPROGS} ; do
+ rm -f "${D}/usr/${prog}"
+ done
+ fi
+
+ if use tdbtest ; then
+ dobin bin/tdbtest || die
+ fi
+
+}