summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-02-03 21:47:57 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-02-03 21:47:57 +0000
commita33b0cf742a6081627f036ad7946e81d08955ba4 (patch)
tree8bcc02e08a053e51fbc942419f97467ebef4f0d5 /sys-libs/pwdb
parenthouse cleaning (diff)
downloadgentoo-2-a33b0cf742a6081627f036ad7946e81d08955ba4.tar.gz
gentoo-2-a33b0cf742a6081627f036ad7946e81d08955ba4.tar.bz2
gentoo-2-a33b0cf742a6081627f036ad7946e81d08955ba4.zip
Multilib fixes.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-libs/pwdb')
-rw-r--r--sys-libs/pwdb/ChangeLog10
-rw-r--r--sys-libs/pwdb/Manifest14
-rw-r--r--sys-libs/pwdb/files/digest-pwdb-0.62-r11
-rw-r--r--sys-libs/pwdb/pwdb-0.62-r1.ebuild69
4 files changed, 81 insertions, 13 deletions
diff --git a/sys-libs/pwdb/ChangeLog b/sys-libs/pwdb/ChangeLog
index cb24fe791fe0..117b71df8e5a 100644
--- a/sys-libs/pwdb/ChangeLog
+++ b/sys-libs/pwdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/pwdb
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/ChangeLog,v 1.30 2004/07/02 08:50:20 eradicator Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/ChangeLog,v 1.31 2005/02/03 21:47:57 eradicator Exp $
+
+*pwdb-0.62-r1 (03 Feb 2005)
+
+ 03 Feb 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ +pwdb-0.62-r1.ebuild:
+ Multilib fixes.
02 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> pwdb-0.61-r4.ebuild,
pwdb-0.62.ebuild:
diff --git a/sys-libs/pwdb/Manifest b/sys-libs/pwdb/Manifest
index 50a31eacc9ed..63e224215c4c 100644
--- a/sys-libs/pwdb/Manifest
+++ b/sys-libs/pwdb/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 14ee08d4b2c3f66ae67e63abdf469831 ChangeLog 3612
+MD5 ce531c38b24e371fef317a71e0b42d11 ChangeLog 3741
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 2a91ac1f12a5da237c5d4e481b3cb201 pwdb-0.62-r1.ebuild 1713
MD5 2227b4c7862f4bd0a25843930bfa5ab7 pwdb-0.62.ebuild 1613
MD5 8cc9a65a57937cd962ff641cf94e40c3 files/digest-pwdb-0.62 61
MD5 0d0c7a6216f5cf079472dfe36ea9d71c files/passwd 143
MD5 bf4eb22a793eb0683d8c62b4677d66f8 files/pwdb-0.62-selinux.patch 10567
MD5 f2d1888e60ba62137f53ed5378eb7e25 files/pwdb-0.62-use-gcc-as-linker.patch 508
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFB2hkQroRuSHgZdywRAsu8AJ9ugAkeyUv+yyofBQwxqFOM/tMYxACgimQU
-Y6GbsMPDQIEFdtVFXGf6kTs=
-=9EKq
------END PGP SIGNATURE-----
+MD5 8cc9a65a57937cd962ff641cf94e40c3 files/digest-pwdb-0.62-r1 61
diff --git a/sys-libs/pwdb/files/digest-pwdb-0.62-r1 b/sys-libs/pwdb/files/digest-pwdb-0.62-r1
new file mode 100644
index 000000000000..fdf881196ce6
--- /dev/null
+++ b/sys-libs/pwdb/files/digest-pwdb-0.62-r1
@@ -0,0 +1 @@
+MD5 1a1fd0312040ef37aa741d09465774b4 pwdb-0.62.tar.gz 133183
diff --git a/sys-libs/pwdb/pwdb-0.62-r1.ebuild b/sys-libs/pwdb/pwdb-0.62-r1.ebuild
new file mode 100644
index 000000000000..fbdf2e87d663
--- /dev/null
+++ b/sys-libs/pwdb/pwdb-0.62-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.62-r1.ebuild,v 1.1 2005/02/03 21:47:57 eradicator Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Password database"
+HOMEPAGE="http://packages.gentoo.org/ebuilds/?pwdb-${PVR}"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+#KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
+# -r1 just has some multilib cleanups
+KEYWORDS="~amd64"
+IUSE="selinux"
+
+DEPEND="virtual/libc
+ selinux? ( sys-libs/libselinux )"
+
+src_unpack () {
+ unpack ${A}
+
+ cd ${S}
+ # Uses gcc as linker needed for hppa, but good idea in general.
+ epatch ${FILESDIR}/${P}-use-gcc-as-linker.patch
+
+ use selinux && epatch ${FILESDIR}/${P}-selinux.patch
+
+ sed -i \
+ -e "s/^DIRS = .*/DIRS = libpwdb/" \
+ -e "s:EXTRAS += :EXTRAS += ${CFLAGS} :" \
+ Makefile
+ sed -i -e "s/=gcc/=$(tc-getCC)/g" default.defs
+}
+
+src_compile() {
+ filter-flags -fstack-protector
+
+ # author has specified application to be compiled with `-g`
+ # no problem, but with ccc `-g` disables optimisation to make
+ # debugging easier, `-g3` enables debugging and optimisation
+ [ "${ARCH}" = "alpha" -a "${CC}" = "ccc" ] && append-flags -g3
+
+ emake || die
+}
+
+src_install() {
+ dodir /$(get_libdir) /usr/$(get_libdir) /usr/include/pwdb
+ make \
+ INCLUDED=${D}/usr/include/pwdb \
+ LIBDIR=${D}/$(get_libdir) \
+ LDCONFIG="echo" \
+ install || die
+
+ preplib /
+ mv ${D}/$(get_libdir)/*.a ${D}/usr/$(get_libdir)
+
+ # See bug #4411 for more info
+ gen_usr_ldscript libpwdb.so
+
+ insinto /etc
+ doins conf/pwdb.conf
+
+ dodoc CHANGES CREDITS README
+ dohtml -r doc
+ docinto txt
+ dodoc doc/*.txt
+}