summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-22 03:27:27 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-22 03:27:27 +0000
commit9d01752a369544304093e96c4aec5aa3ca9ccd17 (patch)
tree5f4bdace75a93b6c1cb8448af51bf4b3a2f5e753 /sys-libs/pwdb
parentRemoved dying on ldap use flag and completely disabled the flag, see bug #125435 (diff)
downloadgentoo-2-9d01752a369544304093e96c4aec5aa3ca9ccd17.tar.gz
gentoo-2-9d01752a369544304093e96c4aec5aa3ca9ccd17.tar.bz2
gentoo-2-9d01752a369544304093e96c4aec5aa3ca9ccd17.zip
merge patches and some LDFLAGS fixes from Diego Pettenò #126977
(Portage version: 2.1_pre6-r5)
Diffstat (limited to 'sys-libs/pwdb')
-rw-r--r--sys-libs/pwdb/files/pwdb-0.62-build.patch16
-rw-r--r--sys-libs/pwdb/files/pwdb-0.62-use-gcc-as-linker.patch11
-rw-r--r--sys-libs/pwdb/pwdb-0.62.ebuild4
3 files changed, 15 insertions, 16 deletions
diff --git a/sys-libs/pwdb/files/pwdb-0.62-build.patch b/sys-libs/pwdb/files/pwdb-0.62-build.patch
index 5e91d96209e8..78bd15caed8d 100644
--- a/sys-libs/pwdb/files/pwdb-0.62-build.patch
+++ b/sys-libs/pwdb/files/pwdb-0.62-build.patch
@@ -1,11 +1,23 @@
- drop ldconfig junk
- - add missing headers
- - add missing comma to supp_entry
+
+http://bugs.gentoo.org/126977
+ - respect user LDFLAGS
http://bugs.gentoo.org/126695
+ - add missing headers
+ - add missing comma to supp_entry
--- libpwdb/Makefile
+++ libpwdb/Makefile
+@@ -50,7 +50,7 @@
+
+
+ $(LIBDYNAME): $(LIBOBJ)
+- $(LD) -soname $(LIBSONAME) -x -shared -o $(LIBFILENAME) $(LIBOBJ) -lcrypt -lnsl -lc
++ $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,$(LIBSONAME) -Wl,-x -o $(LIBFILENAME) $(LIBOBJ) -lcrypt -lnsl -lc
+ @ln -sf $(LIBFILENAME) $@
+
+ $(LIBSTATIC): $(LIBOBJ)
@@ -69,7 +69,7 @@
$(INSTALL) -m 644 radius.h $(INCLUDED)/radius.h
$(INSTALL) -m 644 _pwdb_macros.h $(INCLUDED)/_pwdb_macros.h
diff --git a/sys-libs/pwdb/files/pwdb-0.62-use-gcc-as-linker.patch b/sys-libs/pwdb/files/pwdb-0.62-use-gcc-as-linker.patch
deleted file mode 100644
index 84a4c6bd6f7f..000000000000
--- a/sys-libs/pwdb/files/pwdb-0.62-use-gcc-as-linker.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- pwdb-0.62/libpwdb/Makefile 2003-03-24 09:42:42.000000000 +0000
-+++ pwdb-0.62/libpwdb/Makefile 2003-03-24 09:34:04.000000000 +0000
-@@ -50,7 +50,7 @@
-
-
- $(LIBDYNAME): $(LIBOBJ)
-- $(LD) -soname $(LIBSONAME) -x -shared -o $(LIBFILENAME) $(LIBOBJ) -lcrypt -lnsl -lc
-+ $(CC) -shared -Wl,-soname -Wl,$(LIBSONAME) -Wl,-x -o $(LIBFILENAME) $(LIBOBJ) -lcrypt -lnsl -lc
- @ln -sf $(LIBFILENAME) $@
-
- $(LIBSTATIC): $(LIBOBJ)
diff --git a/sys-libs/pwdb/pwdb-0.62.ebuild b/sys-libs/pwdb/pwdb-0.62.ebuild
index b185d15e7fbd..b3d5f9ed094c 100644
--- a/sys-libs/pwdb/pwdb-0.62.ebuild
+++ b/sys-libs/pwdb/pwdb-0.62.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.62.ebuild,v 1.23 2006/02/12 21:53:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/pwdb-0.62.ebuild,v 1.24 2006/03/22 03:27:26 vapier Exp $
inherit eutils flag-o-matic
@@ -21,8 +21,6 @@ src_unpack () {
cd "${S}"
epatch "${FILESDIR}"/${P}-build.patch
- # Uses gcc as linker needed for hppa, but good idea in general.
- epatch "${FILESDIR}"/${P}-use-gcc-as-linker.patch
use selinux && epatch "${FILESDIR}"/${P}-selinux.patch