summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-11-08 14:13:17 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-11-08 14:13:17 +0000
commit1e6c0fc088dcf9fd18d90d47db7c40df8e40b5d5 (patch)
treeab4ad0470092fc677cca4a3101ec2cfc18347f92 /sys-libs/musl
parentRemove old (Perl 5.16 cleanup) (diff)
downloadgentoo-2-1e6c0fc088dcf9fd18d90d47db7c40df8e40b5d5.tar.gz
gentoo-2-1e6c0fc088dcf9fd18d90d47db7c40df8e40b5d5.tar.bz2
gentoo-2-1e6c0fc088dcf9fd18d90d47db7c40df8e40b5d5.zip
Remove older 1.1.4 versions
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-libs/musl')
-rw-r--r--sys-libs/musl/ChangeLog6
-rw-r--r--sys-libs/musl/musl-1.1.4-r1.ebuild97
-rw-r--r--sys-libs/musl/musl-1.1.4.ebuild102
-rw-r--r--sys-libs/musl/musl-9999.ebuild4
4 files changed, 8 insertions, 201 deletions
diff --git a/sys-libs/musl/ChangeLog b/sys-libs/musl/ChangeLog
index c47762365bc1..71085ca5844c 100644
--- a/sys-libs/musl/ChangeLog
+++ b/sys-libs/musl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/musl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.36 2014/11/08 14:11:07 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.37 2014/11/08 14:13:17 blueness Exp $
+
+ 08 Nov 2014; Anthony G. Basile <blueness@gentoo.org> -musl-1.1.4-r1.ebuild,
+ -musl-1.1.4.ebuild, musl-9999.ebuild:
+ Remove older 1.1.4 versions
08 Nov 2014; Anthony G. Basile <blueness@gentoo.org> musl-1.1.5.ebuild:
Add epatch_user to test patches against musl
diff --git a/sys-libs/musl/musl-1.1.4-r1.ebuild b/sys-libs/musl/musl-1.1.4-r1.ebuild
deleted file mode 100644
index 94c4b3b90687..000000000000
--- a/sys-libs/musl/musl-1.1.4-r1.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-1.1.4-r1.ebuild,v 1.1 2014/10/12 17:19:54 blueness Exp $
-
-EAPI=5
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
- inherit git-2
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
-HOMEPAGE="http://www.musl-libc.org/"
-if [[ ${PV} != "9999" ]] ; then
- PATCH_VER=""
- SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
- KEYWORDS="-* ~amd64 ~arm ~mips ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="crosscompile_opts_headers-only"
-
-if [[ ${CATEGORY} != cross-* ]] ; then
- RDEPEND+=" sys-apps/getent"
-fi
-
-is_crosscompile() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-
-just_headers() {
- use crosscompile_opts_headers-only && is_crosscompile
-}
-
-pkg_setup() {
- if [ ${CTARGET} == ${CHOST} ] ; then
- case ${CHOST} in
- *-musl*) ;;
- *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
- esac
- fi
-}
-
-src_configure() {
- tc-getCC ${CTARGET}
- just_headers && export CC=true
-
- ./configure \
- --target="${CTARGET}" \
- --prefix="/usr" \
- --disable-gcc-wrapper
-}
-
-src_compile() {
- emake include/bits/alltypes.h || die
- just_headers && return 0
-
- emake || die
-}
-
-src_install() {
- local sysroot=${D}
- is_crosscompile && sysroot+="/usr/${CTARGET}"
-
- local target="install"
- just_headers && target="install-headers"
- emake DESTDIR="${sysroot}" ${target} || die
-
- # Make sure we install the sys-include symlink so that when
- # we build a 2nd stage cross-compiler, gcc finds the target
- # system headers correctly. See gcc/doc/gccinstall.info
- if is_crosscompile ; then
- dosym usr/include /usr/${CTARGET}/sys-include
- fi
-}
-
-pkg_postinst() {
- is_crosscompile && return 0
-
- [ "${ROOT}" != "/" ] && return 0
-
- # TODO: musl doesn't use ldconfig, instead here we can
- # create sym links to libraries outside of /lib and /usr/lib
- ldconfig
- # reload init ...
- /sbin/telinit U 2>/dev/null
-}
diff --git a/sys-libs/musl/musl-1.1.4.ebuild b/sys-libs/musl/musl-1.1.4.ebuild
deleted file mode 100644
index 8850bd8ed4aa..000000000000
--- a/sys-libs/musl/musl-1.1.4.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-1.1.4.ebuild,v 1.4 2014/10/11 11:43:31 blueness Exp $
-
-EAPI=5
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
- inherit git-2
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
-HOMEPAGE="http://www.musl-libc.org/"
-if [[ ${PV} != "9999" ]] ; then
- PATCH_VER=""
- SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
- KEYWORDS="-* amd64 arm ~mips x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="crosscompile_opts_headers-only nls"
-
-RDEPEND="nls? ( sys-devel/gettext )"
-if [[ ${CATEGORY} != cross-* ]] ; then
- RDEPEND+=" sys-apps/getent"
-fi
-
-is_crosscompile() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-
-just_headers() {
- use crosscompile_opts_headers-only && is_crosscompile
-}
-
-pkg_setup() {
- if [ ${CTARGET} == ${CHOST} ] ; then
- case ${CHOST} in
- *-musl*) ;;
- *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
- esac
- fi
-}
-
-src_configure() {
- tc-getCC ${CTARGET}
- just_headers && export CC=true
-
- ./configure \
- --target="${CTARGET}" \
- --prefix="/usr" \
- --disable-gcc-wrapper
-}
-
-src_compile() {
- emake include/bits/alltypes.h || die
- just_headers && return 0
-
- emake || die
-}
-
-src_install() {
- local sysroot=${D}
- is_crosscompile && sysroot+="/usr/${CTARGET}"
-
- local target="install"
- just_headers && target="install-headers"
- emake DESTDIR="${sysroot}" ${target} || die
-
- # Make sure we install the sys-include symlink so that when
- # we build a 2nd stage cross-compiler, gcc finds the target
- # system headers correctly. See gcc/doc/gccinstall.info
- if is_crosscompile ; then
- dosym usr/include /usr/${CTARGET}/sys-include
- fi
-
- # If we are going to use gnu's gettext then we have to
- # move musl's libintl out of the way.
- use nls && mv "${D}"/usr/include/libintl{,-musl}.h
-}
-
-pkg_postinst() {
- is_crosscompile && return 0
-
- [ "${ROOT}" != "/" ] && return 0
-
- # TODO: musl doesn't use ldconfig, instead here we can
- # create sym links to libraries outside of /lib and /usr/lib
- ldconfig
- # reload init ...
- /sbin/telinit U 2>/dev/null
-}
diff --git a/sys-libs/musl/musl-9999.ebuild b/sys-libs/musl/musl-9999.ebuild
index 7714a58140cf..9ceb7b0396b1 100644
--- a/sys-libs/musl/musl-9999.ebuild
+++ b/sys-libs/musl/musl-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-9999.ebuild,v 1.10 2014/10/11 20:14:11 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-9999.ebuild,v 1.11 2014/11/08 14:13:17 blueness Exp $
EAPI=5
@@ -49,6 +49,8 @@ pkg_setup() {
*) die "Use sys-devel/crossdev to build a musl toolchain" ;;
esac
fi
+
+ epatch_user
}
src_configure() {