summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-03-10 20:27:04 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-03-10 20:27:04 +0000
commita7edae18d1931ac051c0078981c591b60b87403d (patch)
treeba2f1e56617c7a811fd1ecbc3320f6667ef10419 /sys-libs/musl/musl-9999.ebuild
parentversion bump (diff)
downloadgentoo-2-a7edae18d1931ac051c0078981c591b60b87403d.tar.gz
gentoo-2-a7edae18d1931ac051c0078981c591b60b87403d.tar.bz2
gentoo-2-a7edae18d1931ac051c0078981c591b60b87403d.zip
Fix bug #503934, thanks okias
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-libs/musl/musl-9999.ebuild')
-rw-r--r--sys-libs/musl/musl-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-libs/musl/musl-9999.ebuild b/sys-libs/musl/musl-9999.ebuild
index 8633a711bc8f..9d90f9b3c169 100644
--- a/sys-libs/musl/musl-9999.ebuild
+++ b/sys-libs/musl/musl-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-9999.ebuild,v 1.7 2014/01/27 16:11:07 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-9999.ebuild,v 1.8 2014/03/10 20:27:04 blueness Exp $
EAPI=5
@@ -30,9 +30,10 @@ LICENSE="MIT"
SLOT="0"
IUSE="crosscompile_opts_headers-only nls"
-RDEPEND="
- nls? ( sys-devel/gettext )
- sys-apps/getent"
+RDEPEND="nls? ( sys-devel/gettext )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND+=" sys-apps/getent"
+fi
is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]