summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-23 02:51:15 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-23 02:51:15 +0000
commit0183b668ead722fe972d20400d9bca4fd27cd311 (patch)
tree9c3fa3f9d02df95032930a5dc73fe61fcc0cc2fa /sys-libs/db
parentnc debacle (diff)
downloadgentoo-2-0183b668ead722fe972d20400d9bca4fd27cd311.tar.gz
gentoo-2-0183b668ead722fe972d20400d9bca4fd27cd311.tar.bz2
gentoo-2-0183b668ead722fe972d20400d9bca4fd27cd311.zip
some fix0rs
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/db-4.0.14.ebuild40
1 files changed, 28 insertions, 12 deletions
diff --git a/sys-libs/db/db-4.0.14.ebuild b/sys-libs/db/db-4.0.14.ebuild
index 9525ae718577..f88ecbb16f1c 100644
--- a/sys-libs/db/db-4.0.14.ebuild
+++ b/sys-libs/db/db-4.0.14.ebuild
@@ -1,34 +1,50 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.9 2002/10/04 06:36:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.10 2002/10/23 02:51:15 seemant Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Berkeley DB"
+IUSE="tcltk java"
-SRC_URI="http://www.sleepycat.com/update/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${P}/build_unix
+DESCRIPTION="Berkeley DB"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
HOMEPAGE="http://www.sleepycat.com"
SLOT="4"
LICENSE="DB"
KEYWORDS="x86 ppc sparc sparc64"
-DEPEND="virtual/glibc"
+DEPEND="tcltk? ( dev-lang/tcl )
+ java? ( virtual/jdk )"
src_compile() {
- cd dist
+ local myconf
+
+ use java \
+ && myconf="${myconf} --enable-java" \
+ || myconf="${myconf} --disable-java"
+
+ use tcltk \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/lib" \
+ || myconf="${myconf} --disable-tcl"
- ./configure \
- --host=${CHOST} \
+ ../dist/configure \
--prefix=/usr \
+ --mandir=/usr/share/man \
--infodir=/usr/share/info \
- --mandir=/usr/share/man || die
- emake || die
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --enable-compat185 \
+ --enable-cxx \
+ --enable-posixmutexes \
+ ${myconf} || die
+
+ emake || make || die
}
src_install () {
- cd dist
- make prefix=${D}/usr install || die
+ einstall || die
dodir /usr/share/doc/${PF}/html
mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html/