summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-09-01 16:27:56 +0000
committerAlex Alexander <wired@gentoo.org>2010-09-01 16:27:56 +0000
commitff5d4232a2510ece018acbdd31783522cc7d26b8 (patch)
tree8d391a973ac2f80b2267d768ea6b8aba6759b541 /sys-kernel
parentVersion bump. (diff)
downloadgentoo-2-ff5d4232a2510ece018acbdd31783522cc7d26b8.tar.gz
gentoo-2-ff5d4232a2510ece018acbdd31783522cc7d26b8.tar.bz2
gentoo-2-ff5d4232a2510ece018acbdd31783522cc7d26b8.zip
new ebuilds for pf-kernel
(Portage version: 2.2_rc72/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/pf-sources/ChangeLog16
-rw-r--r--sys-kernel/pf-sources/metadata.xml13
-rw-r--r--sys-kernel/pf-sources/pf-sources-2.6.31_p9.ebuild50
-rw-r--r--sys-kernel/pf-sources/pf-sources-2.6.32_p16.ebuild50
-rw-r--r--sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild50
-rw-r--r--sys-kernel/pf-sources/pf-sources-2.6.34_p7.ebuild50
-rw-r--r--sys-kernel/pf-sources/pf-sources-2.6.35_p7.ebuild50
7 files changed, 279 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
new file mode 100644
index 000000000000..5254960d7731
--- /dev/null
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for sys-kernel/pf-sources
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.1 2010/09/01 16:27:56 wired Exp $
+
+*pf-sources-2.6.35_p7 (01 Sep 2010)
+*pf-sources-2.6.34_p7 (01 Sep 2010)
+*pf-sources-2.6.33_p4 (01 Sep 2010)
+*pf-sources-2.6.32_p16 (01 Sep 2010)
+*pf-sources-2.6.31_p9 (01 Sep 2010)
+
+ 01 Sep 2010; Alex Alexander <wired@gentoo.org>
+ +pf-sources-2.6.31_p9.ebuild, +pf-sources-2.6.32_p16.ebuild,
+ +pf-sources-2.6.33_p4.ebuild, +pf-sources-2.6.34_p7.ebuild,
+ +pf-sources-2.6.35_p7.ebuild, +metadata.xml:
+ new ebuilds for pf-kernel
+
diff --git a/sys-kernel/pf-sources/metadata.xml b/sys-kernel/pf-sources/metadata.xml
new file mode 100644
index 000000000000..b6ea656ecad1
--- /dev/null
+++ b/sys-kernel/pf-sources/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>wired@gentoo.org</email>
+ <name>Alex Alexander</name>
+</maintainer>
+<use>
+ <flag name='deblob'>Remove binary blobs from kernel sources to provide libre license compliance.</flag>
+</use>
+</pkgmetadata>
+
diff --git a/sys-kernel/pf-sources/pf-sources-2.6.31_p9.ebuild b/sys-kernel/pf-sources/pf-sources-2.6.31_p9.ebuild
new file mode 100644
index 000000000000..64930093edbc
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-2.6.31_p9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-2.6.31_p9.ebuild,v 1.1 2010/09/01 16:27:56 wired Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new useful features not merged into mainline"
+HOMEPAGE="http://pf-kernel.org.ua/"
+
+PF_PATCHSET="${PV/*_p}"
+PF_KERNEL="${PV/_p[0-9]*}"
+PF_KERNEL="${PF_KERNEL/_/-}"
+PF_FILE="patch-${PF_KERNEL}-pf${PF_PATCHSET}${COMPRESSTYPE}"
+PF_URI="http://pf-kernel.org.ua/sources/$(get_version_component_range 1-3)/${PF_FILE}"
+SRC_URI="${KERNEL_URI} ${PF_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR/_p/-pf}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."
diff --git a/sys-kernel/pf-sources/pf-sources-2.6.32_p16.ebuild b/sys-kernel/pf-sources/pf-sources-2.6.32_p16.ebuild
new file mode 100644
index 000000000000..1f1c51e19803
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-2.6.32_p16.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-2.6.32_p16.ebuild,v 1.1 2010/09/01 16:27:56 wired Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new useful features not merged into mainline"
+HOMEPAGE="http://pf-kernel.org.ua/"
+
+PF_PATCHSET="${PV/*_p}"
+PF_KERNEL="${PV/_p[0-9]*}"
+PF_KERNEL="${PF_KERNEL/_/-}"
+PF_FILE="patch-${PF_KERNEL}-pf${PF_PATCHSET}${COMPRESSTYPE}"
+PF_URI="http://pf-kernel.org.ua/sources/$(get_version_component_range 1-3)/${PF_FILE}"
+SRC_URI="${KERNEL_URI} ${PF_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR/_p/-pf}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."
diff --git a/sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild b/sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild
new file mode 100644
index 000000000000..3967682b10a1
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-2.6.33_p4.ebuild,v 1.1 2010/09/01 16:27:56 wired Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new useful features not merged into mainline"
+HOMEPAGE="http://pf-kernel.org.ua/"
+
+PF_PATCHSET="${PV/*_p}"
+PF_KERNEL="${PV/_p[0-9]*}"
+PF_KERNEL="${PF_KERNEL/_/-}"
+PF_FILE="patch-${PF_KERNEL}-pf${PF_PATCHSET}${COMPRESSTYPE}"
+PF_URI="http://pf-kernel.org.ua/sources/$(get_version_component_range 1-3)/${PF_FILE}"
+SRC_URI="${KERNEL_URI} ${PF_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR/_p/-pf}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."
diff --git a/sys-kernel/pf-sources/pf-sources-2.6.34_p7.ebuild b/sys-kernel/pf-sources/pf-sources-2.6.34_p7.ebuild
new file mode 100644
index 000000000000..839c6b39a79a
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-2.6.34_p7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-2.6.34_p7.ebuild,v 1.1 2010/09/01 16:27:56 wired Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new useful features not merged into mainline"
+HOMEPAGE="http://pf-kernel.org.ua/"
+
+PF_PATCHSET="${PV/*_p}"
+PF_KERNEL="${PV/_p[0-9]*}"
+PF_KERNEL="${PF_KERNEL/_/-}"
+PF_FILE="patch-${PF_KERNEL}-pf${PF_PATCHSET}${COMPRESSTYPE}"
+PF_URI="http://pf-kernel.org.ua/sources/$(get_version_component_range 1-3)/${PF_FILE}"
+SRC_URI="${KERNEL_URI} ${PF_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR/_p/-pf}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."
diff --git a/sys-kernel/pf-sources/pf-sources-2.6.35_p7.ebuild b/sys-kernel/pf-sources/pf-sources-2.6.35_p7.ebuild
new file mode 100644
index 000000000000..91adebc6ae9f
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-2.6.35_p7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-2.6.35_p7.ebuild,v 1.1 2010/09/01 16:27:56 wired Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new useful features not merged into mainline"
+HOMEPAGE="http://pf-kernel.org.ua/"
+
+PF_PATCHSET="${PV/*_p}"
+PF_KERNEL="${PV/_p[0-9]*}"
+PF_KERNEL="${PF_KERNEL/_/-}"
+PF_FILE="patch-${PF_KERNEL}-pf${PF_PATCHSET}${COMPRESSTYPE}"
+PF_URI="http://pf-kernel.org.ua/sources/$(get_version_component_range 1-3)/${PF_FILE}"
+SRC_URI="${KERNEL_URI} ${PF_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR/_p/-pf}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."