summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2005-01-16 14:44:21 +0000
committerChristian Birchinger <joker@gentoo.org>2005-01-16 14:44:21 +0000
commite2563401cef73dcf0b3c403487a31130b7f0c968 (patch)
tree850450064d61e81e78540e3e0f05494d9eb6e249 /sys-kernel
parentStable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-e2563401cef73dcf0b3c403487a31130b7f0c968.tar.gz
gentoo-2-e2563401cef73dcf0b3c403487a31130b7f0c968.tar.bz2
gentoo-2-e2563401cef73dcf0b3c403487a31130b7f0c968.zip
Security fixes from bug #77094
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog8
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r62
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.28-r6.ebuild63
3 files changed, 72 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index d0422b1f5bfb..14c389d826fe 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.75 2005/01/09 21:44:28 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.76 2005/01/16 14:44:21 joker Exp $
+
+*sparc-sources-2.4.28-r6 (16 Jan 2005)
+
+ 16 Jan 2005; Christian Birchinger <joker@gentoo.org>
+ +sparc-sources-2.4.28-r6.ebuild:
+ Security fixes from bug #77094
*sparc-sources-2.4.28-r5 (09 Jan 2005)
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r6 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r6
new file mode 100644
index 000000000000..b8c61b378ab5
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r6
@@ -0,0 +1,2 @@
+MD5 ac7735000d185bc7778c08288760a8a3 linux-2.4.28.tar.bz2 31064046
+MD5 5b077de3a3faa0418c80110a32779e23 patches-2.4.28-sparc-r6.tar.bz2 212386
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.28-r6.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.28-r6.ebuild
new file mode 100644
index 000000000000..4d8cbb863ad0
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.28-r6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.28-r6.ebuild,v 1.1 2005/01/16 14:44:21 joker Exp $
+
+IUSE="ultra1"
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="grsecurity" would not patch any patches whose names match
+# *grsecurity*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+inherit kernel eutils
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+[ "$OKV" == "" ] && OKV="${PV}"
+
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+PATCH_VERSION="${KV}"
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${PATCH_VERSION}.tar.bz2"
+
+S=${WORKDIR}/linux-${KV}
+KEYWORDS="~x86 -ppc sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+ cd ${PATCH_VERSION} || die "Unable to cd into ${PATCH_VERSION}"
+
+ kernel_src_unpack
+
+ # Patch the HME driver only on Ultra1 machines.
+ use ultra1 && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+}