summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-05-25 23:15:12 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-05-25 23:15:12 +0000
commitcb98c4a76ff2fddaee6a12d3565722231b850fb3 (patch)
tree90d9963f04c51998e7c6b9773552310327931580 /sys-kernel
parentVersion bump, mostly bugfix and compatibility with last GNUstep release (diff)
downloadgentoo-2-cb98c4a76ff2fddaee6a12d3565722231b850fb3.tar.gz
gentoo-2-cb98c4a76ff2fddaee6a12d3565722231b850fb3.tar.bz2
gentoo-2-cb98c4a76ff2fddaee6a12d3565722231b850fb3.zip
Add urgent powernow-k8 patch which fixes turbo clock behavior for the new Phenom II x6 processors
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/zen-sources/ChangeLog13
-rw-r--r--sys-kernel/zen-sources/files/powernow-k8-family10-model10_fix.patch34
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.32_p7-r1.ebuild54
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.33_p2-r1.ebuild54
4 files changed, 154 insertions, 1 deletions
diff --git a/sys-kernel/zen-sources/ChangeLog b/sys-kernel/zen-sources/ChangeLog
index d58a4fd3a9f3..d63830311f95 100644
--- a/sys-kernel/zen-sources/ChangeLog
+++ b/sys-kernel/zen-sources/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-kernel/zen-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.34 2010/05/18 15:32:26 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.35 2010/05/25 23:15:11 hwoarang Exp $
+
+*zen-sources-2.6.33_p2-r1 (25 May 2010)
+*zen-sources-2.6.32_p7-r1 (25 May 2010)
+
+ 25 May 2010; Markos Chandras <hwoarang@gentoo.org>
+ +files/powernow-k8-family10-model10_fix.patch,
+ +zen-sources-2.6.32_p7-r1.ebuild, +zen-sources-2.6.33_p2-r1.ebuild:
+ Add urgent powernow-k8 patch which fixes turbo clock behavior for the new
+ Phenom II x6 processors. Please visit
+ http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.33.y.git;a=comm
+ it;h=1ff21ff30e324d2e994a54baf9dc3df003985b60 for details
18 May 2010; Alex Alexander <wired@gentoo.org>
-zen-sources-2.6.31_p8.ebuild, -zen-sources-2.6.31_p9.ebuild,
diff --git a/sys-kernel/zen-sources/files/powernow-k8-family10-model10_fix.patch b/sys-kernel/zen-sources/files/powernow-k8-family10-model10_fix.patch
new file mode 100644
index 000000000000..10ad496ce57f
--- /dev/null
+++ b/sys-kernel/zen-sources/files/powernow-k8-family10-model10_fix.patch
@@ -0,0 +1,34 @@
+From 679370641e3675633cad222449262abbe93a4a2a Mon Sep 17 00:00:00 2001
+From: Mark Langsdorf <mark.langsdorf@amd.com>
+Date: Wed, 31 Mar 2010 21:56:45 +0200
+Subject: [PATCH] powernow-k8: Fix frequency reporting
+
+With F10, model 10, all valid frequencies are in the ACPI _PST table.
+
+Cc: <stable@kernel.org> # 33.x 32.x
+Signed-off-by: Mark Langsdorf <mark.langsdorf@amd.com>
+LKML-Reference: <1270065406-1814-6-git-send-email-bp@amd64.org>
+Signed-off-by: Borislav Petkov <borislav.petkov@amd.com>
+Reviewed-by: Thomas Renninger <trenn@suse.de>
+Signed-off-by: H. Peter Anvin <hpa@zytor.com>
+---
+ arch/x86/kernel/cpu/cpufreq/powernow-k8.c | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/arch/x86/kernel/cpu/cpufreq/powernow-k8.c b/arch/x86/kernel/cpu/cpufreq/powernow-k8.c
+index 52fce63..6f3dc8f 100644
+--- a/arch/x86/kernel/cpu/cpufreq/powernow-k8.c
++++ b/arch/x86/kernel/cpu/cpufreq/powernow-k8.c
+@@ -935,7 +935,8 @@ static int fill_powernow_table_pstate(struct powernow_k8_data *data,
+ powernow_table[i].index = index;
+
+ /* Frequency may be rounded for these */
+- if (boot_cpu_data.x86 == 0x10 || boot_cpu_data.x86 == 0x11) {
++ if ((boot_cpu_data.x86 == 0x10 && boot_cpu_data.x86_model < 10)
++ || boot_cpu_data.x86 == 0x11) {
+ powernow_table[i].frequency =
+ freq_from_fid_did(lo & 0x3f, (lo >> 6) & 7);
+ } else
+--
+1.7.1
+
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.32_p7-r1.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.32_p7-r1.ebuild
new file mode 100644
index 000000000000..72eab5bdc591
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-2.6.32_p7-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/zen-sources-2.6.32_p7-r1.ebuild,v 1.1 2010/05/25 23:15:11 hwoarang Exp $
+
+COMPRESSTYPE=".lzma"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="The Zen Kernel Sources v2.6"
+HOMEPAGE="http://zen-kernel.org"
+
+ZEN_PATCHSET="${PV/*_p}"
+ZEN_KERNEL="${PV/_p[0-9]*}"
+ZEN_KERNEL="${ZEN_KERNEL/_/-}"
+ZEN_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}.patch${COMPRESSTYPE}"
+ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${ZEN_FILE}"
+SRC_URI="${KERNEL_URI} ${ZEN_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="|| ( app-arch/xz-utils app-arch/lzma-utils )"
+
+KV_FULL="${PVR/_p/-zen}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the Zen developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_unpack(){
+ kernel-2_src_unpack
+ #powernow-k8 fix for AMD family10/model10 CPUs
+ epatch "${FILESDIR}"/powernow-k8-family10-model10_fix.patch
+ cd "${S}"
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
+}
+
+K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \
+${HOMEPAGE}. You may also visit #zen-sources on irc.rizon.net"
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.33_p2-r1.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.33_p2-r1.ebuild
new file mode 100644
index 000000000000..369dac183d65
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-2.6.33_p2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/zen-sources-2.6.33_p2-r1.ebuild,v 1.1 2010/05/25 23:15:11 hwoarang Exp $
+
+COMPRESSTYPE=".lzma"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="The Zen Kernel Sources v2.6"
+HOMEPAGE="http://zen-kernel.org"
+
+ZEN_PATCHSET="${PV/*_p}"
+ZEN_KERNEL="${PV/_p[0-9]*}"
+ZEN_KERNEL="${ZEN_KERNEL/_/-}"
+ZEN_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}.patch${COMPRESSTYPE}"
+ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${ZEN_FILE}"
+SRC_URI="${KERNEL_URI} ${ZEN_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="|| ( app-arch/xz-utils app-arch/lzma-utils )"
+
+KV_FULL="${PVR/_p/-zen}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the Zen developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_unpack(){
+ kernel-2_src_unpack
+ #powernow-k8 fix for AMD family10/model10 CPUs
+ epatch "${FILESDIR}"/powernow-k8-family10-model10_fix.patch
+ cd "${S}"
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
+}
+
+K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \
+${HOMEPAGE}. You may also visit #zen-sources on irc.rizon.net"