summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2012-09-18 22:33:44 +0000
committerRichard Yao <ryao@gentoo.org>2012-09-18 22:33:44 +0000
commit889e322faef5c9a031ce5676a822cb728b4ad51d (patch)
treed2d92efb01b1d2087e174f4d7493d6472eaab6d6 /sys-kernel
parentFix Manifest. (diff)
downloadgentoo-2-889e322faef5c9a031ce5676a822cb728b4ad51d.tar.gz
gentoo-2-889e322faef5c9a031ce5676a822cb728b4ad51d.tar.bz2
gentoo-2-889e322faef5c9a031ce5676a822cb728b4ad51d.zip
Add sys-kernel/spl-0.6.0_rc11 and reintroduce a patch that 0.6.0_rc10 needed
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/spl/ChangeLog9
-rw-r--r--sys-kernel/spl/files/spl-0.6.0_rc9-alias-km-sleep-with-km-pushpage.patch56
-rw-r--r--sys-kernel/spl/spl-0.6.0_rc11.ebuild89
3 files changed, 153 insertions, 1 deletions
diff --git a/sys-kernel/spl/ChangeLog b/sys-kernel/spl/ChangeLog
index 9b35557bc0de..ef8b1b528e35 100644
--- a/sys-kernel/spl/ChangeLog
+++ b/sys-kernel/spl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/spl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/ChangeLog,v 1.28 2012/09/18 22:12:45 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/ChangeLog,v 1.29 2012/09/18 22:33:44 ryao Exp $
+
+*spl-0.6.0_rc11 (18 Sep 2012)
+
+ 18 Sep 2012; Richard Yao <ryao@gentoo.org>
+ +files/spl-0.6.0_rc9-alias-km-sleep-with-km-pushpage.patch,
+ +spl-0.6.0_rc11.ebuild:
+ Add sys-kernel/spl-0.6.0_rc11 and reintroduce a patch that 0.6.0_rc10 needed
18 Sep 2012; Richard Yao <ryao@gentoo.org>
-files/spl-0.6.0_rc9-alias-km-sleep-with-km-pushpage.patch,
diff --git a/sys-kernel/spl/files/spl-0.6.0_rc9-alias-km-sleep-with-km-pushpage.patch b/sys-kernel/spl/files/spl-0.6.0_rc9-alias-km-sleep-with-km-pushpage.patch
new file mode 100644
index 000000000000..fb0e5914e773
--- /dev/null
+++ b/sys-kernel/spl/files/spl-0.6.0_rc9-alias-km-sleep-with-km-pushpage.patch
@@ -0,0 +1,56 @@
+From 5c072b45b66e841ebc7952db7860c2ee7b024b08 Mon Sep 17 00:00:00 2001
+From: Richard Yao <ryao@cs.stonybrook.edu>
+Date: Mon, 25 Jun 2012 20:05:00 -0400
+Subject: [PATCH] Make KM_SLEEP an alias of KM_PUSHPAGE Use GFP_NOIO in
+ KM_SLEEP
+
+This should prevent direct reclaim issues without requiring
+Linux-specific changes to code from Solaris. This is what is done in
+FreeBSD.
+
+Note that a change to __taskq_dispatch() module/spl/spl-taskq.c is
+needed to make this work. Changing KM_PUSHPAGE to use GFP_NOIO is fine,
+but adding __GFP_HIGH to that triggers a hard-coded panic in
+__taskq_dispatch() during zvol initialization. Removing the hard coded
+panic has no ill effects.
+
+Signed-off-by: Richard Yao <ryao@cs.stonybrook.edu>
+---
+ include/sys/kmem.h | 2 +-
+ module/spl/spl-taskq.c | 7 ++++---
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/include/sys/kmem.h b/include/sys/kmem.h
+index 796af44..633278b 100644
+--- a/include/sys/kmem.h
++++ b/include/sys/kmem.h
+@@ -41,7 +41,7 @@
+ /*
+ * Memory allocation interfaces
+ */
+-#define KM_SLEEP GFP_KERNEL /* Can sleep, never fails */
++#define KM_SLEEP (GFP_NOIO | __GFP_HIGH) /* Can sleep, never fails */
+ #define KM_NOSLEEP GFP_ATOMIC /* Can not sleep, may fail */
+ #define KM_PUSHPAGE (GFP_NOIO | __GFP_HIGH) /* Use reserved memory */
+ #define KM_NODEBUG __GFP_NOWARN /* Suppress warnings */
+diff --git a/module/spl/spl-taskq.c b/module/spl/spl-taskq.c
+index 0c546c7..5ab387e 100644
+--- a/module/spl/spl-taskq.c
++++ b/module/spl/spl-taskq.c
+@@ -255,9 +255,10 @@
+ if (!(flags & (TQ_SLEEP | TQ_NOSLEEP)))
+ flags |= TQ_SLEEP;
+
+- if (unlikely(in_atomic() && (flags & TQ_SLEEP)))
+- PANIC("May schedule while atomic: %s/0x%08x/%d\n",
+- current->comm, preempt_count(), current->pid);
++ /* FIXME: Why does this fail when KM_SLEEP contains __GFP_HIGHMEM? */
++ //if (unlikely(in_atomic() && (flags & TQ_SLEEP)))
++ // PANIC("May schedule while atomic: %s/0x%08x/%d\n",
++ // current->comm, preempt_count(), current->pid);
+
+ spin_lock_irqsave(&tq->tq_lock, tq->tq_lock_flags);
+
+--
+1.7.10
+
diff --git a/sys-kernel/spl/spl-0.6.0_rc11.ebuild b/sys-kernel/spl/spl-0.6.0_rc11.ebuild
new file mode 100644
index 000000000000..fbe55a134e8b
--- /dev/null
+++ b/sys-kernel/spl/spl-0.6.0_rc11.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/spl-0.6.0_rc11.ebuild,v 1.1 2012/09/18 22:33:44 ryao Exp $
+
+EAPI="4"
+AUTOTOOLS_AUTORECONF="1"
+
+inherit flag-o-matic linux-mod autotools-utils
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/zfsonlinux/${PN}.git"
+else
+ inherit eutils versionator
+ MY_PV=$(replace_version_separator 3 '-')
+ SRC_URI="https://github.com/downloads/zfsonlinux/${PN}/${PN}-${MY_PV}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="The Solaris Porting Layer is a Linux kernel module which provides many of the Solaris kernel APIs"
+HOMEPAGE="http://zfsonlinux.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+IUSE="custom-cflags debug"
+RESTRICT="test"
+
+RDEPEND="!sys-devel/spl"
+
+AT_M4DIR="config"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+pkg_setup() {
+ CONFIG_CHECK="
+ !DEBUG_LOCK_ALLOC
+ !GRKERNSEC_HIDESYM
+ MODULES
+ KALLSYMS
+ !PAX_KERNEXEC_PLUGIN_METHOD_OR
+ ZLIB_DEFLATE
+ ZLIB_INFLATE
+ "
+
+ kernel_is ge 2 6 26 || die "Linux 2.6.26 or newer required"
+
+ [ ${PV} != "9999" ] && \
+ { kernel_is le 3 5 || die "Linux 3.5 is the latest supported version."; }
+
+ check_extra_config
+}
+
+src_prepare() {
+ # Workaround for hard coded path
+ sed -i "s|/sbin/lsmod|/bin/lsmod|" scripts/check.sh || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ set_arch_to_kernel
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --sbindir="${EPREFIX}/sbin"
+ --with-config=all
+ --with-linux="${KV_DIR}"
+ --with-linux-obj="${KV_OUT_DIR}"
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ if [[ ! -e /proc/modules ]]
+ then
+ die "Missing /proc/modules"
+ elif [[ $UID -ne 0 ]]
+ then
+ ewarn "Cannot run make check tests with FEATURES=userpriv."
+ ewarn "Skipping make check tests."
+ elif grep -q '^spl ' /proc/modules
+ then
+ ewarn "Cannot run make check tests with module spl loaded."
+ ewarn "Skipping make check tests."
+ else
+ autotools-utils_src_test
+ fi
+}