summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-08-03 08:23:48 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-08-03 08:23:48 +0000
commit6e0ae00a70f93e7a2fb498924c3753b1bfe10f09 (patch)
tree5a22987e4b99ba4b791043325159974cb4e0799f /sys-kernel
parentvanilla-3.14.48 + genpatches-3.14-53 + grsecurity-3.1-3.14.48-201508020901 (diff)
downloadgentoo-2-6e0ae00a70f93e7a2fb498924c3753b1bfe10f09.tar.gz
gentoo-2-6e0ae00a70f93e7a2fb498924c3753b1bfe10f09.tar.bz2
gentoo-2-6e0ae00a70f93e7a2fb498924c3753b1bfe10f09.zip
vanilla-4.1.3 + genpatches-4.1-7 + grsecurity-3.1-4.1.3-201508011613
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-4.1.3-r3.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index c35f61ebe468..c8bdeb6c73b7 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1330 2015/08/03 08:20:38 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1331 2015/08/03 08:23:48 blueness Exp $
+
+*hardened-sources-4.1.3-r3 (03 Aug 2015)
+
+ 03 Aug 2015; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-4.1.3-r3.ebuild:
+ vanilla-4.1.3 + genpatches-4.1-7 + grsecurity-3.1-4.1.3-201508011613
*hardened-sources-3.14.48-r3 (03 Aug 2015)
diff --git a/sys-kernel/hardened-sources/hardened-sources-4.1.3-r3.ebuild b/sys-kernel/hardened-sources/hardened-sources-4.1.3-r3.ebuild
new file mode 100644
index 000000000000..a678752b9d2f
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-4.1.3-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-4.1.3-r3.ebuild,v 1.1 2015/08/03 08:23:48 blueness Exp $
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="7"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-4"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="
+ 1500_XATTR_USER_PREFIX.patch
+ 2900_dev-root-proc-mount-fix.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.1*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}