summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2004-02-18 22:41:31 +0000
committerChristian Birchinger <joker@gentoo.org>2004-02-18 22:41:31 +0000
commit66c5e5b00531a02f8e6d2c460de8e6ab3861a4f9 (patch)
tree9815aa8faf40766b29ac75b0a4de46a75c58c9fa /sys-kernel
parentfix to ensure digest integrity. repoman MUST be used with FEATURES='cvs' (diff)
downloadgentoo-2-66c5e5b00531a02f8e6d2c460de8e6ab3861a4f9.tar.gz
gentoo-2-66c5e5b00531a02f8e6d2c460de8e6ab3861a4f9.tar.bz2
gentoo-2-66c5e5b00531a02f8e6d2c460de8e6ab3861a4f9.zip
Added a mremap_unmap security fix
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog8
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.24-r22
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.24-r2.ebuild61
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 908e75449b8b..4355b280075a 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.47 2004/01/26 22:06:26 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.48 2004/02/18 22:41:31 joker Exp $
+
+*sparc-sources-2.4.24-r2 (18 Feb 2004)
+
+ 18 Feb 2004; Christian Birchinger <joker@gentoo.org>
+ sparc-sources-2.4.24-r2.ebuild:
+ Added a mremap_unmap security fix
*sparc-sources-2.4.24-r1 (26 Jan 2004)
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.24-r2 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.24-r2
new file mode 100644
index 000000000000..2f797ac078e8
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.24-r2
@@ -0,0 +1,2 @@
+MD5 1e055c42921b2396a559d84df4c3d9aa linux-2.4.24.tar.bz2 29837818
+MD5 6dd2e159dcf989a4a00dc24775032011 patches-2.4.24-sparc-r2.tar.bz2 139608
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.24-r2.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.24-r2.ebuild
new file mode 100644
index 000000000000..054c14e34611
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.24-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.24-r2.ebuild,v 1.1 2004/02/18 22:41:31 joker Exp $
+
+IUSE="ultra1"
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="grsecurity" would not patch any patches whose names match
+# *grsecurity*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+inherit kernel
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+[ "$OKV" == "" ] && OKV="${PV}"
+
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+
+S=${WORKDIR}/linux-${KV}
+KEYWORDS="~x86 -ppc ~sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+ cd ${KV} || die "Unable to cd into ${KV}"
+
+ kernel_src_unpack
+
+ # Patch the HME driver only on Ultra1 machines.
+ use ultra1 && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+}