summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael J. Cohen <mjc@gentoo.org>2002-06-16 03:12:19 +0000
committerMichael J. Cohen <mjc@gentoo.org>2002-06-16 03:12:19 +0000
commit3335397f6a112580109577af8d436e02898311a9 (patch)
tree58b4056b063065c22ece09e9c7c2eb604d4cb9dd /sys-kernel
parentVersion update. Removed 1.5.0_rcs. (diff)
downloadgentoo-2-3335397f6a112580109577af8d436e02898311a9.tar.gz
gentoo-2-3335397f6a112580109577af8d436e02898311a9.tar.bz2
gentoo-2-3335397f6a112580109577af8d436e02898311a9.zip
digests for mjc-sources 2.4.19-pre10-mjc1
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/mjc-sources/files/digest-mjc-sources-2.4.19_pre102
-rw-r--r--sys-kernel/mjc-sources/mjc-sources-2.4.19_pre10.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/sys-kernel/mjc-sources/files/digest-mjc-sources-2.4.19_pre10 b/sys-kernel/mjc-sources/files/digest-mjc-sources-2.4.19_pre10
new file mode 100644
index 000000000000..44fc53f85b12
--- /dev/null
+++ b/sys-kernel/mjc-sources/files/digest-mjc-sources-2.4.19_pre10
@@ -0,0 +1,2 @@
+MD5 ad92859baaa837847b34d842b9f39d38 linux-2.4.18.tar.bz2 24161675
+MD5 43c24d9f822f963634343295a264aee8 mjc-sources-2.4.19_pre10-ac2-mjc.tbz2 6768640
diff --git a/sys-kernel/mjc-sources/mjc-sources-2.4.19_pre10.ebuild b/sys-kernel/mjc-sources/mjc-sources-2.4.19_pre10.ebuild
new file mode 100644
index 000000000000..ec0f090c1895
--- /dev/null
+++ b/sys-kernel/mjc-sources/mjc-sources-2.4.19_pre10.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.18
+KV=${P}-mjc2
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+#What's in this kernel?
+#
+#INCLUDED:
+# from http://www.kernel.org (ac):
+# 2.4.19-pre10-ac2
+# from http://www.infolinux.de/jp13:
+# HZ config support and others
+# from http://www.sourceforge.net/projects/wolk
+# lots of little things
+# XXX: FILL THIS STUFF IN =)
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 ftp://ohdarn.net/gentoo/${P}-ac2-mjc.tbz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+DEPEND="${DEPEND} app-admin/addpatches"
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+
+# Now we need to deal with the tarball of patches.
+
+ unpack ${P}-ac2-mjc.tbz2
+ addpatches gentoo-patches linux-${KV}
+
+ cd linux-${KV}
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *O
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}