summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-23 18:18:21 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-23 18:18:21 +0000
commit13429b0b2ca491d86bfc9999a30fcbefc4e3a9a3 (patch)
tree949ad95cbf752a76b6a80ebf0012d7f79cd8a10c /sys-kernel
parentmessed up header (diff)
downloadgentoo-2-13429b0b2ca491d86bfc9999a30fcbefc4e3a9a3.tar.gz
gentoo-2-13429b0b2ca491d86bfc9999a30fcbefc4e3a9a3.tar.bz2
gentoo-2-13429b0b2ca491d86bfc9999a30fcbefc4e3a9a3.zip
new testing kernel
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/lolo-sources/ChangeLog28
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre22
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre2.ebuild53
3 files changed, 81 insertions, 2 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index 7d5c458a8e87..2abb3b9c8527 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,10 +1,34 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.15 2002/10/17 19:16:46 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.16 2002/10/23 18:18:21 lostlogic Exp $
+
+*lolo-sources-2.4.20.1_pre2 (23 Oct 2002)
+
+ 23 Oct 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.20.1_pre2.ebuild:
+
+ Changes from _pre1:
+ - Update gentoo FB logos from seemant's sparc stuff
+ - Sort out some of the docs for patches.txt
+ - update grsecurity to 1.9.7d
+ - Fix the grsecurity security issue.
+ - Fix EVMS compilation
+ - I actually test compiled this one with a "all" configuration... only
+ a few problems in mostly unused drivers, please test this one.
+
+ Additional todo:
+ - Stuff from -aa and other sources from http://ohdarn.net/gentoo/used
+ thanks to MJC
+ - Figure out why the heck this thing breaks my VM like mad when using
+ accelerated nvidia-kernel drivers...
+ - <mjc> lostlogic: one of andreas patches adds CMPXCHG8 to the
+ processor stuff in config.in
+ - <mjc> the gcc31 options need it too
+ - <mjc> define_bool CONFIG_X86_CMPXCHG8 y
+
*lolo-sources-2.4.20.1_pre1 (16 Oct 2002)
- 16 Oct 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.20.11_pre1.ebuild:
+ 16 Oct 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.20.1_pre1.ebuild:
The long awaited of the 2.4.20 series of stuff, this one is still missing stuff.
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre2 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre2
new file mode 100644
index 000000000000..f28d35e48876
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre2
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 27e8ce3bd8b2e210030138bfb1f87f13 patches-2.4.20-lolo-r1_pre2.tar.bz2 6085630
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre2.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre2.ebuild
new file mode 100644
index 000000000000..7640e8739dc2
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre2.ebuild,v 1.1 2002/10/23 18:18:21 lostlogic Exp $
+
+IUSE="crypt xfs build acpi4linux"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.19"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ # This is the XFS filesystem from SGI, use at your own risk ;)
+ [ `use xfs` ] || rm *xfs*
+
+ # This is the latest release of ACPI from
+ # http://www.sourceforge.net/projects/acpi
+ [ `use acpi4linux` ] || rm 70*
+
+ kernel_src_unpack
+}