summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStratos Psomadakis <psomas@gentoo.org>2013-05-09 13:49:58 +0000
committerStratos Psomadakis <psomas@gentoo.org>2013-05-09 13:49:58 +0000
commit52e2cdec71cf90407bef004d0865cda84dcd8c48 (patch)
tree7bf0257623651ff73cb57b4fae6634cf4176edd6 /sys-kernel/rt-sources
parentStable for HPPA (bug #469092). (diff)
downloadgentoo-2-52e2cdec71cf90407bef004d0865cda84dcd8c48.tar.gz
gentoo-2-52e2cdec71cf90407bef004d0865cda84dcd8c48.tar.bz2
gentoo-2-52e2cdec71cf90407bef004d0865cda84dcd8c48.zip
Version bump
Signed-off-by: Stratos Psomadakis <psomas@gentoo.org> (Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key BC35D737)
Diffstat (limited to 'sys-kernel/rt-sources')
-rw-r--r--sys-kernel/rt-sources/ChangeLog7
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.8.11_p8.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-kernel/rt-sources/ChangeLog b/sys-kernel/rt-sources/ChangeLog
index e95d9dfb4221..a842de95368b 100644
--- a/sys-kernel/rt-sources/ChangeLog
+++ b/sys-kernel/rt-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/rt-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.22 2013/03/28 12:47:45 psomas Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.23 2013/05/09 13:49:58 psomas Exp $
+
+*rt-sources-3.8.11_p8 (09 May 2013)
+
+ 09 May 2013; <psomas@gentoo.org> +rt-sources-3.8.11_p8.ebuild:
+ Version bump
*rt-sources-3.4.36_p50 (28 Mar 2013)
diff --git a/sys-kernel/rt-sources/rt-sources-3.8.11_p8.ebuild b/sys-kernel/rt-sources/rt-sources-3.8.11_p8.ebuild
new file mode 100644
index 000000000000..2de8ae2a26e1
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-3.8.11_p8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/rt-sources-3.8.11_p8.ebuild,v 1.1 2013/05/09 13:49:58 psomas Exp $
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit versionator
+
+CKV="$(get_version_component_range 1-3)"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst(){
+
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."