summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-23 11:07:21 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-23 11:07:21 +0000
commitb24e8382adadf0a29d35d41c7d50ad23699bc113 (patch)
tree50f10d5f797079cf4ce4888913fe682f0cca4891 /sys-kernel/aufs-sources
parentLinux patches 3.0.101 and 3.4.67. (diff)
downloadgentoo-2-b24e8382adadf0a29d35d41c7d50ad23699bc113.tar.gz
gentoo-2-b24e8382adadf0a29d35d41c7d50ad23699bc113.tar.bz2
gentoo-2-b24e8382adadf0a29d35d41c7d50ad23699bc113.zip
sys-kernel/aufs-sources: Bump to latest linux and genpatches release
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-kernel/aufs-sources')
-rw-r--r--sys-kernel/aufs-sources/ChangeLog7
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.4.67.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/sys-kernel/aufs-sources/ChangeLog b/sys-kernel/aufs-sources/ChangeLog
index b239882a4ab8..e9d3566386cf 100644
--- a/sys-kernel/aufs-sources/ChangeLog
+++ b/sys-kernel/aufs-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/aufs-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.66 2013/10/19 09:51:50 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.67 2013/10/23 11:07:21 jlec Exp $
+
+*aufs-sources-3.4.67 (23 Oct 2013)
+
+ 23 Oct 2013; Justin Lecher <jlec@gentoo.org> +aufs-sources-3.4.67.ebuild:
+ Bump to latest linux and genpatches release
*aufs-sources-3.11.6 (19 Oct 2013)
*aufs-sources-3.10.17 (19 Oct 2013)
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.4.67.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.4.67.ebuild
new file mode 100644
index 000000000000..2566dc3f47db
--- /dev/null
+++ b/sys-kernel/aufs-sources/aufs-sources-3.4.67.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.4.67.ebuild,v 1.1 2013/10/23 11:07:21 jlec Exp $
+
+EAPI=5
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="48"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+AUFS_VERSION=3.4_p20131014
+AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
+# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs3-standalone aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
+AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
+
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
+IUSE="deblob module proc vanilla"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${AUFS_URI}
+ !vanilla? ( ${GENPATCHES_URI} )
+ "
+
+PDEPEND=">=sys-fs/aufs-util-3.2"
+
+src_unpack() {
+ if use vanilla; then
+ unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
+ ewarn "You are using USE=vanilla"
+ ewarn "This will drop all support from the gentoo kernel security team"
+ fi
+
+ UNIPATCH_LIST=""${WORKDIR}"/aufs3-kbuild.patch "${WORKDIR}"/aufs3-base.patch"
+ use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"
+ use proc && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-proc_map.patch"
+ unpack ${AUFS_TARBALL}
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ if ! use module; then
+ sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ if ! use proc; then
+ sed '/config AUFS_PROC_MAP/,/^$/d' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ cp -f "${WORKDIR}"/include/linux/aufs_type.h include/linux/aufs_type.h || die
+ cp -f "${WORKDIR}"/include/linux/aufs_type.h include/linux/aufs_type.h || die
+ cp -rf "${WORKDIR}"/{Documentation,fs} . || die
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+ has_version sys-fs/aufs-util && \
+ einfo "In order to use aufs FS you need to install sys-fs/aufs-util"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}