summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-13 16:48:54 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-13 16:48:54 +0000
commit572f2ae8a2fc996eb77c08827799c875edd8e4a1 (patch)
treec63b0112bb32f2cee4a3e5ebc8ec6372be93e721 /sys-kernel/aufs-sources
parentMasked >=sys-devel/make-4.0 for testing (diff)
downloadgentoo-2-572f2ae8a2fc996eb77c08827799c875edd8e4a1.tar.gz
gentoo-2-572f2ae8a2fc996eb77c08827799c875edd8e4a1.tar.bz2
gentoo-2-572f2ae8a2fc996eb77c08827799c875edd8e4a1.zip
sys-kernel/aufs-sources: Add support for vanilla-sources
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-kernel/aufs-sources')
-rw-r--r--sys-kernel/aufs-sources/ChangeLog6
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.10.15.ebuild25
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.11.4.ebuild25
-rw-r--r--sys-kernel/aufs-sources/metadata.xml1
4 files changed, 42 insertions, 15 deletions
diff --git a/sys-kernel/aufs-sources/ChangeLog b/sys-kernel/aufs-sources/ChangeLog
index 81f402c140fb..25b4dd195bb7 100644
--- a/sys-kernel/aufs-sources/ChangeLog
+++ b/sys-kernel/aufs-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/aufs-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.62 2013/10/08 11:46:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.63 2013/10/13 16:48:54 jlec Exp $
+
+ 13 Oct 2013; Justin Lecher <jlec@gentoo.org> aufs-sources-3.10.15.ebuild,
+ aufs-sources-3.11.4.ebuild, metadata.xml:
+ Add support for vanilla-sources
*aufs-sources-3.11.4 (08 Oct 2013)
*aufs-sources-3.10.15 (08 Oct 2013)
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.10.15.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.10.15.ebuild
index ecd39f86dcd6..f381de2f52da 100644
--- a/sys-kernel/aufs-sources/aufs-sources-3.10.15.ebuild
+++ b/sys-kernel/aufs-sources/aufs-sources-3.10.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.10.15.ebuild,v 1.1 2013/10/08 11:46:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.10.15.ebuild,v 1.2 2013/10/13 16:48:54 jlec Exp $
EAPI=5
@@ -19,21 +19,32 @@ AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
KEYWORDS="~amd64 ~x86"
HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
-IUSE="deblob experimental module proc"
+IUSE="deblob experimental module proc vanilla"
DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
-SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${AUFS_URI}"
-
-UNIPATCH_LIST="
- "${WORKDIR}"/aufs3-kbuild.patch
- "${WORKDIR}"/aufs3-base.patch"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${AUFS_URI}
+ !vanilla? ( ${GENPATCHES_URI} )
+ "
PDEPEND=">=sys-fs/aufs-util-3.9"
src_unpack() {
+ if use vanilla; then
+ unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
+ ewarn "You are using USE=vanilla"
+ ewarn "This will drop all support from the gentoo kernel security team"
+ fi
+
+ UNIPATCH_LIST=""${WORKDIR}"/aufs3-kbuild.patch "${WORKDIR}"/aufs3-base.patch"
+
use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"
use proc && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-proc_map.patch"
+
unpack ${AUFS_TARBALL}
+
kernel-2_src_unpack
}
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.11.4.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.11.4.ebuild
index be59dc3e25e0..bc5fb663b6a6 100644
--- a/sys-kernel/aufs-sources/aufs-sources-3.11.4.ebuild
+++ b/sys-kernel/aufs-sources/aufs-sources-3.11.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.11.4.ebuild,v 1.1 2013/10/08 11:46:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.11.4.ebuild,v 1.2 2013/10/13 16:48:54 jlec Exp $
EAPI=5
@@ -19,21 +19,32 @@ AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
KEYWORDS="~amd64 ~x86"
HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
-IUSE="deblob experimental module proc"
+IUSE="deblob experimental module proc vanilla"
DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
-SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${AUFS_URI}"
-
-UNIPATCH_LIST="
- "${WORKDIR}"/aufs3-kbuild.patch
- "${WORKDIR}"/aufs3-base.patch"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${AUFS_URI}
+ !vanilla? ( ${GENPATCHES_URI} )
+ "
PDEPEND=">=sys-fs/aufs-util-3.9"
src_unpack() {
+ if use vanilla; then
+ unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
+ ewarn "You are using USE=vanilla"
+ ewarn "This will drop all support from the gentoo kernel security team"
+ fi
+
+ UNIPATCH_LIST=""${WORKDIR}"/aufs3-kbuild.patch "${WORKDIR}"/aufs3-base.patch"
+
use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"
use proc && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-proc_map.patch"
+
unpack ${AUFS_TARBALL}
+
kernel-2_src_unpack
}
diff --git a/sys-kernel/aufs-sources/metadata.xml b/sys-kernel/aufs-sources/metadata.xml
index a3a421aab033..99faef1d09f4 100644
--- a/sys-kernel/aufs-sources/metadata.xml
+++ b/sys-kernel/aufs-sources/metadata.xml
@@ -9,6 +9,7 @@
<flag name="experimental">Apply experimental patches; for more information, see "https://wiki.gentoo.org/wiki/Project:Kernel/Experimental".</flag>
<flag name="module">Patch kernel to allow aufs being build as a module.</flag>
<flag name="proc">Support for /proc/maps and lsof(1)</flag>
+ <flag name="vanilla">Use vanilla kernel sources without applying genpatches. WARNING: This flag will drop all support from the Gentoo Kernel Security team</flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/o:linux:linux_kernel</remote-id>