summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2006-03-21 21:07:42 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2006-03-21 21:07:42 +0000
commite0cc130781c71d9052e58586a8def4a02e984835 (patch)
treed31f3d1e19663edf81dad08c3b7a8c4c13b540c8 /sys-fs
parentversion bump, mqueue has been merged back into head, remove old ebuilds (diff)
downloadgentoo-2-e0cc130781c71d9052e58586a8def4a02e984835.tar.gz
gentoo-2-e0cc130781c71d9052e58586a8def4a02e984835.tar.bz2
gentoo-2-e0cc130781c71d9052e58586a8def4a02e984835.zip
Make the selinux conditional dependency explicit
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/device-mapper/ChangeLog7
-rw-r--r--sys-fs/device-mapper/device-mapper-1.02.03.ebuild8
2 files changed, 10 insertions, 5 deletions
diff --git a/sys-fs/device-mapper/ChangeLog b/sys-fs/device-mapper/ChangeLog
index a86db2c327b1..8af785666af0 100644
--- a/sys-fs/device-mapper/ChangeLog
+++ b/sys-fs/device-mapper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/device-mapper
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/ChangeLog,v 1.27 2006/03/12 21:14:07 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/ChangeLog,v 1.28 2006/03/21 21:07:42 pauldv Exp $
+
+ 21 Mar 2006; Paul de Vrieze <pauldv@gentoo.org>
+ device-mapper-1.02.03.ebuild:
+ Make the selinux conditional dependency explicit, and use use_enable (bug
+ #127089)
12 Mar 2006; Luis Medinas <metalgod@gentoo.org>
device-mapper-1.02.02.ebuild:
diff --git a/sys-fs/device-mapper/device-mapper-1.02.03.ebuild b/sys-fs/device-mapper/device-mapper-1.02.03.ebuild
index 6f141c5706a8..ab278d04c7b3 100644
--- a/sys-fs/device-mapper/device-mapper-1.02.03.ebuild
+++ b/sys-fs/device-mapper/device-mapper-1.02.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/device-mapper-1.02.03.ebuild,v 1.1 2006/03/05 03:50:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/device-mapper-1.02.03.ebuild,v 1.2 2006/03/21 21:07:42 pauldv Exp $
inherit eutils multilib
@@ -11,14 +11,14 @@ SRC_URI="ftp://sources.redhat.com/pub/dm/${PN}.${PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE=""
+IUSE="selinux"
-DEPEND=""
+DEPEND="selinux? ( sys-libs/libselinux )"
S=${WORKDIR}/${PN}.${PV}
src_compile() {
- econf --sbindir=/sbin || die "econf failed"
+ econf --sbindir=/sbin $(use_enable selinux) || die "econf failed"
emake || die "compile problem"
}