summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-06-05 21:09:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-06-05 21:09:22 +0000
commitc0d0048c9941665e20b7a075a9d6ac745eeadfca (patch)
tree9268f168a8fc6607f17d9a568015a05ee46cee66 /sys-fs
parentVersion bump, keyworded amd64 (diff)
downloadgentoo-2-c0d0048c9941665e20b7a075a9d6ac745eeadfca.tar.gz
gentoo-2-c0d0048c9941665e20b7a075a9d6ac745eeadfca.tar.bz2
gentoo-2-c0d0048c9941665e20b7a075a9d6ac745eeadfca.zip
Linux-3.0 support for udev version checks.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog9
-rw-r--r--sys-fs/udev/udev-146-r1.ebuild8
-rw-r--r--sys-fs/udev/udev-149.ebuild8
-rw-r--r--sys-fs/udev/udev-151-r4.ebuild8
-rw-r--r--sys-fs/udev/udev-162.ebuild8
-rw-r--r--sys-fs/udev/udev-163.ebuild8
-rw-r--r--sys-fs/udev/udev-164-r1.ebuild8
-rw-r--r--sys-fs/udev/udev-164-r2.ebuild8
-rw-r--r--sys-fs/udev/udev-164.ebuild8
-rw-r--r--sys-fs/udev/udev-167-r1.ebuild8
-rw-r--r--sys-fs/udev/udev-167.ebuild8
-rw-r--r--sys-fs/udev/udev-168-r1.ebuild8
-rw-r--r--sys-fs/udev/udev-168-r2.ebuild8
-rw-r--r--sys-fs/udev/udev-168.ebuild8
-rw-r--r--sys-fs/udev/udev-171.ebuild8
-rw-r--r--sys-fs/udev/udev-9999.ebuild8
16 files changed, 98 insertions, 31 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index c9f0e53747d0..c9d5fec50d08 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.579 2011/06/05 19:59:06 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.580 2011/06/05 21:09:22 robbat2 Exp $
+
+ 05 Jun 2011; Robin H. Johnson <robbat2@gentoo.org> udev-146-r1.ebuild,
+ udev-149.ebuild, udev-151-r4.ebuild, udev-162.ebuild, udev-163.ebuild,
+ udev-164.ebuild, udev-164-r1.ebuild, udev-164-r2.ebuild, udev-167.ebuild,
+ udev-167-r1.ebuild, udev-168.ebuild, udev-168-r1.ebuild, udev-168-r2.ebuild,
+ udev-171.ebuild, udev-9999.ebuild:
+ Linux-3.0 support for udev version checks.
*udev-171 (05 Jun 2011)
diff --git a/sys-fs/udev/udev-146-r1.ebuild b/sys-fs/udev/udev-146-r1.ebuild
index 92840f243fef..fcce0d8f9dbf 100644
--- a/sys-fs/udev/udev-146-r1.ebuild
+++ b/sys-fs/udev/udev-146-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-146-r1.ebuild,v 1.13 2011/04/15 21:55:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-146-r1.ebuild,v 1.14 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -57,9 +57,13 @@ fi
# required kernel options
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-149.ebuild b/sys-fs/udev/udev-149.ebuild
index 5e5ebfeedfe3..009b566b98ef 100644
--- a/sys-fs/udev/udev-149.ebuild
+++ b/sys-fs/udev/udev-149.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-149.ebuild,v 1.17 2011/04/15 21:55:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-149.ebuild,v 1.18 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -63,9 +63,13 @@ fi
# required kernel options
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-151-r4.ebuild b/sys-fs/udev/udev-151-r4.ebuild
index 9b66bd035086..d4be3d234eb0 100644
--- a/sys-fs/udev/udev-151-r4.ebuild
+++ b/sys-fs/udev/udev-151-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-151-r4.ebuild,v 1.15 2011/04/15 21:55:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-151-r4.ebuild,v 1.16 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -64,9 +64,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-162.ebuild b/sys-fs/udev/udev-162.ebuild
index 7c77920444ef..8f25ecc969e2 100644
--- a/sys-fs/udev/udev-162.ebuild
+++ b/sys-fs/udev/udev-162.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-162.ebuild,v 1.2 2011/04/15 21:55:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-162.ebuild,v 1.3 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -65,9 +65,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-163.ebuild b/sys-fs/udev/udev-163.ebuild
index c5e5b4b8edc4..a795c765540b 100644
--- a/sys-fs/udev/udev-163.ebuild
+++ b/sys-fs/udev/udev-163.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-163.ebuild,v 1.2 2011/04/15 21:55:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-163.ebuild,v 1.3 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -65,9 +65,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-164-r1.ebuild b/sys-fs/udev/udev-164-r1.ebuild
index 5b1ebeb1d518..47c61f575cf6 100644
--- a/sys-fs/udev/udev-164-r1.ebuild
+++ b/sys-fs/udev/udev-164-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-164-r1.ebuild,v 1.2 2011/04/15 21:55:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-164-r1.ebuild,v 1.3 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -67,9 +67,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-164-r2.ebuild b/sys-fs/udev/udev-164-r2.ebuild
index f391ba87bd2e..017d0c7a95b0 100644
--- a/sys-fs/udev/udev-164-r2.ebuild
+++ b/sys-fs/udev/udev-164-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-164-r2.ebuild,v 1.6 2011/06/05 18:24:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-164-r2.ebuild,v 1.7 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -67,9 +67,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-164.ebuild b/sys-fs/udev/udev-164.ebuild
index a6e9759d1c60..56aaa5105216 100644
--- a/sys-fs/udev/udev-164.ebuild
+++ b/sys-fs/udev/udev-164.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-164.ebuild,v 1.2 2011/04/15 21:55:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-164.ebuild,v 1.3 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -65,9 +65,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-167-r1.ebuild b/sys-fs/udev/udev-167-r1.ebuild
index b878159ffbfd..977fd7b3bdbd 100644
--- a/sys-fs/udev/udev-167-r1.ebuild
+++ b/sys-fs/udev/udev-167-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-167-r1.ebuild,v 1.4 2011/04/15 21:55:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-167-r1.ebuild,v 1.5 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -68,9 +68,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-167.ebuild b/sys-fs/udev/udev-167.ebuild
index 9299e1b249e9..29250bef1ea1 100644
--- a/sys-fs/udev/udev-167.ebuild
+++ b/sys-fs/udev/udev-167.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-167.ebuild,v 1.3 2011/04/15 21:55:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-167.ebuild,v 1.4 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -67,9 +67,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-168-r1.ebuild b/sys-fs/udev/udev-168-r1.ebuild
index 13abc86bc8ff..823844b3d2b8 100644
--- a/sys-fs/udev/udev-168-r1.ebuild
+++ b/sys-fs/udev/udev-168-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-168-r1.ebuild,v 1.1 2011/04/30 20:07:08 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-168-r1.ebuild,v 1.2 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -68,9 +68,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-168-r2.ebuild b/sys-fs/udev/udev-168-r2.ebuild
index d45e7abb2d48..36f2f086f015 100644
--- a/sys-fs/udev/udev-168-r2.ebuild
+++ b/sys-fs/udev/udev-168-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-168-r2.ebuild,v 1.1 2011/05/14 14:00:34 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-168-r2.ebuild,v 1.2 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -68,9 +68,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-168.ebuild b/sys-fs/udev/udev-168.ebuild
index 9bc88894ad3d..a2898f6a8b08 100644
--- a/sys-fs/udev/udev-168.ebuild
+++ b/sys-fs/udev/udev-168.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-168.ebuild,v 1.2 2011/04/30 13:15:40 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-168.ebuild,v 1.3 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -68,9 +68,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-171.ebuild b/sys-fs/udev/udev-171.ebuild
index 33acb540b770..a5868625c49b 100644
--- a/sys-fs/udev/udev-171.ebuild
+++ b/sys-fs/udev/udev-171.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-171.ebuild,v 1.1 2011/06/05 19:59:06 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-171.ebuild,v 1.2 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -68,9 +68,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 22c439081122..3a298aa84f92 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.39 2011/06/05 19:59:06 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.40 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -68,9 +68,13 @@ fi
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2
~!IDE"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2