summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2005-03-25 12:31:35 +0000
committerChristian Andreetta <satya@gentoo.org>2005-03-25 12:31:35 +0000
commitae6f83d4989163d09b7aabf7a3b893fbc4c7b913 (patch)
tree5b53ecbf30f9da788b3588ed31002defc760e362 /sys-fs
parentManual Manifest commit. (diff)
downloadgentoo-2-ae6f83d4989163d09b7aabf7a3b893fbc4c7b913.tar.gz
gentoo-2-ae6f83d4989163d09b7aabf7a3b893fbc4c7b913.tar.bz2
gentoo-2-ae6f83d4989163d09b7aabf7a3b893fbc4c7b913.zip
version bump. NFS readdir issue resolved
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/unionfs/ChangeLog7
-rw-r--r--sys-fs/unionfs/Manifest2
-rw-r--r--sys-fs/unionfs/files/digest-unionfs-1.0.111
-rw-r--r--sys-fs/unionfs/unionfs-1.0.11.ebuild47
4 files changed, 56 insertions, 1 deletions
diff --git a/sys-fs/unionfs/ChangeLog b/sys-fs/unionfs/ChangeLog
index ce5f17b258c3..51885e3f9f5d 100644
--- a/sys-fs/unionfs/ChangeLog
+++ b/sys-fs/unionfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/unionfs
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.7 2005/03/23 14:18:23 satya Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.8 2005/03/25 12:31:34 satya Exp $
+
+*unionfs-1.0.11 (25 Mar 2005)
+
+ 25 Mar 2005; Christian Andreetta <satya@gentoo.org> +unionfs-1.0.11.ebuild:
+ version bump. NFS readdir issue resolved
*unionfs-1.0.10 (23 Mar 2005)
diff --git a/sys-fs/unionfs/Manifest b/sys-fs/unionfs/Manifest
index 66f8f35ee121..c34468a3ee83 100644
--- a/sys-fs/unionfs/Manifest
+++ b/sys-fs/unionfs/Manifest
@@ -1,5 +1,6 @@
MD5 0cffb451a8ec857edd5665ebdcb85c99 unionfs-1.0.9.ebuild 1210
MD5 e8b3222280b922ab2fcfcdbf880951a7 unionfs-1.0.8-r2.ebuild 1713
+MD5 a11b1ddcdb01e635fc75a2ac1a3b3a52 unionfs-1.0.11.ebuild 1287
MD5 4970b965d7183e3424b52abea83f54ad unionfs-1.0.8.ebuild 1205
MD5 3aeaf93d8df4ecb220fff7835bd1e75b unionfs-1.0.8-r1.ebuild 1488
MD5 a11b1ddcdb01e635fc75a2ac1a3b3a52 unionfs-1.0.10.ebuild 1287
@@ -14,3 +15,4 @@ MD5 ca0c70650ac2ad10a83bc3255de16baa files/unionfs-1.0.8-vserver.patch 520
MD5 ed43e0aa2c797f7089d0b5233c2f4a28 files/digest-unionfs-1.0.8-r1 65
MD5 ed43e0aa2c797f7089d0b5233c2f4a28 files/digest-unionfs-1.0.8-r2 65
MD5 7fa8dc7044d2dbf56ceb60eebb857be2 files/digest-unionfs-1.0.10 66
+MD5 2410ef6f38ddf9737cbb13bfe0325c9a files/digest-unionfs-1.0.11 66
diff --git a/sys-fs/unionfs/files/digest-unionfs-1.0.11 b/sys-fs/unionfs/files/digest-unionfs-1.0.11
new file mode 100644
index 000000000000..9a3f0ad9b893
--- /dev/null
+++ b/sys-fs/unionfs/files/digest-unionfs-1.0.11
@@ -0,0 +1 @@
+MD5 494651fe0cf724c093b4be80e35e857f unionfs-1.0.11.tar.gz 109648
diff --git a/sys-fs/unionfs/unionfs-1.0.11.ebuild b/sys-fs/unionfs/unionfs-1.0.11.ebuild
new file mode 100644
index 000000000000..140b0dc74421
--- /dev/null
+++ b/sys-fs/unionfs/unionfs-1.0.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.0.11.ebuild,v 1.1 2005/03/25 12:31:35 satya Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
+HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
+SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+#IUSE="acl debug" # 2005-03-20: satya: acl has issues that will be fixed upstream
+IUSE="debug"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ MODULE_NAMES="unionfs(fs:)"
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
+}
+
+src_unpack() {
+ local user_Makefile=fistdev.mk EXTRACFLAGS=""
+
+ unpack ${A}
+ cd ${S}
+
+ if ! use debug; then
+ echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
+ EXTRACFLAGS="${EXTRACFLAGS} -DNODEBUG"
+ fi
+
+ #use acl && EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR -DFIST_SETXATTR_CONSTVOID"
+
+ echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile} || die
+}
+
+src_install() {
+ dosbin unionctl uniondbg
+ doman man/unionfs.4 man/unionctl.8 man/uniondbg.8
+
+ linux-mod_src_install
+
+ dodoc INSTALL NEWS README ChangeLog
+}
+