summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-23 22:42:14 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-23 22:42:14 +0000
commita1df331f8fc2b13b5e375d54dedea275dd6ff874 (patch)
tree37c2ae17d7cc2fb1be82b38614273b92d9acb79d /sys-fs
parentLower v8 dep to 3.7.6; it will probably work and makes testing preserve_old_l... (diff)
downloadgentoo-2-a1df331f8fc2b13b5e375d54dedea275dd6ff874.tar.gz
gentoo-2-a1df331f8fc2b13b5e375d54dedea275dd6ff874.tar.bz2
gentoo-2-a1df331f8fc2b13b5e375d54dedea275dd6ff874.zip
Version bump. Update to EAPI 4 and apply patch by Arfrever to fix python issue (bug #391065 by Patrick).
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ecryptfs-utils/ChangeLog9
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-93.ebuild136
-rw-r--r--sys-fs/ecryptfs-utils/files/ecryptfs-utils-93-python.patch27
3 files changed, 171 insertions, 1 deletions
diff --git a/sys-fs/ecryptfs-utils/ChangeLog b/sys-fs/ecryptfs-utils/ChangeLog
index 7ce092a7592c..64bf81a7ec59 100644
--- a/sys-fs/ecryptfs-utils/ChangeLog
+++ b/sys-fs/ecryptfs-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/ecryptfs-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.37 2011/09/03 00:26:03 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.38 2011/11/23 22:42:14 radhermit Exp $
+
+*ecryptfs-utils-93 (23 Nov 2011)
+
+ 23 Nov 2011; Tim Harder <radhermit@gentoo.org> +ecryptfs-utils-93.ebuild,
+ +files/ecryptfs-utils-93-python.patch:
+ Version bump. Update to EAPI 4 and apply patch by Arfrever to fix python
+ issue (bug #391065 by Patrick).
*ecryptfs-utils-92 (03 Sep 2011)
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-93.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-93.ebuild
new file mode 100644
index 000000000000..cc6b2a297d04
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/ecryptfs-utils-93.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-93.ebuild,v 1.1 2011/11/23 22:42:14 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit flag-o-matic pam python linux-info autotools-utils
+
+DESCRIPTION="eCryptfs userspace utilities"
+HOMEPAGE="https://launchpad.net/ecryptfs"
+SRC_URI="http://launchpad.net/ecryptfs/trunk/${PV}/+download/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gpg gtk openssl pam pkcs11 python suid tpm"
+
+RDEPEND=">=sys-apps/keyutils-1.0
+ >=dev-libs/libgcrypt-1.2.0
+ dev-libs/nss
+ gpg? ( app-crypt/gpgme )
+ gtk? ( x11-libs/gtk+:2 )
+ openssl? ( >=dev-libs/openssl-0.9.7 )
+ pam? ( sys-libs/pam )
+ pkcs11? (
+ >=dev-libs/openssl-0.9.7
+ >=dev-libs/pkcs11-helper-1.04
+ )
+ tpm? ( app-crypt/trousers )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ sys-devel/gettext
+ >=dev-util/intltool-0.41.0
+ python? ( dev-lang/swig )"
+
+pkg_setup() {
+ use python && python_pkg_setup
+
+ CONFIG_CHECK="~ECRYPT_FS"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ echo "#!/bin/sh" > py-compile
+
+ # Python bindings are built/installed manually.
+ sed -e "/SUBDIRS =/s/ libecryptfs-swig//" -i src/Makefile.am || die "sed failed"
+
+ epatch "${FILESDIR}"/${P}-python.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -D_FILE_OFFSET_BITS=64
+
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-nss \
+ --with-pamdir=$(getpam_mod_dir) \
+ $(use_enable doc docs) \
+ $(use_enable gpg) \
+ $(use_enable gtk gui) \
+ $(use_enable openssl) \
+ $(use_enable pam) \
+ $(use_enable pkcs11 pkcs11-helper) \
+ $(use_enable python pywrap) \
+ $(use_enable tpm tspi)
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources src/libecryptfs-swig
+ building() {
+ emake \
+ PYTHON="$(PYTHON)" \
+ PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
+ PYTHON_LDFLAGS="-L$(python_get_libdir) $(python_get_library -l)" \
+ PYTHON_SITE_PKG="$(python_get_sitedir)" \
+ PYTHON_VERSION="$(python_get_version)" \
+ SWIG_PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir src/libecryptfs-swig building
+ fi
+}
+
+src_install(){
+ emake DESTDIR="${D}" install
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON="$(PYTHON)" \
+ PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
+ PYTHON_LDFLAGS="-L$(python_get_libdir) $(python_get_library -l)" \
+ PYTHON_SITE_PKG="$(python_get_sitedir)" \
+ PYTHON_VERSION="$(python_get_version)" \
+ SWIG_PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install || return 1
+ echo "ecryptfs-utils" > "${ED}$(python_get_sitedir)/ecryptfs-utils.pth"
+ }
+ python_execute_function -s --source-dir src/libecryptfs-swig installation
+
+ python_clean_installation_image
+ fi
+
+ use suid && fperms u+s /sbin/mount.ecryptfs_private
+
+ remove_libtool_files all
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ecryptfs-utils
+
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there are any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ecryptfs-utils
+}
diff --git a/sys-fs/ecryptfs-utils/files/ecryptfs-utils-93-python.patch b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-93-python.patch
new file mode 100644
index 000000000000..2767b582ef8d
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-93-python.patch
@@ -0,0 +1,27 @@
+https://bugs.launchpad.net/ecryptfs/+bug/893327
+
+--- configure.ac
++++ configure.ac
+@@ -19,9 +19,6 @@
+ AC_CONFIG_MACRO_DIR([m4])
+
+ AC_DISABLE_STATIC
+-AM_PATH_PYTHON(2.5, [have_python="yes"], [have_python="no"])
+-AC_PROG_SWIG(1.3.31)
+-SWIG_PYTHON
+
+ LIBECRYPTFS_LT_CURRENT="0"
+ LIBECRYPTFS_LT_REVISION="0"
+@@ -248,6 +245,12 @@
+ AC_CHECK_HEADER([openssl/rsa.h],, [have_openssl="no"])
+ CFLAGS="${OLD_CFLAGS}"
+
++if test "${enable_pywrap}" != "no" ; then
++ AM_PATH_PYTHON(2.5, [have_python="yes"], [have_python="no"])
++ AC_PROG_SWIG(1.3.31)
++ SWIG_PYTHON
++fi
++
+ if test "x${SWIG}" != "x" ; then
+ have_swig="yes"
+ else