summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-30 18:11:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-30 18:11:23 +0000
commit92aaf0c2639499b90d168f4aabf130e2df8eb9e3 (patch)
tree62d813d300114d5f4a8926bce4820ee9108cbf91 /sys-fs
parentStable for amd64 wrt bug #518182 (diff)
downloadgentoo-2-92aaf0c2639499b90d168f4aabf130e2df8eb9e3.tar.gz
gentoo-2-92aaf0c2639499b90d168f4aabf130e2df8eb9e3.tar.bz2
gentoo-2-92aaf0c2639499b90d168f4aabf130e2df8eb9e3.zip
Use udev_reload() function from udev.eclass to avoid duplicating code.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog5
-rw-r--r--sys-fs/udev/udev-9999.ebuild13
2 files changed, 8 insertions, 10 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 3d27d0d24224..6c632c0b6b88 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.1073 2014/07/29 19:23:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.1074 2014/07/30 18:11:23 ssuominen Exp $
+
+ 30 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> udev-9999.ebuild:
+ Use udev_reload() function from udev.eclass to avoid duplicating code.
29 Jul 2014; Markus Meier <maekke@gentoo.org> udev-215-r1.ebuild:
arm stable, bug #517106
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index b6493a4a54bc..1622345f93b5 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.313 2014/07/25 04:03:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.314 2014/07/30 18:11:23 ssuominen Exp $
EAPI=5
-inherit autotools bash-completion-r1 eutils linux-info multilib multilib-minimal toolchain-funcs user versionator
+inherit autotools bash-completion-r1 eutils linux-info multilib multilib-minimal toolchain-funcs udev user versionator
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="git://anongit.freedesktop.org/systemd/systemd"
@@ -497,12 +497,7 @@ pkg_postinst() {
if has_version 'sys-apps/hwids[udev]'; then
udevadm hwdb --update --root="${ROOT%/}"
# Only reload when we are not upgrading to avoid potential race w/ incompatible hwdb.bin and the running udevd
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
- if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
- return 0
- fi
- udevadm control --reload
- fi
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ [[ -z ${REPLACING_VERSIONS} ]] && udev_reload
fi
}