summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-01-21 20:49:42 +0000
committerPacho Ramos <pacho@gentoo.org>2013-01-21 20:49:42 +0000
commit68702388e9e6aa46e450330f41b506ac7314ead7 (patch)
tree85e572bf86fac9615f497db0001b95e5db8d9346 /sys-fs
parentAdd fix to avoid array subscript above bounds (diff)
downloadgentoo-2-68702388e9e6aa46e450330f41b506ac7314ead7.tar.gz
gentoo-2-68702388e9e6aa46e450330f41b506ac7314ead7.tar.bz2
gentoo-2-68702388e9e6aa46e450330f41b506ac7314ead7.zip
Install missing doc file, also use readme.gentoo eclass
(Portage version: 2.1.11.47/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e4rat/ChangeLog6
-rw-r--r--sys-fs/e4rat/e4rat-0.2.3-r1.ebuild22
-rw-r--r--sys-fs/e4rat/e4rat-0.2.3.ebuild56
3 files changed, 16 insertions, 68 deletions
diff --git a/sys-fs/e4rat/ChangeLog b/sys-fs/e4rat/ChangeLog
index 7d4afacd4acc..b830bdedb012 100644
--- a/sys-fs/e4rat/ChangeLog
+++ b/sys-fs/e4rat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/e4rat
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/ChangeLog,v 1.14 2013/01/15 21:24:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/ChangeLog,v 1.15 2013/01/21 20:49:42 pacho Exp $
+
+ 21 Jan 2013; Pacho Ramos <pacho@gentoo.org> -e4rat-0.2.3.ebuild,
+ e4rat-0.2.3-r1.ebuild:
+ Install missing doc file, also use readme.gentoo eclass
15 Jan 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Remove myself from metadata
diff --git a/sys-fs/e4rat/e4rat-0.2.3-r1.ebuild b/sys-fs/e4rat/e4rat-0.2.3-r1.ebuild
index 252636049261..f94c612ef86f 100644
--- a/sys-fs/e4rat/e4rat-0.2.3-r1.ebuild
+++ b/sys-fs/e4rat/e4rat-0.2.3-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/e4rat-0.2.3-r1.ebuild,v 1.4 2013/01/13 11:21:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/e4rat-0.2.3-r1.ebuild,v 1.5 2013/01/21 20:49:42 pacho Exp $
-EAPI=4
+EAPI=5
-inherit cmake-utils linux-info
+inherit cmake-utils linux-info readme.gentoo
DESCRIPTION="Toolset to accelerate the boot process and application startup"
HOMEPAGE="http://e4rat.sourceforge.net/"
@@ -15,8 +15,8 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="dev-lang/perl
- >=dev-libs/boost-1.42
+DEPEND="dev-lang/perl:=
+ >=dev-libs/boost-1.42:=
sys-fs/e2fsprogs
sys-process/audit
sys-process/lsof"
@@ -32,6 +32,8 @@ PATCHES=(
pkg_setup() {
check_extra_config
+ DOC_CONTENTS="Please consult the following link if you need help
+ configuring your system: http://en.gentoo-wiki.com/wiki/E4rat"
}
src_install() {
@@ -41,18 +43,16 @@ src_install() {
dodir sbin
find "${D}"/usr/sbin -type f -exec mv {} "${D}"/sbin/. \; \
|| die
+
+ dodoc README
+ readme.gentoo_create_doc
}
pkg_postinst() {
- elog
- elog "Please consult the upstream wiki if you need help"
- elog "configuring your system"
- elog "http://e4rat.sourceforge.net/wiki/index.php/Main_Page"
- elog
+ readme.gentoo_print_elog
if has_version sys-apps/preload; then
elog "It appears you have sys-apps/preload installed. This may"
elog "has negative effects on ${PN}. You may want to disable preload"
elog "when using ${PN}."
- elog "http://e4rat.sourceforge.net/wiki/index.php/Main_Page#Debian.2FUbuntu"
fi
}
diff --git a/sys-fs/e4rat/e4rat-0.2.3.ebuild b/sys-fs/e4rat/e4rat-0.2.3.ebuild
deleted file mode 100644
index 017787f8c6c9..000000000000
--- a/sys-fs/e4rat/e4rat-0.2.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/e4rat-0.2.3.ebuild,v 1.3 2012/10/17 03:49:02 phajdan.jr Exp $
-
-EAPI=4
-
-inherit cmake-utils linux-info
-
-DESCRIPTION="Toolset to accelerate the boot process and application startup"
-HOMEPAGE="http://e4rat.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="dev-lang/perl
- >=dev-libs/boost-1.42
- sys-fs/e2fsprogs
- sys-process/audit"
-RDEPEND="${DEPEND}"
-
-CONFIG_CHECK="~AUDITSYSCALL"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.2.2-shared-build.patch
- "${FILESDIR}"/${PN}-0.2.2-libdir.patch
-)
-
-pkg_setup() {
- check_extra_config
-}
-
-src_install() {
- cmake-utils_src_install
- # relocate binaries to /sbin. If someone knows of a better way to do it
- # please do tell me
- dodir sbin
- find "${D}"/usr/sbin -type f -exec mv {} "${D}"/sbin/. \; \
- || die
-}
-
-pkg_postinst() {
- elog
- elog "Please consult the upstream wiki if you need help"
- elog "configuring your system"
- elog "http://e4rat.sourceforge.net/wiki/index.php/Main_Page"
- elog
- if has_version sys-apps/preload; then
- elog "It appears you have sys-apps/preload installed. This may"
- elog "has negative effects on ${PN}. You may want to disable preload"
- elog "when using ${PN}."
- elog "http://e4rat.sourceforge.net/wiki/index.php/Main_Page#Debian.2FUbuntu"
- fi
-}