summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-02-21 12:00:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-02-21 12:00:36 +0000
commit558a68d51084a04ad3d57eded3f12cd5a69b4793 (patch)
tree995fb85b0124bcb4d5dd2dcf92d8efb37c2d1ddc /sys-fs
parentx86 stable wrt bug #492122 (diff)
downloadgentoo-2-558a68d51084a04ad3d57eded3f12cd5a69b4793.tar.gz
gentoo-2-558a68d51084a04ad3d57eded3f12cd5a69b4793.tar.bz2
gentoo-2-558a68d51084a04ad3d57eded3f12cd5a69b4793.zip
Fix bash completion directory using bash-completion-r1.eclass. Install 99-default.link to /lib/systemd and move udevd binary there as well to follow suit. Remove reference to now non-existing 80-net-name-slot.rules from postinst message. Sort ./configure flags based on --help and only pass required --disable flags.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog9
-rw-r--r--sys-fs/udev/udev-9999.ebuild131
2 files changed, 58 insertions, 82 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 6a425a6f4ccb..1b4459389334 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.985 2014/02/16 20:03:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.986 2014/02/21 12:00:36 ssuominen Exp $
+
+ 21 Feb 2014; Samuli Suominen <ssuominen@gentoo.org> udev-9999.ebuild:
+ Fix bash completion directory using bash-completion-r1.eclass. Install
+ 99-default.link to /lib/systemd and move udevd binary there as well to follow
+ suit. Remove reference to now non-existing 80-net-name-slot.rules from
+ postinst message. Sort ./configure flags based on --help and only pass
+ required --disable flags.
16 Feb 2014; Samuli Suominen <ssuominen@gentoo.org> udev-9999.ebuild:
Check for CONFIG_FHANDLE wrt http://cgit.freedesktop.org/systemd/systemd/commi
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index b6a54f2ec15d..3dcab04e336b 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.261 2014/02/16 20:03:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.262 2014/02/21 12:00:36 ssuominen Exp $
EAPI=5
-inherit autotools eutils linux-info multilib toolchain-funcs versionator multilib-minimal
+inherit autotools bash-completion-r1 eutils linux-info multilib toolchain-funcs versionator multilib-minimal
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="git://anongit.freedesktop.org/systemd/systemd"
@@ -31,9 +31,9 @@ RESTRICT="test"
COMMON_DEPEND=">=sys-apps/util-linux-2.20
acl? ( sys-apps/acl )
- gudev? ( >=dev-libs/glib-2 )
+ gudev? ( >=dev-libs/glib-2.22 )
introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
- kmod? ( >=sys-apps/kmod-15 )
+ kmod? ( >=sys-apps/kmod-16 )
selinux? ( >=sys-libs/libselinux-2.1.9 )
!<sys-libs/glibc-2.11
!sys-apps/systemd
@@ -43,30 +43,26 @@ COMMON_DEPEND=">=sys-apps/util-linux-2.20
)"
DEPEND="${COMMON_DEPEND}
dev-util/gperf
- >=sys-devel/make-3.82-r4
virtual/os-headers
virtual/pkgconfig
+ !<sys-devel/make-3.82-r4
!<sys-kernel/linux-headers-2.6.32
doc? ( >=dev-util/gtk-doc-1.18 )"
+# Try with `emerge -C docbook-xml-dtd` to see the build failure without DTDs
if [[ ${PV} = 9999* ]]; then
DEPEND="${DEPEND}
app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
app-text/docbook-xsl-stylesheets
dev-libs/libxslt
>=dev-util/intltool-0.50"
fi
RDEPEND="${COMMON_DEPEND}
- openrc? ( !<sys-apps/openrc-0.9.9 )
- !sys-apps/coldplug
- !<sys-fs/lvm2-2.02.97-r1
- !sys-fs/device-mapper
- !<sys-fs/udev-init-scripts-22
- !<sys-kernel/dracut-017-r1
- !<sys-kernel/genkernel-3.4.25
+ !<sys-fs/lvm2-2.02.103
!<sec-policy/selinux-base-2.20120725-r10"
-PDEPEND=">=virtual/udev-206-r2
- >=sys-apps/hwids-20130717-r1[udev]
- openrc? ( >=sys-fs/udev-init-scripts-25 )"
+PDEPEND=">=virtual/udev-208
+ >=sys-apps/hwids-20140101[udev]
+ openrc? ( >=sys-fs/udev-init-scripts-26 )"
S=${WORKDIR}/systemd-${PV}
@@ -94,8 +90,8 @@ pkg_setup() {
# Based on README from tarball:
local MINKV=3.0
- # These arch's have the mandatory accept4() function support in Linux 2.6.32.61, see:
- # $ grep -r define.*accept4 linux-2.6.32.61/*
+ # These arch's have the mandatory accept4() function support in Linux 2.6.32*, see:
+ # $ grep -r define.*accept4 linux-2.6.32*/*
if use amd64 || use ia64 || use mips || use sparc || use x86; then
MINKV=2.6.32
fi
@@ -109,7 +105,7 @@ pkg_setup() {
src_prepare() {
if ! [[ ${PV} = 9999* ]]; then
# secure_getenv() disable for non-glibc systems wrt bug #443030
- if ! [[ $(grep -r secure_getenv * | wc -l) -eq 20 ]]; then
+ if ! [[ $(grep -r secure_getenv * | wc -l) -eq 26 ]]; then
eerror "The line count for secure_getenv() failed, see bug #443030"
die
fi
@@ -120,11 +116,11 @@ src_prepare() {
EPATCH_SUFFIX=patch EPATCH_FORCE=yes epatch
fi
- # These are missing from upstream 50-udev-default.rules
cat <<-EOF > "${T}"/40-gentoo.rules
# Gentoo specific usb group
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", GROUP="usb"
- # Keep this for Linux 2.6.32 kernels with accept4() support like .60 wrt #457868
+ # Keep this for Linux 2.6.32 kernels with incomplete devtmpfs support because
+ # accept4() function is supported for some arch's wrt #457868
SUBSYSTEM=="mem", KERNEL=="null|zero|full|random|urandom", MODE="0666"
EOF
@@ -182,38 +178,35 @@ src_prepare() {
multilib_src_configure() {
tc-export CC #463846
+ # Keep sorted by ./configure --help and only pass --disable flags
+ # when *required* to avoid external deps or unnecessary compile
local econf_args
econf_args=(
ac_cv_search_cap_init=
ac_cv_header_sys_capability_h=yes
- DBUS_CFLAGS=' '
- DBUS_LIBS=' '
- --docdir=/usr/share/doc/${PF}
--libdir=/usr/$(get_libdir)
- --with-html-dir=/usr/share/doc/${PF}/html
- --with-rootprefix=
- --without-python
+ --docdir=/usr/share/doc/${PF}
+ --disable-nls
--disable-python-devel
+ --disable-dbus
+ --disable-seccomp
+ --disable-xz
+ --disable-tcpwrap
+ --disable-pam
+ --disable-xattr
+ --disable-gcrypt
--disable-audit
- --disable-coredump
- --disable-hostnamed
- --disable-ima
--disable-libcryptsetup
- --disable-localed
- --disable-logind
- --disable-myhostname
- --disable-nls
- --disable-pam
+ --disable-qrencode
+ --disable-microhttpd
--disable-quotacheck
- --disable-readahead
- --enable-split-usr
- --disable-tcpwrap
- --disable-timedated
- --disable-xz
--disable-polkit
- --disable-tmpfiles
- --disable-machined
- --disable-xattr
+ --disable-myhostname
+ --enable-split-usr
+ --with-html-dir=/usr/share/doc/${PF}/html
+ --without-python
+ --with-bashcompletiondir="$(get_bashcompdir)"
+ --with-rootprefix=
)
# Use pregenerated copies when possible wrt #480924
if ! [[ ${PV} = 9999* ]]; then
@@ -223,26 +216,26 @@ multilib_src_configure() {
fi
if multilib_build_binaries; then
econf_args+=(
- --with-rootlibdir=/$(get_libdir)
- $(use_enable acl)
+ $(use_enable static-libs static)
$(use_enable doc gtk-doc)
- $(use_enable gudev)
+ $(use_enable introspection)
+ $(use_enable acl)
$(use_enable kmod)
$(use_enable selinux)
- $(use_enable static-libs static)
- --enable-introspection=$(usex introspection)
+ $(use_enable gudev)
+ --with-rootlibdir=/$(get_libdir)
)
else
econf_args+=(
- --with-rootlibdir=/usr/$(get_libdir)
- --disable-acl
+ --disable-static
--disable-gtk-doc
- --disable-gudev
+ --disable-introspection
+ --disable-acl
--disable-kmod
--disable-selinux
- --disable-static
+ --disable-gudev
--disable-manpages
- --enable-introspection=no
+ --with-rootlibdir=/usr/$(get_libdir)
)
fi
use firmware-loader && econf_args+=( --with-firmware-path="/lib/firmware/updates:/lib/firmware" )
@@ -321,6 +314,7 @@ multilib_src_install() {
libudev-install-hook
install-directories-hook
install-dist_bashcompletionDATA
+ install-dist_networkDATA
)
if use gudev; then
@@ -329,6 +323,7 @@ multilib_src_install() {
fi
# add final values of variables:
+ # TODO: networkdir follows prefix, not rootprefix, which is an upstream bug
targets+=(
rootlibexec_PROGRAMS=systemd-udevd
rootbin_PROGRAMS=udevadm
@@ -337,6 +332,7 @@ multilib_src_install() {
INSTALL_DIRS='$(sysconfdir)/udev/rules.d \
$(sysconfdir)/udev/hwdb.d'
dist_bashcompletion_DATA="shell-completion/bash/udevadm"
+ networkdir=/lib/systemd/network
)
emake -j1 DESTDIR="${D}" "${targets[@]}"
@@ -348,11 +344,6 @@ multilib_src_install() {
# install udevadm compatibility symlink
dosym {../bin,sbin}/udevadm
- # install udevd to /sbin and remove empty and redudant directory
- # /lib/systemd because systemd is installed to /usr wrt #462750
- mv "${D}"/{lib/systemd/systemd-,sbin/}udevd || die
- rm -r "${D}"/lib/systemd
-
if [[ ${PV} = 9999* ]]; then
doman man/{udev.7,udevadm.8,systemd-udevd.service.8}
else
@@ -416,14 +407,6 @@ pkg_postinst() {
ewarn "else losetup may be confused when looking for unused devices."
fi
- # 64-device-mapper.rules is related to sys-fs/device-mapper which we block
- # in favor of sys-fs/lvm2
- old_dm_rules=${ROOT}etc/udev/rules.d/64-device-mapper.rules
- if [[ -f ${old_dm_rules} ]]; then
- rm -f "${old_dm_rules}"
- einfo "Removed unneeded file ${old_dm_rules}"
- fi
-
local fstab="${ROOT}"etc/fstab dev path fstype rest
while read -r dev path fstype rest; do
if [[ ${path} == /dev && ${fstype} != devtmpfs ]]; then
@@ -444,18 +427,6 @@ pkg_postinst() {
ewarn "Note that qfile can be found in app-portage/portage-utils"
fi
- local old_net_name="${ROOT}"etc/udev/rules.d/80-net-name-slot.rules
- if [[ -f ${old_net_name} ]]; then
- local old_net_sum=bebf4bd1b6b668e9ff34a3999aa6ff32
- MD5=$(md5sum < "${old_net_name}")
- MD5=${MD5/ -/}
- if [[ ${MD5} == ${old_net_sum} ]]; then
- ewarn "Removing unmodified file ${old_net_name} from old udev installation to enable"
- ewarn "the new predictable network interface naming."
- rm -f "${old_net_name}"
- fi
- fi
-
local old_cd_rules="${ROOT}"etc/udev/rules.d/70-persistent-cd.rules
local old_net_rules="${ROOT}"etc/udev/rules.d/70-persistent-net.rules
for old_rules in "${old_cd_rules}" "${old_net_rules}"; do
@@ -468,7 +439,7 @@ pkg_postinst() {
done
elog
- elog "Starting from version >= 200 the new predictable network interface names are"
+ elog "Starting from version >= 197 the new predictable network interface names are"
elog "used by default, see:"
elog "http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames"
elog "http://cgit.freedesktop.org/systemd/systemd/tree/src/udev/udev-builtin-net_id.c"
@@ -477,9 +448,7 @@ pkg_postinst() {
elog "(replace <ifname> with, for example, eth0):"
elog "# udevadm test-builtin net_id /sys/class/net/<ifname> 2> /dev/null"
elog
- elog "You can use either kernel parameter \"net.ifnames=0\", create empty"
- elog "file /etc/udev/rules.d/80-net-name-slot.rules, or symlink it to /dev/null"
- elog "to disable the feature."
+ elog "You can disable the feature with kernel parameter \"net.ifnames=0\""
if has_version sys-apps/biosdevname; then
ewarn