summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-07-24 06:30:11 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-07-24 06:30:11 +0000
commit1500b681c3fc3494078044169403493b7f9bc8e8 (patch)
tree84e20353d389999b78bc296e5e8f81c1e7d60490 /sys-fs
parentimproved patch to work with kml 2.1 thanks to Ed Catmur again (diff)
downloadgentoo-2-1500b681c3fc3494078044169403493b7f9bc8e8.tar.gz
gentoo-2-1500b681c3fc3494078044169403493b7f9bc8e8.tar.bz2
gentoo-2-1500b681c3fc3494078044169403493b7f9bc8e8.zip
version bump
(Portage version: 2.1.1_pre3-r3)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog8
-rw-r--r--sys-fs/fuse/files/digest-fuse-2.6.0_pre33
-rw-r--r--sys-fs/fuse/fuse-2.6.0_pre3.ebuild68
3 files changed, 78 insertions, 1 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 72e20431d827..6ae3c47ff8b4 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.55 2006/06/08 12:06:18 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.56 2006/07/24 06:30:10 genstef Exp $
+
+*fuse-2.6.0_pre3 (24 Jul 2006)
+
+ 24 Jul 2006; Stefan Schweizer <genstef@gentoo.org>
+ +fuse-2.6.0_pre3.ebuild:
+ version bump
08 Jun 2006; Stefan Schweizer <genstef@gentoo.org> fuse-2.6.0_pre2.ebuild:
use emake install instead of make install to allow parallel installs and
diff --git a/sys-fs/fuse/files/digest-fuse-2.6.0_pre3 b/sys-fs/fuse/files/digest-fuse-2.6.0_pre3
new file mode 100644
index 000000000000..a0e12d3b749b
--- /dev/null
+++ b/sys-fs/fuse/files/digest-fuse-2.6.0_pre3
@@ -0,0 +1,3 @@
+MD5 36d540444ff703ac9ec3f28e88f8e167 fuse-2.6.0-pre3.tar.gz 425584
+RMD160 6ac3d0b5fb5d1c70ca414acca835a9d37e5303d3 fuse-2.6.0-pre3.tar.gz 425584
+SHA256 127874a258a7d7a436f1ccd11c8978db508dd01bc1c0fdf53ffbcb252c7fa0d9 fuse-2.6.0-pre3.tar.gz 425584
diff --git a/sys-fs/fuse/fuse-2.6.0_pre3.ebuild b/sys-fs/fuse/fuse-2.6.0_pre3.ebuild
new file mode 100644
index 000000000000..fb01bfdc83c7
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.6.0_pre3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0_pre3.ebuild,v 1.1 2006/07/24 06:30:10 genstef Exp $
+
+inherit linux-mod eutils libtool
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace."
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_linux kernel_FreeBSD"
+S=${WORKDIR}/${MY_P}
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+
+MODULE_NAMES="fuse(fs:${S}/kernel)"
+CONFIG_CHECK="@FUSE_FS:fuse"
+BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
+BUILD_TARGETS="all"
+ECONF_PARAMS="--with-kernel=${KV_OUT_DIR}"
+FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+We will continue, but we wont build the module this time."
+
+pkg_setup() {
+ use kernel_linux && linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/fuse-fix-lazy-binding.patch
+ elibtoolize
+}
+
+src_compile() {
+ einfo "Preparing fuse userland"
+ econf --disable-kernel-module --disable-example || \
+ die "econf failed for fuse userland"
+ emake || die "emake failed"
+
+ if use kernel_linux; then
+ sed -i -e 's/.*depmod.*//g' ${S}/kernel/Makefile.in
+ convert_to_m ${S}/kernel/Makefile.in
+ linux-mod_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog Filesystems README README-2.4 \
+ README.NFS NEWS doc/how-fuse-works
+ docinto example
+ dodoc example/*
+
+ if use kernel_linux; then
+ linux-mod_src_install
+ else
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ fi
+}
+
+pkg_postinst() {
+ use kernel_linux && linux-mod_pkg_postinst
+}