summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-27 00:59:15 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-27 00:59:15 +0000
commit90045bc9ff6762da905b5a22504885dd39fc7d09 (patch)
tree9e65eb3c3cedf8f5ec43caea99de099e1ab68991 /sys-fs/xfsdump
parentarm/hppa/ia64/s390/sh stable (diff)
downloadgentoo-2-90045bc9ff6762da905b5a22504885dd39fc7d09.tar.gz
gentoo-2-90045bc9ff6762da905b5a22504885dd39fc7d09.tar.bz2
gentoo-2-90045bc9ff6762da905b5a22504885dd39fc7d09.zip
Version bump.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-fs/xfsdump')
-rw-r--r--sys-fs/xfsdump/ChangeLog9
-rw-r--r--sys-fs/xfsdump/files/digest-xfsdump-2.2.331
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.33.ebuild47
3 files changed, 55 insertions, 2 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index a1b002a3b15c..5557bf58bbeb 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/xfsdump
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.23 2005/09/04 05:16:09 vapier Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.24 2006/01/27 00:57:24 vapier Exp $
+
+*xfsdump-2.2.33 (27 Jan 2006)
+
+ 27 Jan 2006; Mike Frysinger <vapier@gentoo.org> +xfsdump-2.2.33.ebuild:
+ Version bump.
04 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+files/xfsdump-2.2.30-docs.patch, xfsdump-2.2.30.ebuild:
diff --git a/sys-fs/xfsdump/files/digest-xfsdump-2.2.33 b/sys-fs/xfsdump/files/digest-xfsdump-2.2.33
new file mode 100644
index 000000000000..20693f6168f1
--- /dev/null
+++ b/sys-fs/xfsdump/files/digest-xfsdump-2.2.33
@@ -0,0 +1 @@
+MD5 d891a6f0215f4ad33840ddf60a295ec7 xfsdump-2.2.33.src.tar.gz 576941
diff --git a/sys-fs/xfsdump/xfsdump-2.2.33.ebuild b/sys-fs/xfsdump/xfsdump-2.2.33.ebuild
new file mode 100644
index 000000000000..121c6fb8aa29
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-2.2.33.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.33.ebuild,v 1.1 2006/01/27 00:57:24 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc -sparc ~x86"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/xfsdump-2.2.30-docs.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ -e '/^GCFLAGS/s:-O1::' \
+ include/builddefs.in \
+ || die
+}
+
+src_compile() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install || die
+ prepalldocs
+}