summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-15 20:47:11 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-15 20:47:11 +0000
commitaa8711bbeb61a591e7216fdc6b9da80b9999b149 (patch)
tree78bff47bd6907d4ec4257565fcadfca0d9b52801 /sys-fs/squashfs-tools
parentFixing collision with /usr/lib/libtalloc.so.2 bug #351608 setting python 2.6 ... (diff)
downloadgentoo-2-aa8711bbeb61a591e7216fdc6b9da80b9999b149.tar.gz
gentoo-2-aa8711bbeb61a591e7216fdc6b9da80b9999b149.tar.bz2
gentoo-2-aa8711bbeb61a591e7216fdc6b9da80b9999b149.zip
Version Bump
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/squashfs-tools')
-rw-r--r--sys-fs/squashfs-tools/ChangeLog7
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index b915eb94f7dd..da959cfb7ed0 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/squashfs-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.74 2011/02/06 11:03:19 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.75 2011/03/15 20:47:11 jlec Exp $
+
+*squashfs-tools-4.2 (15 Mar 2011)
+
+ 15 Mar 2011; Justin Lecher <jlec@gentoo.org> +squashfs-tools-4.2.ebuild:
+ Version Bump
06 Feb 2011; Mart Raudsepp <leio@gentoo.org> squashfs-tools-3.4.ebuild:
Drop to ~mips
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
new file mode 100644
index 000000000000..adf1d86ec991
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild,v 1.1 2011/03/15 20:47:11 jlec Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_PV=${PV}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+gzip +lzma lzo xattr"
+
+RDEPEND="
+ gzip? ( sys-libs/zlib )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ !lzma? ( !lzo? ( sys-libs/zlib ) )
+ xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
+
+use_sed() {
+ local u=$1 s="${2:-`echo $1 | tr '[:lower:]' '[:upper:]'`}_SUPPORT"
+ printf '/^#?%s =/%s\n' "${s}" \
+ "$( use $u && echo s:.*:${s} = 1: || echo d )"
+}
+
+src_configure() {
+ tc-export CC
+ local def
+ if [[ -n ${SQUASH_FS_DEFAULT_COMP} ]]; then
+ def=${SQUASH_FS_DEFAULT_COMP}
+ else
+ einfo "You can set the default compression (gzip, xz or lzo) by exporting SQUASH_FS_DEFAULT_COMP"
+ if use gzip; then
+ def="gzip"
+ elif use lzma; then
+ def="xz"
+ elif use lzo; then
+ def="lzo"
+ else
+ die "Please set at least one of the gzip, lzma and lzo USE flags as compression algorithm."
+ fi
+ fi
+
+ einfo "Using ${def} as compression algorithm."
+
+ sed -i -r \
+ -e "/^COMP_DEFAULT =/s:=.*:= ${def}:" \
+ -e "$(use_sed gzip)" \
+ -e "$(use_sed lzma XZ)" \
+ -e "$(use_sed lzo)" \
+ -e "$(use_sed xattr)" \
+ Makefile || die
+}
+
+src_install() {
+ dobin mksquashfs unsquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README || die
+}
+
+pkg_postinst() {
+ ewarn "This version of mksquashfs requires a 2.6.29 kernel or better"
+ use lzma &&
+ ewarn "XZ support requires a 2.6.38 kernel or better"
+}