summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-04-15 22:38:13 +0000
committerMike Frysinger <vapier@gentoo.org>2013-04-15 22:38:13 +0000
commit5e3e5593df82ec127a8fc08566a780586616d0f9 (patch)
treeda07a58b03c23821ecf2781eafe75b27781363e1 /sys-fs/quota
parentVersion bump and remove old. (diff)
downloadgentoo-2-5e3e5593df82ec127a8fc08566a780586616d0f9.tar.gz
gentoo-2-5e3e5593df82ec127a8fc08566a780586616d0f9.tar.bz2
gentoo-2-5e3e5593df82ec127a8fc08566a780586616d0f9.zip
Avoid building rpc related code when USE=-rpc #465810 by darwinskernel.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-fs/quota')
-rw-r--r--sys-fs/quota/ChangeLog5
-rw-r--r--sys-fs/quota/quota-4.01.ebuild20
2 files changed, 18 insertions, 7 deletions
diff --git a/sys-fs/quota/ChangeLog b/sys-fs/quota/ChangeLog
index eacebd45e4f1..f5f38b7e190b 100644
--- a/sys-fs/quota/ChangeLog
+++ b/sys-fs/quota/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/quota
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.64 2013/01/06 22:37:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.65 2013/04/15 22:38:13 vapier Exp $
+
+ 15 Apr 2013; Mike Frysinger <vapier@gentoo.org> quota-4.01.ebuild:
+ Avoid building rpc related code when USE=-rpc #465810 by darwinskernel.
*quota-4.01 (06 Jan 2013)
diff --git a/sys-fs/quota/quota-4.01.ebuild b/sys-fs/quota/quota-4.01.ebuild
index 621fbc4171e1..879ab54c180f 100644
--- a/sys-fs/quota/quota-4.01.ebuild
+++ b/sys-fs/quota/quota-4.01.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-4.01.ebuild,v 1.1 2013/01/06 22:37:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-4.01.ebuild,v 1.2 2013/04/15 22:38:13 vapier Exp $
EAPI="4"
-inherit eutils flag-o-matic
+inherit eutils
DESCRIPTION="Linux quota tools"
HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
@@ -28,7 +28,17 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/quota-tools
src_prepare() {
- sed -i '1iCC = @CC@' Makefile.in || die #446277
+ local args=(
+ -e '1iCC = @CC@' #446277
+ )
+ if ! use rpc ; then
+ args+=( #465810
+ -e '/^PROGS/s:rpc.rquotad::'
+ -e '/^RPCGEN/s:=.*:=false:'
+ -e '/^RPCCLNTOBJS/s:=.*:=:'
+ )
+ fi
+ sed -i "${args[@]}" Makefile.in || die
epatch "${FILESDIR}"/${PN}-4.01-mnt.patch
}
@@ -44,7 +54,7 @@ src_configure() {
src_install() {
emake STRIP="" ROOTDIR="${D}" install
dodoc doc/* README.* Changelog
- rm -r "${D}"/usr/include || die #70938
+ rm -r "${ED}"/usr/include || die #70938
insinto /etc
insopts -m0644
@@ -55,8 +65,6 @@ src_install() {
if use rpc ; then
newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
- else
- rm -f "${D}"/usr/sbin/rpc.rquotad
fi
if use ldap ; then