summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Edgar <rocket@gentoo.org>2006-09-07 13:58:56 +0000
committerEric Edgar <rocket@gentoo.org>2006-09-07 13:58:56 +0000
commitc36a1270439a27f83dfbdff2b57c30b8eacbd82d (patch)
treeeada9e9ab68505d815bea9a40ddcde9ab93c687b /sys-fs/lvm2
parentStable on sparc wrt #133520 (diff)
downloadgentoo-2-c36a1270439a27f83dfbdff2b57c30b8eacbd82d.tar.gz
gentoo-2-c36a1270439a27f83dfbdff2b57c30b8eacbd82d.tar.bz2
gentoo-2-c36a1270439a27f83dfbdff2b57c30b8eacbd82d.zip
Add lvm2 2.02.09 to the tree
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/ChangeLog7
-rw-r--r--sys-fs/lvm2/files/digest-lvm2-2.02.093
-rw-r--r--sys-fs/lvm2/lvm2-2.02.09.ebuild108
3 files changed, 117 insertions, 1 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index c6071762a859..86eccbc28f59 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/lvm2
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.83 2006/09/04 06:03:55 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.84 2006/09/07 13:58:56 rocket Exp $
+
+*lvm2-2.02.09 (07 Sep 2006)
+
+ 07 Sep 2006; Eric Edgar <rocket@gentoo.org> +lvm2-2.02.09.ebuild:
+ Add version 2.02.09 to the tree
04 Sep 2006; Joshua Kinard <kumba@gentoo.org> lvm2-2.02.06.ebuild:
Marked stable on mips.
diff --git a/sys-fs/lvm2/files/digest-lvm2-2.02.09 b/sys-fs/lvm2/files/digest-lvm2-2.02.09
new file mode 100644
index 000000000000..eec4ee13b745
--- /dev/null
+++ b/sys-fs/lvm2/files/digest-lvm2-2.02.09
@@ -0,0 +1,3 @@
+MD5 04aa4bd7781e9b57bf214654d5a0267c LVM2.2.02.09.tgz 487599
+RMD160 ee56c644c567a24c3de04f1fd733072e21eaea18 LVM2.2.02.09.tgz 487599
+SHA256 d6493169666058ea7514b6782de9985d1df1230fcca072306dbe645bb91ac177 LVM2.2.02.09.tgz 487599
diff --git a/sys-fs/lvm2/lvm2-2.02.09.ebuild b/sys-fs/lvm2/lvm2-2.02.09.ebuild
new file mode 100644
index 000000000000..bb85163905cf
--- /dev/null
+++ b/sys-fs/lvm2/lvm2-2.02.09.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.09.ebuild,v 1.1 2006/09/07 13:58:56 rocket Exp $
+
+inherit eutils
+
+DESCRIPTION="User-land utilities for LVM2 (device-mapper) software."
+HOMEPAGE="http://sources.redhat.com/lvm2/"
+SRC_URI="ftp://sources.redhat.com/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="readline nolvmstatic clvm cman gulm nolvm1 nosnapshots nomirrors selinux"
+
+DEPEND=">=sys-fs/device-mapper-1.02.03
+ clvm? ( >=sys-cluster/dlm-1.01.00
+ cman? ( >=sys-cluster/cman-1.01.00 )
+ gulm? ( >=sys-cluster/gulm-1.00.00 ) )"
+
+RDEPEND="${DEPEND}
+ !sys-fs/lvm-user
+ !sys-fs/clvm"
+
+S="${WORKDIR}/${PN/lvm/LVM}.${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+ #epatch ${FILESDIR}/lvm2-2.02.04-vgid.patch
+}
+
+src_compile() {
+ # Static compile of lvm2 so that the install described in the handbook works
+ # http://www.gentoo.org/doc/en/lvm2.xml
+ # fixes http://bugs.gentoo.org/show_bug.cgi?id=84463
+ local myconf
+
+ if ! use nolvmstatic
+ then
+ myconf="${myconf} --enable-static_link"
+ use nosnapshots || myconf="${myconf} --with-snapshots=internal"
+ use nomirrors || myconf="${myconf} --with-mirrors=internal"
+ if use nolvm1
+ then
+ myconf="${myconf} --with-lvm1=none"
+ else
+ myconf="${myconf} --with-lvm1=internal"
+ fi
+ else
+ use nosnapshots || myconf="${myconf} --with-snapshots=shared"
+ use nomirrors || myconf="${myconf} --with-mirrors=shared"
+ if use nolvm1
+ then
+ myconf="${myconf} --with-lvm1=none"
+ else
+ myconf="${myconf} --with-lvm1=shared"
+ fi
+ fi
+
+ # disable O_DIRECT support on hppa, breaks pv detection (#99532)
+ use hppa && myconf="${myconf} --disable-o_direct"
+
+ if use clvm; then
+ if use nolvmstatic
+ then
+ myconf="${myconf} --with-cluster=shared"
+ else
+ myconf="${myconf} --with-cluster=internal"
+ fi
+ if useq cman && useq gulm; then
+ myconf="${myconf} --with-clvmd=all"
+ fi
+ if useq cman && ! useq gulm; then
+ myconf="${myconf} --with-clvmd=cman"
+ fi
+ if useq gulm && ! useq cman; then
+ myconf="${myconf} --with-clvmd=gulm"
+ fi
+ if ! useq gulm && ! useq cman; then
+ myconf="${myconf} --with-clvmd=none"
+ fi
+ fi
+
+ econf $(use_enable readline) $(use_enable selinux) ${myconf} || die
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall sbindir="${D}/sbin" staticdir="${D}/sbin" confdir="${D}/etc/lvm"
+ mv -f "${D}/sbin/lvm.static" "${D}/sbin/lvm"
+
+ dodoc COPYING* INSTALL README VERSION WHATS_NEW doc/*.{conf,c,txt}
+ insinto /lib/rcscripts/addons
+ newins ${FILESDIR}/lvm2-start.sh lvm-start.sh || die
+ newins ${FILESDIR}/lvm2-stop.sh lvm-stop.sh || die
+ if use clvm; then
+ newinitd ${FILESDIR}/clvmd.rc clvmd || die
+ fi
+
+ ewarn "use flag nocman is deprecated and replaced"
+ ewarn "with cman and gulm use flags."
+ ewarn ""
+ ewarn "use flags clvm,cman and gulm are masked"
+ ewarn "by default and need to be unmasked to use them"
+ ewarn ""
+ ewarn "Rebuild your genkernel initramfs if you are using lvm"
+}