summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Edgar <rocket@gentoo.org>2005-02-23 03:47:44 +0000
committerEric Edgar <rocket@gentoo.org>2005-02-23 03:47:44 +0000
commit734bde8feb1da740b072c05ee9ca35c844d4229c (patch)
treed572f18cd91179a3c9cf32d0709876656583f800 /sys-fs/lvm-user/lvm-user-1.0.7-r3.ebuild
parentInitial import. Ebuild by me. Closes bug #70914. (diff)
downloadgentoo-2-734bde8feb1da740b072c05ee9ca35c844d4229c.tar.gz
gentoo-2-734bde8feb1da740b072c05ee9ca35c844d4229c.tar.bz2
gentoo-2-734bde8feb1da740b072c05ee9ca35c844d4229c.zip
New ebuild to install lvm-user-start.sh and lvm-user-stop.sh into /lib/rcscripts/addons to initialize lvm at startup and shutdown
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-fs/lvm-user/lvm-user-1.0.7-r3.ebuild')
-rw-r--r--sys-fs/lvm-user/lvm-user-1.0.7-r3.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/sys-fs/lvm-user/lvm-user-1.0.7-r3.ebuild b/sys-fs/lvm-user/lvm-user-1.0.7-r3.ebuild
new file mode 100644
index 000000000000..325cb6b6baf1
--- /dev/null
+++ b/sys-fs/lvm-user/lvm-user-1.0.7-r3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm-user/lvm-user-1.0.7-r3.ebuild,v 1.1 2005/02/23 03:47:44 rocket Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="User-land utilities for LVM (Logical Volume Manager) software"
+HOMEPAGE="http://www.sistina.com/products_lvm.htm"
+SRC_URI="ftp://ftp.sistina.com/pub/LVM/1.0/lvm_${PV}.tar.gz"
+
+LICENSE=" || ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa -ppc sparc x86"
+IUSE="static"
+
+RDEPEND="!sys-fs/lvm2"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0
+ virtual/linux-sources"
+
+S=${WORKDIR}/LVM/${PV}
+
+pkg_setup() {
+ check_KV
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-tmpfile.patch
+}
+
+src_compile() {
+ local myconf
+
+ filter-flags -fomit-frame-pointer #598
+
+ if use static; then
+ myconf="--enable-static_link"
+ else
+ # bug 29694 -- make static vgscan and vgchange for initrds
+ epatch ${FILESDIR}/lvm-user-1.0.7-statics.patch
+ fi
+
+ ./configure --prefix=/ \
+ --mandir=/usr/share/man \
+ --with-kernel_dir="/usr/src/linux" \
+ ${myconf} || die "configure failed"
+
+ # Fix flags
+ sed -i -e "54,56d" -e "73d" make.tmpl
+
+ make || die "Make failed"
+}
+
+src_install() {
+ einstall sbindir=${D}/sbin libdir=${D}/lib
+
+ if use static; then
+ # already static, make symlinks
+ dosym vgscan /sbin/vgscan.static
+ dosym vgchange /sbin/vgchange.static
+ else
+ # install vgscan.static and vgchange.static
+ into /
+ dosbin ${S}/tools/{vgscan,vgchange}.static
+ fi
+
+ # no need for a static library in /lib
+ dodir /usr/lib
+ mv ${D}/lib/*.a ${D}/usr/lib
+
+ dodoc ABSTRACT CONTRIBUTORS INSTALL LVM-HOWTO TODO CHANGELOG FAQ KNOWN_BUGS README WHATSNEW
+
+ insinto /lib/rcscripts/addons
+ newins ${FILESDIR}/lvm-user-start.sh lvm-start.sh
+ newins ${FILESDIR}/lvm-user-stop.sh lvm-stop.sh
+
+}