summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-10-15 20:17:14 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-10-15 20:17:14 +0000
commit31721c17f184ebd0a260c17baad5165a89cb8b16 (patch)
tree118ac25f0f5e8a341c8d241d3dd9a6d9de35cd0e /sys-fs/libeatmydata/libeatmydata-65.ebuild
parentsci-libs/io_lib: Drop old (diff)
downloadgentoo-2-31721c17f184ebd0a260c17baad5165a89cb8b16.tar.gz
gentoo-2-31721c17f184ebd0a260c17baad5165a89cb8b16.tar.bz2
gentoo-2-31721c17f184ebd0a260c17baad5165a89cb8b16.zip
Initial commit. LD_PRELOAD hack to workaround some exceeding fsync()/open(mode=O_SYNC) in applications. Does not pass tests as sandbox breaks LD_PRELOAD order and interferes to normal working order.
(Portage version: 2.2.0_alpha135_p2/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/libeatmydata/libeatmydata-65.ebuild')
-rw-r--r--sys-fs/libeatmydata/libeatmydata-65.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/libeatmydata/libeatmydata-65.ebuild b/sys-fs/libeatmydata/libeatmydata-65.ebuild
new file mode 100644
index 000000000000..6ef73fc5f6cf
--- /dev/null
+++ b/sys-fs/libeatmydata/libeatmydata-65.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/libeatmydata/libeatmydata-65.ebuild,v 1.1 2012/10/15 20:17:14 slyfox Exp $
+
+EAPI="4"
+inherit eutils
+
+DESCRIPTION="LD_PRELOAD hack to convert sync()/msync() and the like to NO-OP"
+HOMEPAGE="https://launchpad.net/libeatmydata/"
+SRC_URI="https://launchpad.net/${PN}/trunk/release-${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+# sandbox fools LD_PRELOAD and libeatmydata does not get control
+# bug/feature in sandbox?
+#DEPEND="test? ( dev-util/strace )"
+RESTRICT=test
+
+DEPEND="sys-apps/sed"
+RDEPEND=""
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+ dodoc AUTHORS README
+}