summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-25 10:10:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-25 10:10:58 +0000
commitf587474466c3479534f9387e3bed22d508cf16c7 (patch)
tree854435976abc31e3759717b65ec7f2c83da3475f /sys-fs/fuseiso
parentAdjust deps on gdb per bug #290440. (diff)
downloadgentoo-2-f587474466c3479534f9387e3bed22d508cf16c7.tar.gz
gentoo-2-f587474466c3479534f9387e3bed22d508cf16c7.tar.bz2
gentoo-2-f587474466c3479534f9387e3bed22d508cf16c7.zip
Initial commit wrt #143307, thanks to Thomas Fischer for reporting.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/fuseiso')
-rw-r--r--sys-fs/fuseiso/ChangeLog10
-rw-r--r--sys-fs/fuseiso/files/fuseiso-20070708-largeiso.patch48
-rw-r--r--sys-fs/fuseiso/fuseiso-20070708.ebuild30
-rw-r--r--sys-fs/fuseiso/metadata.xml9
4 files changed, 97 insertions, 0 deletions
diff --git a/sys-fs/fuseiso/ChangeLog b/sys-fs/fuseiso/ChangeLog
new file mode 100644
index 000000000000..a0a9ef3d5e13
--- /dev/null
+++ b/sys-fs/fuseiso/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-fs/fuseiso
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuseiso/ChangeLog,v 1.1 2009/10/25 10:10:57 ssuominen Exp $
+
+*fuseiso-20070708 (25 Oct 2009)
+
+ 25 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +fuseiso-20070708.ebuild, +files/fuseiso-20070708-largeiso.patch:
+ Initial commit wrt #143307, thanks to Thomas Fischer for reporting.
+
diff --git a/sys-fs/fuseiso/files/fuseiso-20070708-largeiso.patch b/sys-fs/fuseiso/files/fuseiso-20070708-largeiso.patch
new file mode 100644
index 000000000000..e323768d247e
--- /dev/null
+++ b/sys-fs/fuseiso/files/fuseiso-20070708-largeiso.patch
@@ -0,0 +1,48 @@
+http://bugzilla.redhat.com/show_bug.cgi?id=440436
+
+diff -ur fuseiso-20070708.orig/src/isofs.c fuseiso-20070708/src/isofs.c
+--- fuseiso-20070708.orig/src/isofs.c 2007-07-08 15:22:59.000000000 +0300
++++ fuseiso-20070708/src/isofs.c 2009-10-25 12:02:16.000000000 +0200
+@@ -178,7 +178,7 @@
+ context.data_size = isonum_723(context.pd.logical_block_size);
+
+ if(!context.block_size) {
+- fprintf(stderr, "init: wrong block data size %d, using default 2048\n", context.data_size);
++ fprintf(stderr, "init: wrong block data size %Lu, using default 2048\n", context.data_size);
+ context.data_size = 2048;
+ };
+
+@@ -324,7 +324,7 @@
+
+ if(context.block_size != 2048) {
+ // report unusual data block size
+- printf("Data block size: %d\n", context.block_size);
++ printf("Data block size: %Lu\n", context.block_size);
+ };
+
+ char buf[129];
+@@ -479,7 +479,7 @@
+ };
+ size_t len = read(context.fd, buf, context.data_size);
+ if(len != context.data_size) {
+- fprintf(stderr, "isofs_read_raw_block: can`t read full block, read only %d bytes from offset %d, %d required; errno %d, message %s\n",
++ fprintf(stderr, "isofs_read_raw_block: can`t read full block, read only %d bytes from offset %d, %Lu required; errno %d, message %s\n",
+ len, (int) off, context.data_size, errno, strerror(errno));
+ fprintf(stderr, "isofs_read_raw_block: huh? reading zeros beyond file end? someone want to save a penny?\n");
+ memset(buf + len, 0, context.data_size - len);
+diff -ur fuseiso-20070708.orig/src/isofs.h fuseiso-20070708/src/isofs.h
+--- fuseiso-20070708.orig/src/isofs.h 2006-10-17 04:50:39.000000000 +0300
++++ fuseiso-20070708/src/isofs.h 2009-10-25 12:02:16.000000000 +0200
+@@ -38,9 +38,9 @@
+ struct iso_directory_record *root;
+ int file_offset; // offset to begin of useful data (for .nrg files)
+ int id_offset; // offset to CD001 inside file
+- size_t block_size; // raw block size
+- size_t block_offset; // offset from block start to data
+- size_t data_size; // data size inside block
++ off_t block_size; // raw block size
++ off_t block_offset; // offset from block start to data
++ off_t data_size; // data size inside block
+ int susp; // parse susp entries
+ int susp_skip; // skip bytes from susp SP entry
+ int joliet_level; // joliet extension level (1, 2 or 3)
diff --git a/sys-fs/fuseiso/fuseiso-20070708.ebuild b/sys-fs/fuseiso/fuseiso-20070708.ebuild
new file mode 100644
index 000000000000..fa4d7567d845
--- /dev/null
+++ b/sys-fs/fuseiso/fuseiso-20070708.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuseiso/fuseiso-20070708.ebuild,v 1.1 2009/10/25 10:10:57 ssuominen Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Fuse module to mount ISO9660"
+HOMEPAGE="http://fuseiso.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/fuse
+ sys-libs/zlib
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-largeiso.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/sys-fs/fuseiso/metadata.xml b/sys-fs/fuseiso/metadata.xml
new file mode 100644
index 000000000000..7cc5007c5d79
--- /dev/null
+++ b/sys-fs/fuseiso/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>