summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-30 00:40:05 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-30 00:40:05 +0000
commit0d1b1ad74ca82bc0f9128db60934030ada230fa0 (patch)
tree6c4e7d6b97c67c3524beca86a157dc126677a530 /sys-fs/e2fsprogs
parentStable on amd64 wrt bug #146453 (diff)
downloadgentoo-2-0d1b1ad74ca82bc0f9128db60934030ada230fa0.tar.gz
gentoo-2-0d1b1ad74ca82bc0f9128db60934030ada230fa0.tar.bz2
gentoo-2-0d1b1ad74ca82bc0f9128db60934030ada230fa0.zip
Add support for ext4 #156697.
(Portage version: 2.1.2_rc4-r2)
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/ChangeLog7
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.39-r1.ebuild130
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r16
3 files changed, 142 insertions, 1 deletions
diff --git a/sys-fs/e2fsprogs/ChangeLog b/sys-fs/e2fsprogs/ChangeLog
index 458580c18283..90e1ed6cbde7 100644
--- a/sys-fs/e2fsprogs/ChangeLog
+++ b/sys-fs/e2fsprogs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/e2fsprogs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.92 2006/12/10 00:39:19 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.93 2006/12/30 00:40:04 vapier Exp $
+
+*e2fsprogs-1.39-r1 (30 Dec 2006)
+
+ 30 Dec 2006; Mike Frysinger <vapier@gentoo.org> +e2fsprogs-1.39-r1.ebuild:
+ Add support for ext4 #156697.
10 Dec 2006; Timothy Redaelli <drizzt@gentoo.org> e2fsprogs-1.39.ebuild:
Add ~x86-fbsd keyword
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.39-r1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.39-r1.ebuild
new file mode 100644
index 000000000000..d3e717d04dd9
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.39-r1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.39-r1.ebuild,v 1.1 2006/12/30 00:40:04 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ http://www.bullopensource.org/ext4/patches/ext4-e2fsprogs-1.39.patch.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls static"
+
+RDEPEND="~sys-libs/com_err-${PV}
+ ~sys-libs/ss-${PV}
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-apps/texinfo"
+
+pkg_setup() {
+ # sanity check for #125146
+ if [[ -L ${ROOT}/usr/$(get_libdir)/libcom_err.a ]] || \
+ [[ ! -e ${ROOT}/usr/$(get_libdir)/libcom_err.a ]]
+ then
+ rm -f "${ROOT}"/usr/$(get_libdir)/libcom_err.a
+ eerror "Your libcom_err.a is broken, please re-emerge com_err:"
+ eerror " # emerge com_err"
+ die "Mr. T pities the fool with a broken libcom_err.a"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix locale issues while running tests #99766
+ epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch
+ epatch "${FILESDIR}"/${PN}-1.38-locale.patch #131462
+ # Fix a cosmetic error in mk_cmds's help output.
+ epatch "${FILESDIR}"/e2fsprogs-1.32-mk_cmds-cosmetic.patch
+ chmod u+w po/*.po # Userpriv fix #27348
+ # Clean up makefile to suck less
+ epatch "${FILESDIR}"/e2fsprogs-1.39-makefile.patch
+ epatch "${FILESDIR}"/e2fsprogs-1.39-parse-types.patch #146903
+ # Fixes libintl handling on non-glibc #122368
+ epatch "${FILESDIR}"/${PN}-1.39-libintl.patch
+ # Add ext4 support #156697
+ epatch $(sed -e 's:^:patches/:g' patches/series)
+
+ # kernel headers use the same defines as e2fsprogs and can cause issues #48829
+ sed -i \
+ -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
+ $(grep -rl CONFIG_JBD_DEBUG *) \
+ || die "sed jbd debug failed"
+
+ # fake out files we forked into sep packages
+ sed -i \
+ -e '/^LIB_SUBDIRS/s:lib/et::' \
+ -e '/^LIB_SUBDIRS/s:lib/ss::' \
+ Makefile.in || die "remove subdirs"
+ ln -s "${ROOT}"/usr/$(get_libdir)/libcom_err.a lib/libcom_err.a
+ ln -s "${ROOT}"/$(get_libdir)/libcom_err.so lib/libcom_err.so
+ ln -s /usr/bin/mk_cmds lib/ss/mk_cmds
+ ln -s "${ROOT}"/usr/include/ss/ss_err.h lib/ss/
+ ln -s "${ROOT}"/$(get_libdir)/libss.so lib/libss.so
+
+ # sanity check for Bug 105304
+ if [[ -z ${USERLAND} ]] ; then
+ eerror "You just hit Bug 105304, please post your 'emerge info' here:"
+ eerror "http://bugs.gentoo.org/105304"
+ die "Aborting to prevent screwing your system"
+ fi
+}
+
+src_compile() {
+ # Keep the package from doing silly things
+ export LDCONFIG=/bin/true
+ export CC=$(tc-getCC)
+ export STRIP=/bin/true
+
+ econf \
+ --bindir=/bin \
+ --sbindir=/sbin \
+ --enable-elf-shlibs \
+ --with-ldopts="${LDFLAGS}" \
+ $(use_enable !static dynamic-e2fsck) \
+ --without-included-gettext \
+ $(use_enable nls) \
+ $(use_enable userland_GNU fsck) \
+ || die
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+ # Parallel make sometimes fails
+ emake -j1 COMPILE_ET=compile_et || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog README RELEASE-NOTES SHLIBS
+ docinto e2fsck
+ dodoc e2fsck/ChangeLog e2fsck/CHANGES
+
+ # Move shared libraries to /lib/, install static libraries to /usr/lib/,
+ # and install linker scripts to /usr/lib/.
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
+ dolib.a lib/*.a || die "dolib.a"
+ rm -f "${D}"/usr/$(get_libdir)/libcom_err.a #125146
+ local x
+ cd "${D}"/$(get_libdir)
+ for x in *.so ; do
+ gen_usr_ldscript ${x} || die "gen ldscript ${x}"
+ done
+
+ # move 'useless' stuff to /usr/
+ dosbin "${D}"/sbin/mklost+found
+ rm -f "${D}"/sbin/mklost+found
+
+ # these manpages are already provided by FreeBSD libc
+ use elibc_FreeBSD && \
+ rm -f "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
+ "${D}"/usr/share/man/man1/uuidgen.1
+}
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r1 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r1
new file mode 100644
index 000000000000..2580942c50b2
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r1
@@ -0,0 +1,6 @@
+MD5 06f7806782e357797fad1d34b7ced0c6 e2fsprogs-1.39.tar.gz 3695111
+RMD160 67e77a7cbf0e719fa8b5a8ac6285b334e1c3481b e2fsprogs-1.39.tar.gz 3695111
+SHA256 dc2033447e69a1612881151f6f163e8a3b80e51d16f5e8b3576f3f8ccb325ea3 e2fsprogs-1.39.tar.gz 3695111
+MD5 9c966817dcb61a515b34497f4517ebb9 ext4-e2fsprogs-1.39.patch.tar 716800
+RMD160 5b20e7f2133e7339d22ee85d39c92cd7af920bb9 ext4-e2fsprogs-1.39.patch.tar 716800
+SHA256 0472210d002808f1505f96b1ca0e667f3cc2a6d585bca7d9a00130d6fe0ca38e ext4-e2fsprogs-1.39.patch.tar 716800