summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-05-28 13:53:21 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-05-28 13:53:21 +0000
commitdd79614fd26bf6fff2c18fb4bd011d3b9f373246 (patch)
treecaf960203881073431b44cec5c0ef66eacec0d23 /sys-fs/dd-rescue
parentFix execstack in libffi.so.6 wrt #511634 by Anthony Basile and Magnus Granberg (diff)
downloadgentoo-2-dd79614fd26bf6fff2c18fb4bd011d3b9f373246.tar.gz
gentoo-2-dd79614fd26bf6fff2c18fb4bd011d3b9f373246.tar.bz2
gentoo-2-dd79614fd26bf6fff2c18fb4bd011d3b9f373246.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-fs/dd-rescue')
-rw-r--r--sys-fs/dd-rescue/ChangeLog7
-rw-r--r--sys-fs/dd-rescue/dd-rescue-1.44.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-fs/dd-rescue/ChangeLog b/sys-fs/dd-rescue/ChangeLog
index d2e053aeb056..802b080d3515 100644
--- a/sys-fs/dd-rescue/ChangeLog
+++ b/sys-fs/dd-rescue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/dd-rescue
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/ChangeLog,v 1.34 2014/01/07 09:56:11 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/ChangeLog,v 1.35 2014/05/28 13:53:21 polynomial-c Exp $
+
+*dd-rescue-1.44 (28 May 2014)
+
+ 28 May 2014; Lars Wendler <polynomial-c@gentoo.org> +dd-rescue-1.44.ebuild:
+ Version bump.
07 Jan 2014; Lars Wendler <polynomial-c@gentoo.org> -dd-rescue-1.10.ebuild,
-dd-rescue-1.24.ebuild, -dd-rescue-1.25.ebuild:
diff --git a/sys-fs/dd-rescue/dd-rescue-1.44.ebuild b/sys-fs/dd-rescue/dd-rescue-1.44.ebuild
new file mode 100644
index 000000000000..0e27de128efa
--- /dev/null
+++ b/sys-fs/dd-rescue/dd-rescue-1.44.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/dd-rescue-1.44.ebuild,v 1.1 2014/05/28 13:53:21 polynomial-c Exp $
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic autotools
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Similar to dd but can copy from source with errors"
+HOMEPAGE="http://www.garloff.de/kurt/linux/ddrescue/"
+SRC_URI="http://www.garloff.de/kurt/linux/ddrescue/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare() {
+ sed -i \
+ -e 's:-ldl:$(LDFLAGS) -ldl:' \
+ Makefile
+ eautoreconf
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ # The Makefile is a mess. Override a few vars rather than patch it.
+ emake \
+ RPM_OPT_FLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CFLAGS_OPT='$(CFLAGS)' \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ # easier to install by hand than trying to make sense of the Makefile.
+ dobin dd_rescue
+ dodoc README.dd_rescue
+ doman dd_rescue.1
+}