summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-20 05:49:29 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-20 05:49:29 +0000
commitd6781e4cd74016a83a69b172724557052b639c49 (patch)
treef883e572f4e29902b2552f148d22d4c50d5b42e9 /sys-fs/aufs2
parentPut versions of arel in slots since they are not compatible, bug 372047. (diff)
downloadgentoo-2-d6781e4cd74016a83a69b172724557052b639c49.tar.gz
gentoo-2-d6781e4cd74016a83a69b172724557052b639c49.tar.bz2
gentoo-2-d6781e4cd74016a83a69b172724557052b639c49.zip
Version BUmp
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/aufs2')
-rw-r--r--sys-fs/aufs2/ChangeLog8
-rw-r--r--sys-fs/aufs2/aufs2-0_p20110620.ebuild116
-rw-r--r--sys-fs/aufs2/files/aufs2-base-39.patch6
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-39.patch18
4 files changed, 135 insertions, 13 deletions
diff --git a/sys-fs/aufs2/ChangeLog b/sys-fs/aufs2/ChangeLog
index ccf9de52fc25..99beb7eff7be 100644
--- a/sys-fs/aufs2/ChangeLog
+++ b/sys-fs/aufs2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/aufs2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.36 2011/06/09 13:51:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.37 2011/06/20 05:49:29 jlec Exp $
+
+*aufs2-0_p20110620 (20 Jun 2011)
+
+ 20 Jun 2011; Justin Lecher <jlec@gentoo.org> +aufs2-0_p20110620.ebuild,
+ files/aufs2-base-39.patch, files/aufs2-standalone-39.patch:
+ Version BUmp
*aufs2-0_p20110605 (09 Jun 2011)
diff --git a/sys-fs/aufs2/aufs2-0_p20110620.ebuild b/sys-fs/aufs2/aufs2-0_p20110620.ebuild
new file mode 100644
index 000000000000..a3f1d5c5ba22
--- /dev/null
+++ b/sys-fs/aufs2/aufs2-0_p20110620.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20110620.ebuild,v 1.1 2011/06/20 05:49:29 jlec Exp $
+
+EAPI="4"
+
+inherit linux-mod multilib toolchain-funcs
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fuse hardened hfs inotify kernel-patch nfs ramfs"
+
+DEPEND="dev-vcs/git"
+RDEPEND="!sys-fs/aufs"
+
+S="${WORKDIR}"/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ CONFIG_CHECK="${CONFIG_CHECK} ~EXPERIMENTAL"
+ use inotify && CONFIG_CHECK="${CONFIG_CHECK} ~FSNOTIFY"
+ use nfs && CONFIG_CHECK="${CONFIG_CHECK} ~EXPORTFS"
+ use fuse && CONFIG_CHECK="${CONFIG_CHECK} ~FUSE_FS"
+ use hfs && CONFIG_CHECK="${CONFIG_CHECK} ~HFSPLUS_FS"
+
+ # this is needed so merging a binpkg aufs2 is possible w/out a kernel unpacked on the system
+ [ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return
+
+ get_version
+ kernel_is lt 2 6 31 && die "kernel too old"
+ kernel_is gt 2 6 39 && die "kernel too new"
+
+ linux-mod_pkg_setup
+ if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null && \
+ patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null ); then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null
+ epatch "${FILESDIR}"/aufs2-{base,standalone}-${KV_PATCH}.patch
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the aufs2 module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply ${FILESDIR}/aufs2-base-${KV_PATCH}.patch and"
+ eerror "${FILESDIR}/aufs2-standalone-${KV_PATCH}.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+ export PKG_SETUP_HAS_BEEN_RAN=1
+}
+
+set_config() {
+ for option in $*; do
+ grep -q "^CONFIG_AUFS_${option} =" config.mk || die "${option} is not a valid config option"
+ sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
+ done
+}
+
+src_prepare() {
+ local branch=origin/aufs2.1-${KV_PATCH}
+ git checkout -q $branch || die
+
+ # All config options to off
+ sed "s:= y:=:g" -i config.mk || die
+
+ set_config RDU BRANCH_MAX_127 SBILIST
+
+ use debug && set_config DEBUG
+ use fuse && set_config BR_FUSE POLL
+ use hfs && set_config BR_HFSPLUS
+ use inotify && set_config HNOTIFY HFSNOTIFY
+ use nfs && set_config EXPORT
+ use nfs && use amd64 && set_config INO_T_64
+ use ramfs && set_config BR_RAMFS
+
+ if use hardened ; then
+ epatch "${FILESDIR}"/pax.patch
+ fi
+
+ sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
+ sed -i "s:__user::g" include/linux/aufs_type.h || die
+
+ cd "${WORKDIR}"/${PN}-util
+ git checkout -q origin/aufs2.1
+ sed -i "/LDFLAGS += -static -s/d" Makefile || die
+ sed -i -e "s:m 644 -s:m 644:g" -e "s:/usr/lib:/usr/$(get_libdir):g" libau/Makefile || die
+}
+
+src_compile() {
+ local ARCH=x86
+
+ emake CC=$(tc-getCC) CONFIG_AUFS_FS=m KDIR=${KV_DIR}
+
+ cd "${WORKDIR}"/${PN}-util
+ emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_DIR} C_INCLUDE_PATH="${S}"/include
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README
+ docinto design
+ dodoc design/*.txt
+ cd "${WORKDIR}"/${PN}-util
+ emake DESTDIR="${D}" KDIR=${KV_DIR} install
+ docinto
+ newdoc README README-utils
+}
diff --git a/sys-fs/aufs2/files/aufs2-base-39.patch b/sys-fs/aufs2/files/aufs2-base-39.patch
index 299697f18077..e98dc85a214f 100644
--- a/sys-fs/aufs2/files/aufs2-base-39.patch
+++ b/sys-fs/aufs2/files/aufs2-base-39.patch
@@ -1,10 +1,10 @@
-aufs2.1 base patch for linux-2.6.
+aufs2.1 base patch for linux-2.6.39
diff --git a/fs/namei.c b/fs/namei.c
-index e6cd611..27d7dc7 100644
+index e3c4f11..202d358 100644
--- a/fs/namei.c
+++ b/fs/namei.c
-@@ -1768,7 +1768,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
+@@ -1769,7 +1769,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/
diff --git a/sys-fs/aufs2/files/aufs2-standalone-39.patch b/sys-fs/aufs2/files/aufs2-standalone-39.patch
index 57dd820c24fa..777febabe1cf 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-39.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-39.patch
@@ -1,4 +1,4 @@
-aufs2.1 standalone patch for linux-2.6.
+aufs2.1 standalone patch for linux-2.6.39
diff --git a/fs/file_table.c b/fs/file_table.c
index 01e4c1e..0e800e2 100644
@@ -26,7 +26,7 @@ index 33c963d..e31e8d5 100644
/*
* iprune_sem provides exclusion between the icache shrinking and the
diff --git a/fs/namei.c b/fs/namei.c
-index 27d7dc7..3c72fd5 100644
+index 202d358..876010f 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -364,6 +364,7 @@ int deny_write_access(struct file * file)
@@ -37,7 +37,7 @@ index 27d7dc7..3c72fd5 100644
/**
* path_get - get a reference to a path
-@@ -1772,6 +1773,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
+@@ -1773,6 +1774,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
@@ -46,10 +46,10 @@ index 27d7dc7..3c72fd5 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
-index 7dba2ed..d7570d1 100644
+index d99bcf5..3ec2aa7 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
-@@ -1524,6 +1524,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
+@@ -1508,6 +1508,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@@ -172,7 +172,7 @@ index 8d9c48f..29108aa 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
-index 1011423..3bb850b 100644
+index 4ba6d4c..9f64bb8 100644
--- a/security/security.c
+++ b/security/security.c
@@ -373,6 +373,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
@@ -233,13 +233,13 @@ index 1011423..3bb850b 100644
{
@@ -520,6 +527,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
- return security_ops->inode_permission(inode, mask);
+ return security_ops->inode_permission(inode, mask, 0);
}
+EXPORT_SYMBOL(security_inode_permission);
int security_inode_exec_permission(struct inode *inode, unsigned int flags)
{
-@@ -628,6 +636,7 @@ int security_file_permission(struct file *file, int mask)
+@@ -626,6 +634,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@@ -247,7 +247,7 @@ index 1011423..3bb850b 100644
int security_file_alloc(struct file *file)
{
-@@ -655,6 +664,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
+@@ -653,6 +662,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
return ret;
return ima_file_mmap(file, prot);
}