summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-11-09 09:16:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-11-09 09:16:25 +0000
commitde67d21fd1417aa9d40ea775a796f90ec612f11f (patch)
tree5f73292c8099e1e66072694b0a73c11b6a42b725 /sys-freebsd
parentbump to 9.2 (diff)
downloadgentoo-2-de67d21fd1417aa9d40ea775a796f90ec612f11f.tar.gz
gentoo-2-de67d21fd1417aa9d40ea775a796f90ec612f11f.tar.bz2
gentoo-2-de67d21fd1417aa9d40ea775a796f90ec612f11f.zip
bump to 9.2
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-contrib/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-contrib/freebsd-contrib-9.2.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-contrib/ChangeLog b/sys-freebsd/freebsd-contrib/ChangeLog
index e9a05a455df3..cb23357bb3ed 100644
--- a/sys-freebsd/freebsd-contrib/ChangeLog
+++ b/sys-freebsd/freebsd-contrib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-contrib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.48 2013/08/26 20:42:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.49 2013/11/09 09:16:25 aballier Exp $
+
+*freebsd-contrib-9.2 (09 Nov 2013)
+
+ 09 Nov 2013; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-contrib-9.2.ebuild:
+ bump to 9.2
*freebsd-contrib-9.2_rc3 (26 Aug 2013)
diff --git a/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2.ebuild b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2.ebuild
new file mode 100644
index 000000000000..810160adfa3c
--- /dev/null
+++ b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2.ebuild,v 1.1 2013/11/09 09:16:25 aballier Exp $
+
+inherit bsdmk freebsd flag-o-matic multilib
+
+DESCRIPTION="Contributed sources for FreeBSD."
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+ SRC_URI="mirror://gentoo/${GNU}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+fi
+LICENSE="BSD GPL-2+ libodialog"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-sources-${RV}*
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+S="${WORKDIR}/gnu"
+
+src_compile() {
+ cd "${S}/lib/libodialog"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/sort"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/patch"
+ freebsd_src_compile
+}
+
+src_install() {
+ use profile || mymakeopts="${mymakeopts} NO_PROFILE= "
+ mymakeopts="${mymakeopts} NO_MANCOMPRESS= NO_INFOCOMPRESS= "
+
+ cd "${S}/lib/libodialog"
+ mkinstall LIBDIR="/usr/$(get_libdir)" || die "libodialog install failed"
+
+ cd "${S}/usr.bin/sort"
+ mkinstall BINDIR="/bin/" || die "sort install failed"
+
+ cd "${S}/usr.bin/patch"
+ mkinstall BINDIR="/usr/bin/" || die "patch install failed"
+}