summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-22 15:46:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-22 15:46:10 +0000
commit4cccfc781b65a4fea88297c142737f1c1898789a (patch)
tree52180b32c97eb35a35b8110908f64b7161ef8fee /sys-freebsd/freebsd-rescue
parentbump to rc2 (diff)
downloadgentoo-2-4cccfc781b65a4fea88297c142737f1c1898789a.tar.gz
gentoo-2-4cccfc781b65a4fea88297c142737f1c1898789a.tar.bz2
gentoo-2-4cccfc781b65a4fea88297c142737f1c1898789a.zip
bump to rc2
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd/freebsd-rescue')
-rw-r--r--sys-freebsd/freebsd-rescue/ChangeLog9
-rw-r--r--sys-freebsd/freebsd-rescue/freebsd-rescue-9.2_rc2.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/sys-freebsd/freebsd-rescue/ChangeLog b/sys-freebsd/freebsd-rescue/ChangeLog
index b1b4dd740928..db7b29102371 100644
--- a/sys-freebsd/freebsd-rescue/ChangeLog
+++ b/sys-freebsd/freebsd-rescue/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-rescue
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-rescue/ChangeLog,v 1.38 2013/08/11 19:45:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-rescue/ChangeLog,v 1.39 2013/08/22 15:46:10 aballier Exp $
+
+*freebsd-rescue-9.2_rc2 (22 Aug 2013)
+
+ 22 Aug 2013; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-rescue-9.2_rc2.ebuild:
+ bump to rc2
*freebsd-rescue-9.2_rc1 (11 Aug 2013)
@@ -223,4 +229,3 @@
+files/freebsd-rescue-5.4-gentoo.patch,
+files/freebsd-rescue-5.4-sbin-gentoo.patch, +freebsd-rescue-5.4.ebuild:
Added freebsd-rescue package that builds /rescue binaries.
-
diff --git a/sys-freebsd/freebsd-rescue/freebsd-rescue-9.2_rc2.ebuild b/sys-freebsd/freebsd-rescue/freebsd-rescue-9.2_rc2.ebuild
new file mode 100644
index 000000000000..2ea211b521bf
--- /dev/null
+++ b/sys-freebsd/freebsd-rescue/freebsd-rescue-9.2_rc2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-rescue/freebsd-rescue-9.2_rc2.ebuild,v 1.1 2013/08/22 15:46:10 aballier Exp $
+
+EAPI=5
+
+inherit bsdmk freebsd toolchain-funcs
+
+DESCRIPTION="FreeBSD's rescue binaries"
+SLOT="0"
+LICENSE="BSD zfs? ( CDDL )"
+
+IUSE="atm netware nis zfs"
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64-fbsd ~x86-fbsd"
+ SRC_URI="mirror://gentoo/${UBIN}.tar.bz2
+ mirror://gentoo/${CONTRIB}.tar.bz2
+ mirror://gentoo/${LIB}.tar.bz2
+ mirror://gentoo/${BIN}.tar.bz2
+ mirror://gentoo/${SBIN}.tar.bz2
+ mirror://gentoo/${USBIN}.tar.bz2
+ mirror://gentoo/${GNU}.tar.bz2
+ mirror://gentoo/${SYS}.tar.bz2
+ mirror://gentoo/${LIBEXEC}.tar.bz2
+ mirror://gentoo/${RESCUE}.tar.bz2
+ zfs? ( mirror://gentoo/${CDDL}.tar.bz2 )"
+fi
+
+RDEPEND=""
+DEPEND="sys-devel/flex
+ app-arch/xz-utils[static-libs]
+ sys-libs/ncurses[static-libs]
+ dev-libs/expat[static-libs]
+ app-arch/bzip2[static-libs]
+ dev-libs/libedit[static-libs]
+ dev-libs/libxml2:2[static-libs]
+ dev-libs/openssl[static-libs]
+ sys-libs/zlib[static-libs]
+ sys-libs/readline[static-libs]
+ =sys-freebsd/freebsd-lib-${RV}*[atm?,netware?]
+ =sys-freebsd/freebsd-sources-${RV}*
+ =sys-freebsd/freebsd-mk-defs-${RV}*
+ zfs? ( =sys-freebsd/freebsd-cddl-${RV}* )"
+
+S="${WORKDIR}/rescue"
+
+pkg_setup() {
+ use atm || mymakeopts="${mymakeopts} WITHOUT_ATM= "
+ use netware || mymakeopts="${mymakeopts} WITHOUT_IPX= "
+ use nis || mymakeopts="${mymakeopts} WITHOUT_NIS= "
+ use zfs || mymakeopts="${mymakeopts} WITHOUT_CDDL= "
+ mymakeopts="${mymakeopts} NO_PIC= "
+}
+
+src_prepare() {
+ # As they are patches from ${WORKDIR} apply them by hand
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${PN}"-7.1-zlib.patch
+ epatch "${FILESDIR}/freebsd-sbin-bsdxml2expat.patch"
+}
+
+src_compile() {
+ tc-export CC
+ # crunchgen is now checks env MAKE.
+ # Use to force BSD's make
+ export MAKE=/usr/bin/make
+
+ cd "${WORKDIR}/lib/libarchive"
+ echo "#include <expat.h>" > bsdxml.h
+ freebsd_src_compile
+ export CC="${CC} -L${WORKDIR}/lib/libarchive"
+
+ cd "${S}"
+ freebsd_src_compile
+}