summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-03-19 11:51:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-03-19 11:51:07 +0000
commitbbf334e5c06d8676968eb2327d560d97c76a4523 (patch)
treee2be7c9800aa6fed357f9dda0d7c5f9d20357b13 /sys-freebsd/freebsd-contrib
parentFix bug 293374 and sync with fedora to solve other issues (diff)
downloadgentoo-2-bbf334e5c06d8676968eb2327d560d97c76a4523.tar.gz
gentoo-2-bbf334e5c06d8676968eb2327d560d97c76a4523.tar.bz2
gentoo-2-bbf334e5c06d8676968eb2327d560d97c76a4523.zip
bump to 8.0 from the bsd overlay
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd/freebsd-contrib')
-rw-r--r--sys-freebsd/freebsd-contrib/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-contrib/freebsd-contrib-8.0.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-contrib/ChangeLog b/sys-freebsd/freebsd-contrib/ChangeLog
index 23b621e9ffbd..9854382832b3 100644
--- a/sys-freebsd/freebsd-contrib/ChangeLog
+++ b/sys-freebsd/freebsd-contrib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-contrib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.26 2010/03/11 10:57:55 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.27 2010/03/19 11:50:58 aballier Exp $
+
+*freebsd-contrib-8.0 (19 Mar 2010)
+
+ 19 Mar 2010; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-contrib-8.0.ebuild:
+ bump to 8.0 from the bsd overlay
11 Mar 2010; Alexis Ballier <aballier@gentoo.org>
-freebsd-contrib-6.2.ebuild, -freebsd-contrib-7.1.ebuild:
diff --git a/sys-freebsd/freebsd-contrib/freebsd-contrib-8.0.ebuild b/sys-freebsd/freebsd-contrib/freebsd-contrib-8.0.ebuild
new file mode 100644
index 000000000000..ba68a9bbf27d
--- /dev/null
+++ b/sys-freebsd/freebsd-contrib/freebsd-contrib-8.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/freebsd-contrib-8.0.ebuild,v 1.1 2010/03/19 11:50:58 aballier Exp $
+
+inherit bsdmk freebsd flag-o-matic
+
+DESCRIPTION="Contributed sources for FreeBSD."
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+LICENSE="BSD GPL-2 as-is"
+
+IUSE=""
+
+SRC_URI="mirror://gentoo/${GNU}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-sources-${RV}*
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+S="${WORKDIR}/gnu"
+
+src_unpack() {
+ echo ">>> Unpacking needed parts of ${GNU}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${GNU}.tar.bz2" gnu/lib/libdialog gnu/usr.bin/sort gnu/usr.bin/patch
+ echo ">>> Unpacking needed parts of ${CONTRIB}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${CONTRIB}.tar.bz2" contrib/gnu-sort
+
+ freebsd_do_patches
+ freebsd_rename_libraries
+}
+
+src_compile() {
+ cd "${S}/lib/libdialog"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/sort"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/patch"
+ freebsd_src_compile
+}
+
+src_install() {
+ use profile || mymakeopts="${mymakeopts} NO_PROFILE= "
+ mymakeopts="${mymakeopts} NO_MANCOMPRESS= NO_INFOCOMPRESS= "
+
+ cd "${S}/lib/libdialog"
+ mkinstall || die "libdialog install failed"
+
+ cd "${S}/usr.bin/sort"
+ mkinstall BINDIR="/bin/" || die "libdialog install failed"
+
+ cd "${S}/usr.bin/patch"
+ mkinstall BINDIR="/usr/bin/" || die "libdialog install failed"
+}